What might I be doing wrong?

Tips and Techniques for using MLServer's Automation Rules
jackpod
Intermediate
Intermediate
Posts: 442
Joined: Sat Oct 22, 2005 8:26 pm
Contact:

What might I be doing wrong?

Postby jackpod » Mon Apr 02, 2007 9:44 am

I have several automation rules that push mlserver variables to Homeseer for event triggers, TTS of the variables and now recently to my BetaBrite LED sign. For example I have the mlweather_temp_description working fine. I also have an automation rule based on when xmcurrentsong changes value to send all of the "XM" variables to HS and in turn to my BetaBrite, this also works great....

But when I try to do the same thing with MusicLobby variables, they never get to hs. Now on a couple of my scenes I use the var mlmediacenter_server_zone1_curtitle and it works.

This works for XM

whenever xmcurrentsong changes value
then MLServecmd.mlhsplugin|hs_setdevicestring:m21~{{xmcurrentsong}}

But this will not work for MUL
whenever mlmediacenter_melody_zone1_curtitle changes value
then MLServecmd.mlhsplugin|hs_setdevicestring:m31~{{mlmediacenter_melody_zone1_curtitle}}

Its making me crazy as to why this won't work. And yes the variables are subcribed in the MLHSPlugin. I even tried creating a ML Variable and I can't get it to update from th MUL variable

:?: :?:

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Postby mcascio » Mon Apr 02, 2007 9:48 am

Couple things I would start with to begin debugging:

1) Swap xmcurrentsong to hs_setdevicestring:m31 with the MuL variable.
That will help us learn whether the issue resides on the HS side or MLServer side.

2) Not sure, but you may have to make sure the m31 is subscribed via the MLHSPlugin.

3) Try taking MLHS out of the picture and just open Notepad when the MuL variable changes: MLServeCmd.MLFileOpen|notepad

4) Check for spelling errors

5) Verify in MLServer's variable list that the variable in question is in fact changing.
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

jackpod
Intermediate
Intermediate
Posts: 442
Joined: Sat Oct 22, 2005 8:26 pm
Contact:

Postby jackpod » Mon Apr 02, 2007 8:20 pm

Hi Mario,

Ok here is what I did. The rule that works for XMLobby, I changed to {{mlmediacenter_melody_zone1_curtitle}} (melody is the servername this server has mlserver and J river on it)

I changed the rule for Musiclobby to show {{xmcurrentsong}}

The musiclobby rule shows the correct value for xmradio, the xmlobby rule that now has {{mlmediacenter_melody_zone1_curtitle}} shows unknown.

The HS variable is selected in MLHSplugin. From MLHSplugin HS side it shows the variable as blank "" in the incoming queue window

One of my ML scenes has current artist, title and album for all 5 zones that I use. It shows the mlmediacenter_melody_zone1_curtitle (and curalbum and curartist) correctly

I tried creating a mlserver variable, named it z1title, used the same rule and it would not update either. It is like for some reason MUL will not let you take the variable info and put it in a different variable. I will try the notepad suggestion, altho I have never done that before

Thanks

Jack

jackpod
Intermediate
Intermediate
Posts: 442
Joined: Sat Oct 22, 2005 8:26 pm
Contact:

Postby jackpod » Tue Apr 03, 2007 9:46 am

Mario, I have never used the mlfileopen command, but if I set a rule for whenever {{mlmediacenter_melody_zone1_curtitle}} changes value then mlservecmd.mlfileopen|notepad, it opens notepad

jackpod
Intermediate
Intermediate
Posts: 442
Joined: Sat Oct 22, 2005 8:26 pm
Contact:

Postby jackpod » Fri Apr 06, 2007 7:58 pm

Any ideas on this?

Jack

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Fri Apr 06, 2007 8:05 pm

jackpod,
In musicLobby server (in J. River Plugins list), there is a line to trigger a MLServeCmd on song change - would that help?
I use it with MLLyrics to pass artist name / song name for Lyrics lookup when the song changes.

jackpod
Intermediate
Intermediate
Posts: 442
Joined: Sat Oct 22, 2005 8:26 pm
Contact:

Postby jackpod » Fri Apr 06, 2007 8:45 pm

Smoothtlk, I'll give that a try. Thanks for the suggestion

Jack


Return to “Automation Rules”

Who is online

Users browsing this forum: No registered users and 1 guest