3808CI Support?

DemonFox
Newbie
Newbie
Posts: 22
Joined: Wed Jan 02, 2008 5:55 pm
Contact:

3808CI Support?

Postby DemonFox » Tue Jan 29, 2008 4:37 pm

I just purchased this plug-in assuming it supported my new 3808 but is that not the case? The documentation only calls out a couple of the models of Denons. I thought the interface was well published and pretty standard between the models?

On a different note I am unable to use the plugin at all. It apparently needs MLDeviceManager so I went and grabbed that, but whenever I tried to add a device to that plugin I get some funky visual basic error.

Comparing the ease of setup to the FREE 3rd party PioneerVSX which I had working in about 30 mins to this... not a happy comparison.

digitaltrader
Senior Member
Senior Member
Posts: 205
Joined: Sat Jan 10, 2004 2:15 pm
Contact:

Postby digitaltrader » Tue Jan 29, 2008 8:20 pm

I was considering an upgrade to the 4308CI and am disappointed to hear the plugin doesn't work.
Last edited by digitaltrader on Tue Jan 29, 2008 10:01 pm, edited 1 time in total.

User avatar
bhiga
Expert
Expert
Posts: 854
Joined: Tue Mar 08, 2005 10:28 pm
Location: San Jose, CA
Contact:

Postby bhiga » Tue Jan 29, 2008 9:06 pm

DemonFox - what version of MLServer are you running?

If you have a recent version, Additional Software Updates should bring up MLInstaller which will help you get everything up to date.
- Brandon
My MainLobby stuff (plug-ins, screenshots, etc)

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Tue Jan 29, 2008 9:17 pm

The interface has not been "standard". I don't think that exists anywhere.

There is a later plugin that has not been released yet. We are putting things together to beta release it. That has much better odds of supporting the later Denon receivers.

It doesn't sound like you installed the current one as it sounds like you installed the driver, and then the plugin. Start by installing MLDeviceManager, and then the Denon driver that you downloaded from the registered user's website. You then go into the MLDevice Manager plugin and add the Denon driver. If this doesn't work, then delete all software components from MLDeviceManager folder and do the installation again.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Tue Jan 29, 2008 11:21 pm

The latest version of the Denon plugin does support the 3808. I am making some changes to the plugin to assist users in the transation from the old verion to the new version. The new version will be released to beta users tomorrow.

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Postby mcascio » Wed Jan 30, 2008 9:51 am

DemonFox,

There have been two generations of the Denon plugin. The first one used MLDeviceManager but the second does not.

So you should just double click on the MLDenon plugin for configuration.
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Wed Jan 30, 2008 9:57 am

There are three generations of Denon. The two mario mentioned and the third which will be released to beta very soon.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Wed Jan 30, 2008 2:47 pm

A new version, the third generation, of the MLDenon plugin is now available for download in the beta area. Look for version 3.0.140. This version of the plugin adds support for multiple Denon receivers and makes the plugin a member of the AV family of devices.

Before using this plugin you must define at least one device. After that the syntax for sending commands becomes

MLDenon|<<device ID or Alias>>~<<command>>~<<parameter ...>>

or

AV.<<device ID or Alias>>|<<command>>~<<parameter ...>>

This plugin will also support backwards compatibility with previous versions where the device id or alias is not present. If the plugin receives a command with no valid device ID or alias in the command then it will default to using the first device in the list. So, in theory all existing scenes using legacy MLDenon commands should work. Please be aware of this change in the plugin syntax and move all your scenes to the new syntax.

This plugin should respond to the 3808 and 5808 command sets. It has been tested to work with a 3808ci.
Last edited by CinemarDave on Thu Jan 31, 2008 4:23 pm, edited 1 time in total.

DemonFox
Newbie
Newbie
Posts: 22
Joined: Wed Jan 02, 2008 5:55 pm
Contact:

Postby DemonFox » Thu Jan 31, 2008 3:56 pm

Thanks for all the responses guys! I had taken a couple days off from MainLobby hacking but I will try out all your suggestions / instructions.

I was using what I thought was the latest pay MLDenon which supports multiple receivers and I had updated my MLServer to the latest as of this last Saturday. I will double check all my versions and install things in the correct order.

Once again thanks for the responses.

fnkpet
Expert
Expert
Posts: 632
Joined: Sun Nov 30, 2003 1:20 pm
Location: Charlotte, NC
Contact:

Postby fnkpet » Sun Feb 24, 2008 7:13 pm

This plugin should respond to the 3808 and 5808 command sets. It has been tested to work with a 3808ci


I have just purchased a 4306ci.

Note the plugin will work with setting the videoselect to SAT but will not work to set it to VCR.

In the 4306ci there is no VCR1, VCR2, VCR3. It is just VCR and that command does not work.

Can you add a VideoSelect for VCR please?

Frank

User avatar
rpalori
Member
Member
Posts: 82
Joined: Thu Jan 27, 2005 10:13 pm
Location: Houston, TX
Contact:

Postby rpalori » Wed Jul 30, 2008 10:54 pm

CinemarDave wrote:A new version, the third generation, of the MLDenon plugin is now available for download in the beta area. Look for version 3.0.140. This version of the plugin adds support for multiple Denon receivers and makes the plugin a member of the AV family of devices.

Before using this plugin you must define at least one device. After that the syntax for sending commands becomes

MLDenon|<<device ID or Alias>>~<<command>>~<<parameter ...>>

or

AV.<<device ID or Alias>>|<<command>>~<<parameter ...>>

This plugin will also support backwards compatibility with previous versions where the device id or alias is not present. If the plugin receives a command with no valid device ID or alias in the command then it will default to using the first device in the list. So, in theory all existing scenes using legacy MLDenon commands should work. Please be aware of this change in the plugin syntax and move all your scenes to the new syntax.

This plugin should respond to the 3808 and 5808 command sets. It has been tested to work with a 3808ci.



Dave I have been having alot of issues with this plugin. I bought a 3808ci because it says it is suported by MLDenon plugin. The problems I am having is some not all of the commands work my 3808ci.

MLDenon|001~ZoneSource~1~TV not working
MLDenon|001~ZoneSource~1~VCR1 not working
MLDenon|001~ZoneSource~1~CDRTAPE not working


All the tuner preset and channel up/down commands not working
Plus there is more commands not listed that are not responding

My biggest problem is the ZoneSource~1~TV is not responding. I need a quick fix PLEASE!!

I am controlling this device thru the network on port 23


Ryan

fnkpet
Expert
Expert
Posts: 632
Joined: Sun Nov 30, 2003 1:20 pm
Location: Charlotte, NC
Contact:

Postby fnkpet » Thu Jul 31, 2008 9:11 am

I have the same issues with the 4308ci, and agree the biggest ones are that some of the source selects do not work.

I have gotten 'away with it' as I just have 3 or 4 things hooked into it and use the ones that I can control but it does need to get fixed.

Frank

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

New Models On The Way

Postby T.Wells » Thu Jul 31, 2008 10:04 am

I may be getting a new Denon for the family room and have been thinking about the Denon plug-in.

The comments regarding issues for the xx08 models is very concerning. Especially because the xx09's are starting to hit the stores now. The 2309's are already sold out at Amazon.

-T

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Thu Jul 31, 2008 12:16 pm

Can someone that is having trouble post what MLServeCmd they are sending, a MLServer log capturing that transaction, and and MLDenon log for that transaction.

This is what is needed to see exactly what it is / isn't doing.

We don't have the hardware to replicate the problem.

It's probably a quick fix as the data isn't being read / sent appropriately for that transaction. Need the detail to determine.

User avatar
rpalori
Member
Member
Posts: 82
Joined: Thu Jan 27, 2005 10:13 pm
Location: Houston, TX
Contact:

Postby rpalori » Thu Jul 31, 2008 3:09 pm

DavidL

Yep I have some logs I created real quick trying to control my 3808ci.


I hope this helps to get this plugin working. I will send you some more logs if needed, let me know.



Ryan
You do not have the required permissions to view the files attached to this post.


Return to “Denon”

Who is online

Users browsing this forum: No registered users and 1 guest