MLirrigation trigger - are these all fast mode?

Post here issues and solutions that relate to MainLobby Server 3
Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

MLirrigation trigger - are these all fast mode?

Postby Art Dustman » Mon Jul 25, 2011 2:53 pm

I need a trigger when the irrigation starts running to run my fertilizer program, as well as something to check if it is still running as the macro sequence loops. I started an automation rule that simply checks to see if the MLirrigation program status changes value, but the server misses that, maybe it updates fast mode?
Any thoughts? I need to see when the the irrigation system starts, regardless of how, have some flag/variable to know it is still running, and ideally a trigger when it is "complete." Thanks

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: MLirrigation trigger - are these all fast mode?

Postby ronsatter » Mon Jul 25, 2011 10:14 pm

Art Dustman wrote:I need a trigger when the irrigation starts running to run my fertilizer program, as well as something to check if it is still running as the macro sequence loops. I started an automation rule that simply checks to see if the MLirrigation program status changes value, but the server misses that, maybe it updates fast mode?
Any thoughts? I need to see when the the irrigation system starts, regardless of how, have some flag/variable to know it is still running, and ideally a trigger when it is "complete." Thanks


Hi Art,

I don't use MLirrigation. That being said, I would be quite surprised if the plugin was written to update variables in fast mode. Usually, Dave codes an option in the settings panel for fast mode, but default mode is normal. Sometimes server rules won't kick in until you reboot the server. I've had that experience before.

So much for guessing ... :roll:

Ron
If it ain't broke ... don't fix it!

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: MLirrigation trigger - are these all fast mode?

Postby Art Dustman » Tue Jul 26, 2011 7:01 am

I have rebooted several times for other reasons over the last few weeks, but to no avail. I'll take a closer look and see.

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Re: MLirrigation trigger - are these all fast mode?

Postby mcascio » Tue Jul 26, 2011 12:41 pm

Posting your existing rule might prove helpful in debugging the issue. I don't "believe" the varibles update in fast mode...but there is a lot going on, so it is a possiblity.
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: MLirrigation trigger - are these all fast mode?

Postby Art Dustman » Tue Jul 26, 2011 1:24 pm

I can't copy the text, so here is verbatim:

Whenever mlirrigation_active_program_status changes value
Then Fertigator.Startup.sequence

Or
Whenever mlirrigation_active_program_status changes value
Then Setvariable|mlirrigation_fertigator_trigger~changed


Or
Whenever mlirrigation_active_progtimerremainingmin changes value
Then Setvariable|mlirrigation_fertigator_trigger~changed


All no go...

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLirrigation trigger - are these all fast mode?

Postby CinemarDave » Sat Jul 30, 2011 10:41 am

The MLIrrigation Family plugin was setting variables in "fast" mode so no automation events were being triggered. Version 3.99.3 of the MLIrrigation Family plugin now sets variables in normal mode so it will trigger the automation events.


Return to “MLServer 3”

Who is online

Users browsing this forum: No registered users and 2 guests