Periodic MLServer Crash

Post here issues and solutions that relate to MainLobby Server 3
User avatar
itanic
Intermediate
Intermediate
Posts: 455
Joined: Tue Jun 15, 2004 10:05 am
Location: Oregon
Contact:

Periodic MLServer Crash

Postby itanic » Thu Mar 10, 2011 10:29 am

A month or so ago my MLServer Computer crashed. I've replaced it and followed the instructions for reinstalling MLServer from a backup with new activivation codes. Over the past two weeks since the reinstall, MLServer will periodiclly crash and need to be restarted. Sometimes it's up for an hour, sometimes for several hours - but never more that a day.

There does not seems to be any consistency or pattern in when it crashes. I've unloded the vast majory of any plugins in an attemt to isolate the issues without luck. I don't see anything in the log that is unusual so I'm stuck on what to do next. I'm using MLServer 3.75.221.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Periodic MLServer Crash

Postby CinemarDave » Thu Mar 10, 2011 11:19 am

Crash how? With a Windows report? Or does it just go away? If it just goes away are you using Watchdog? If so are the watchdog settings too low? Need more data.

User avatar
itanic
Intermediate
Intermediate
Posts: 455
Joined: Tue Jun 15, 2004 10:05 am
Location: Oregon
Contact:

Re: Periodic MLServer Crash

Postby itanic » Thu Mar 10, 2011 12:36 pm

When running it will say (listening) in the upper left corner of the screen. This changes to (not responding) when it crashes and the screen is otherwise blank. I have to force a close and restart. I was not using watchdog and I don't see anything unusual in the MLServer log to indicate why it stops responding.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Periodic MLServer Crash

Postby CinemarDave » Thu Mar 10, 2011 1:17 pm

then the most likely cause it a plugin that has gone into an infinite loop. what plugins are loaded?

User avatar
itanic
Intermediate
Intermediate
Posts: 455
Joined: Tue Jun 15, 2004 10:05 am
Location: Oregon
Contact:

Re: Periodic MLServer Crash

Postby itanic » Thu Mar 10, 2011 1:31 pm

See attached.
You do not have the required permissions to view the files attached to this post.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Periodic MLServer Crash

Postby CinemarDave » Thu Mar 10, 2011 3:20 pm

That's a pretty benign set of plugins. None of them jump out at me as suspect.

User avatar
itanic
Intermediate
Intermediate
Posts: 455
Joined: Tue Jun 15, 2004 10:05 am
Location: Oregon
Contact:

Re: Periodic MLServer Crash

Postby itanic » Thu Mar 10, 2011 3:59 pm

CinemarDave wrote:That's a pretty benign set of plugins. None of them jump out at me as suspect.


So now what do I do?

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Re: Periodic MLServer Crash

Postby mcascio » Thu Mar 10, 2011 4:42 pm

Are you using MLSiders?

Can you unregister MLHSPlugin for the day to see if that's it?
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

User avatar
itanic
Intermediate
Intermediate
Posts: 455
Joined: Tue Jun 15, 2004 10:05 am
Location: Oregon
Contact:

Re: Periodic MLServer Crash

Postby itanic » Thu Mar 10, 2011 4:50 pm

Done. We will wait and see

User avatar
itanic
Intermediate
Intermediate
Posts: 455
Joined: Tue Jun 15, 2004 10:05 am
Location: Oregon
Contact:

Re: Periodic MLServer Crash

Postby itanic » Mon Mar 14, 2011 9:41 am

Well, it does appear that the MLHSPlugin is causing the crashes. Without the plugin running - no crashes for over 24 hours. With the plugin - only lasts a couple of hours. Tried to reinstall the plugin and only enable a few devices but still crashes. Now what?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Periodic MLServer Crash

Postby CinemarDave » Mon Mar 14, 2011 10:54 am

That one is out of our hands since we do not have source code for that. The plugin is merely a conduit for sending Homeseer data back and forth. My guess is that there is something in that data stream that the plugin does not anticipate and it causes the plugin to crash. Crumpy will have to comment on this.

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Re: Periodic MLServer Crash

Postby mcascio » Mon Mar 14, 2011 11:19 am

Try to think back as to when the crashes starting occuring. Perhaps you added a device that has a unique character in it since then. I thought the MLHSPlugin supported changed the character device names at some point. Otherwise look at other plugins that you've added to HomeSeer.
Mario Cascio

Cinemar, Inc.

http://www.cinemaronline.com

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: Periodic MLServer Crash

Postby DavidL » Mon Mar 14, 2011 8:49 pm

There is a windows component that was suspect...see Homeseer's MLHSPlugin forum for details....don't remember the info off the top.


Return to “MLServer 3”

Who is online

Users browsing this forum: No registered users and 1 guest