Clean Install - ML Server Crashes

Post here issues and solutions that relate to MainLobby Server 3
Clever1
Senior Member
Senior Member
Posts: 220
Joined: Mon Jan 14, 2008 10:31 am
Location: Huntsville, AL.
Contact:

Re: Clean Install - ML Server Crashes

Postby Clever1 » Tue Aug 03, 2010 2:45 pm

Is there a status update on this thread? I was experiencing the same issue and just conduct a clean install the other day. No issues yet with the fresh system but am interested in what to watch for.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Clean Install - ML Server Crashes

Postby CinemarDave » Tue Aug 03, 2010 2:58 pm

The problems reported earlier in this thread were due to a third party plugin with a memory leak. Due to the memory leak MLServer eventually exhausted memory resources and crashed. The third party plugin was updated to remove the memory leak. There are no known instability issues with MLServer or any Cinemar plugin.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Clean Install - ML Server Crashes

Postby DaveB » Tue Aug 03, 2010 5:45 pm

Which TPP was the guilty one? Can you share?
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Clean Install - ML Server Crashes

Postby CinemarDave » Tue Aug 03, 2010 5:54 pm

I believe it was the Tallus MLComDevice plugin. It was never purging its event log. If you had a chatty serial device it would eventually consume all available Windows memory.

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: Clean Install - ML Server Crashes

Postby DavidL » Tue Aug 03, 2010 6:35 pm

All Tallus MLComDevice versions since June have resolved any logging / memory issues.
All customers report it is running solid.

Clever1
Senior Member
Senior Member
Posts: 220
Joined: Mon Jan 14, 2008 10:31 am
Location: Huntsville, AL.
Contact:

Re: Clean Install - ML Server Crashes

Postby Clever1 » Tue Aug 03, 2010 9:49 pm

Great! Thank you for the update!

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Clean Install - ML Server Crashes

Postby DaveB » Tue Aug 03, 2010 9:52 pm

Maybe they were on an old version.

DavidL; I have had and issue with your plugins deciding if I was current or not. There is not automated way to determine this. You can use older versions without knowing that therre is an update. SOmething for you and Forcenor to look into.
Thanks!

Dave Bruner
:shock:

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: Clean Install - ML Server Crashes

Postby DavidL » Tue Aug 03, 2010 10:12 pm

Yes,
The easiest (which is not completely easy) is to check the Wiki for the product. At the bottom of that wiki page is the version history. If yours is older...update it by the link in the top of the same Wiki page (not the shopping cart).

And yes, they were on an older version (the one in the shopping cart).
We are removing download from the shopping cart to avoid these version control issues. All Tallus software is either free or licensed so we don't need to lock down the download ability to subscribed users.

So feel free to try any of the our latest versions!


Return to “MLServer 3”

Who is online

Users browsing this forum: No registered users and 1 guest