Clean Install - ML Server Crashes

Post here issues and solutions that relate to MainLobby Server 3
TheCodeMan
Senior Member
Senior Member
Posts: 204
Joined: Fri Sep 22, 2006 12:16 pm
Contact:

Clean Install - ML Server Crashes

Postby TheCodeMan » Tue Jan 12, 2010 2:56 pm

I just upgraded my servers to 2008 Enterprise. Performed a clean install of MLServer and a small handful of plugins, all fresh downloads. I get this error repeatedly in Event Viewer when trying to launch the application:

Faulting application MLServer.exe, version 3.75.0.78, time stamp 0x4afdd3f6, faulting module kernel32.dll, version 6.0.6002.18005, time stamp 0x49e037dd, exception code 0xc06d007e, fault offset 0x0003fbae, process id 0x1668, application start time 0x01ca93bf978de78c.

+ System

- Provider

[ Name] Application Error

- EventID 1000

[ Qualifiers] 0

Level 2

Task 100

Keywords 0x80000000000000

- TimeCreated

[ SystemTime] 2010-01-12T19:44:08.000Z

EventRecordID 21622

Channel Application

Computer admin2

Security


- EventData

MLServer.exe
3.75.0.78
4afdd3f6
kernel32.dll
6.0.6002.18005
49e037dd
c06d007e
0003fbae
1668
01ca93bf978de78c


Any suggestions on the possible problem?

Man, I have really regretted upgrading my servers to Windows 2008. Major problems all around, can't run Symantec Console, WSUS died, Problems with MLServer, Xboxes can't connect to network shares without ccXgui, the list just goes on and on.

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Re: Clean Install - ML Server Crashes

Postby mcascio » Tue Jan 12, 2010 6:48 pm

Not familiar with Windows 2008 Enterprise, but is there an option to turn off UAC?
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

TheCodeMan
Senior Member
Senior Member
Posts: 204
Joined: Fri Sep 22, 2006 12:16 pm
Contact:

Re: Clean Install - ML Server Crashes

Postby TheCodeMan » Fri Jan 15, 2010 6:54 pm

2008 Server does indeed have UAC. I disabled it and it still will not start. I also set the compatibility level to Windows XP and Windows 2003 and it will not start. I guess there is some underlying component in Cinemar or perhaps some 2008 security setting that makes it incompatible. Any other suggestions?

pendlet
Senior Member
Senior Member
Posts: 172
Joined: Thu Jun 26, 2003 2:11 am
Location: Maryland
Contact:

Mlserver Carashing

Postby pendlet » Sun Jan 17, 2010 7:31 pm

Mlserver is crashing on me too but i have windows 7. It runs good for a day or so but then crashes. Here is the event log.

Log Name: Application
Source: Application Error
Date: 1/17/2010 5:56:49 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Automation-PC
Description:
Faulting application name: MLServer.exe, version: 3.75.0.78, time stamp: 0x4afdd3f6
Faulting module name: KERNELBASE.dll, version: 6.1.7600.16385, time stamp: 0x4a5bdaae
Exception code: 0xe0434f4d
Fault offset: 0x00009617
Faulting process id: 0x1220
Faulting application start time: 0x01ca971c80ea36df
Faulting application path: C:\Program Files\MLServer\MLServer.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 97cd5d68-03bb-11df-8dff-001731f595d4


I am running windows seven 32bit and have uac turned off. I have the newest version of MLServer running with all the major plugins. DVD lobby, Muisic lobby, ETC. It all ways seems to crash when i am not around so i have no idea what it is doing when it crash's. I have also noticed that Mlserver is using alot of memory. Sometimes as much as 2.5 gig. Here are parts of my MlServer logs dureing the time of the last few crashes. As you can see its not douing much but loading the weather maps and updating DVD lobby stats so not sure why it would crash.


1/15/2010 7:36:49 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,493,598,720~20,362,235,904~1~104,855,834,624~1~19
1/15/2010 8:06:55 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,493,099,008~20,362,735,616~1~104,855,834,624~1~19
1/15/2010 8:27:29 PM Processing (1) Worker MLWeatherLobby|LoadXMLAdv~C:\Program Files\MLServer\Data\AdvUSMD0414.xml
1/15/2010 8:27:34 PM Processing (1) System SetVariable|MLWeather_map_1_url~http://AUTOMATION-PC:6246/images/MLWeather/map1.jpg?84383858
1/15/2010 8:27:37 PM Processing (1) System SetVariable|MLWeather_map_3_url~http://AUTOMATION-PC:6246/images/MLWeather/map3.jpg?84383858
1/15/2010 8:27:39 PM Processing (1) System SetVariable|MLWeather_map_5_url~http://AUTOMATION-PC:6246/images/MLWeather/map5.jpg?84383873
1/15/2010 8:27:42 PM Processing (1) System SetVariable|MLWeather_map_7_url~http://AUTOMATION-PC:6246/images/MLWeather/map7.jpg?84383889
1/15/2010 8:27:44 PM Processing (1) System SetVariable|MLWeather_map_9_url~http://AUTOMATION-PC:6246/images/MLWeather/map9.jpg?84383889
1/15/2010 8:27:47 PM Processing (1) System SetVariable|MLWeather_map_11_url~http://AUTOMATION-PC:6246/images/MLWeather/map11.jpg?84383904
1/15/2010 8:27:50 PM Processing (1) System SetVariable|MLWeather_map_2_url~http://AUTOMATION-PC:6246/images/MLWeather/map2.jpg?84383858
1/15/2010 8:27:52 PM Processing (1) System SetVariable|MLWeather_map_6_url~http://AUTOMATION-PC:6246/images/MLWeather/map6.jpg?84383873
1/15/2010 8:27:55 PM Processing (1) System SetVariable|MLWeather_map_10_url~http://AUTOMATION-PC:6246/images/MLWeather/map10.jpg?84383889
1/15/2010 8:27:57 PM Processing (1) System SetVariable|MLWeather_map_4_url~http://AUTOMATION-PC:6246/images/MLWeather/map4.jpg?84383873
1/15/2010 8:28:00 PM Processing (1) System SetVariable|MLWeather_map_12_url~http://AUTOMATION-PC:6246/images/MLWeather/map12.jpg?84383904
1/15/2010 8:28:00 PM Processing (1) System SetVariable|MLWeather_map_8_url~http://AUTOMATION-PC:6246/images/MLWeather/map8.jpg?84383889
1/15/2010 8:37:04 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,491,911,168~20,363,923,456~1~104,855,834,624~1~19
1/15/2010 9:07:13 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,492,255,232~20,363,579,392~1~104,855,834,624~1~19
1/15/2010 10:39:26 PM Server Socket Communications
1/15/2010 10:39:26 PM Server Loading variables
1/15/2010 10:39:27 PM Server Starting server
1/15/2010 10:39:27 PM Server SMTP Init
1/15/2010 10:39:27 PM Server Command Processor
1/15/2010 10:39:27 PM Server Getting Plug-Ins
1/15/2010 10:39:27 PM Server Loading Plugins



1/17/2010 3:35:51 PM Processing (1) System SetVariable|MLWeather_map_4_url~http://AUTOMATION-PC:6246/images/MLWeather/map4.jpg?239651996
1/17/2010 3:35:51 PM Processing (1) System SetVariable|MLWeather_map_10_url~http://AUTOMATION-PC:6246/images/MLWeather/map10.jpg?239652027
1/17/2010 4:05:20 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,520,931,328~20,334,903,296~1~104,855,834,624~1~19
1/17/2010 4:35:28 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,519,997,440~20,335,837,184~1~104,855,834,624~1~19
1/17/2010 4:35:38 PM Processing (1) Worker MLWeatherLobby|LoadXMLAdv~C:\Program Files\MLServer\Data\AdvUSMD0414.xml
1/17/2010 4:35:41 PM Processing (1) System SetVariable|MLWeather_map_1_url~http://AUTOMATION-PC:6246/images/MLWeather/map1.jpg?243271001
1/17/2010 4:35:44 PM Processing (1) System SetVariable|MLWeather_map_3_url~http://AUTOMATION-PC:6246/images/MLWeather/map3.jpg?243271016
1/17/2010 4:35:46 PM Processing (1) System SetVariable|MLWeather_map_5_url~http://AUTOMATION-PC:6246/images/MLWeather/map5.jpg?243271016
1/17/2010 4:35:49 PM Processing (1) System SetVariable|MLWeather_map_7_url~http://AUTOMATION-PC:6246/images/MLWeather/map7.jpg?243271032
1/17/2010 4:35:52 PM Processing (1) System SetVariable|MLWeather_map_9_url~http://AUTOMATION-PC:6246/images/MLWeather/map9.jpg?243271032
1/17/2010 4:35:54 PM Processing (1) System SetVariable|MLWeather_map_11_url~http://AUTOMATION-PC:6246/images/MLWeather/map11.jpg?243271047
1/17/2010 4:35:57 PM Processing (1) System SetVariable|MLWeather_map_2_url~http://AUTOMATION-PC:6246/images/MLWeather/map2.jpg?243271001
1/17/2010 4:35:59 PM Processing (1) System SetVariable|MLWeather_map_6_url~http://AUTOMATION-PC:6246/images/MLWeather/map6.jpg?243271016
1/17/2010 4:36:02 PM Processing (1) System SetVariable|MLWeather_map_10_url~http://AUTOMATION-PC:6246/images/MLWeather/map10.jpg?243271047
1/17/2010 4:36:04 PM Processing (1) System SetVariable|MLWeather_map_4_url~http://AUTOMATION-PC:6246/images/MLWeather/map4.jpg?243271016
1/17/2010 4:36:07 PM Processing (1) System SetVariable|MLWeather_map_12_url~http://AUTOMATION-PC:6246/images/MLWeather/map12.jpg?243271047
1/17/2010 4:36:07 PM Processing (1) System SetVariable|MLWeather_map_8_url~http://AUTOMATION-PC:6246/images/MLWeather/map8.jpg?243271032
1/17/2010 5:05:36 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,519,505,920~20,336,328,704~1~104,855,834,624~1~19
1/17/2010 5:35:42 PM Processing (1) System MLDVDLobby|UpdateStats~Server1~104,855,834,624~84,519,047,168~20,336,787,456~1~104,855,834,624~1~19
1/17/2010 5:35:51 PM Processing (1) Worker MLWeatherLobby|LoadXMLAdv~C:\Program Files\MLServer\Data\AdvUSMD0414.xml
1/17/2010 5:35:57 PM Processing (1) System SetVariable|MLWeather_map_1_url~http://AUTOMATION-PC:6246/images/MLWeather/map1.jpg?246885310
1/17/2010 5:35:58 PM Processing (1) System SetVariable|MLWeather_map_3_url~http://AUTOMATION-PC:6246/images/MLWeather/map3.jpg?246885310
1/17/2010 5:36:01 PM Processing (1) System SetVariable|MLWeather_map_5_url~http://AUTOMATION-PC:6246/images/MLWeather/map5.jpg?246885325
1/17/2010 5:36:03 PM Processing (1) System SetVariable|MLWeather_map_7_url~http://AUTOMATION-PC:6246/images/MLWeather/map7.jpg?246885325
1/17/2010 5:36:06 PM Processing (1) System SetVariable|MLWeather_map_9_url~http://AUTOMATION-PC:6246/images/MLWeather/map9.jpg?246885341
1/17/2010 5:36:09 PM Processing (1) System SetVariable|MLWeather_map_11_url~http://AUTOMATION-PC:6246/images/MLWeather/map11.jpg?246885357
1/17/2010 5:36:11 PM Processing (1) System SetVariable|MLWeather_map_2_url~http://AUTOMATION-PC:6246/images/MLWeather/map2.jpg?246885310
1/17/2010 5:36:14 PM Processing (1) System SetVariable|MLWeather_map_6_url~http://AUTOMATION-PC:6246/images/MLWeather/map6.jpg?246885325
1/17/2010 5:36:16 PM Processing (1) System SetVariable|MLWeather_map_10_url~http://AUTOMATION-PC:6246/images/MLWeather/map10.jpg?246885341
1/17/2010 5:36:19 PM Processing (1) System SetVariable|MLWeather_map_4_url~http://AUTOMATION-PC:6246/images/MLWeather/map4.jpg?246885325
1/17/2010 5:36:21 PM Processing (1) System SetVariable|MLWeather_map_12_url~http://AUTOMATION-PC:6246/images/MLWeather/map12.jpg?246885357
1/17/2010 5:36:21 PM Processing (1) System SetVariable|MLWeather_map_8_url~http://AUTOMATION-PC:6246/images/MLWeather/map8.jpg?246885341
1/17/2010 6:42:59 PM Server Socket Communications
1/17/2010 6:42:59 PM Server Loading variables
1/17/2010 6:42:59 PM Server Starting server
1/17/2010 6:43:00 PM Server SMTP Init
1/17/2010 6:43:00 PM Server Command Processor
1/17/2010 6:43:00 PM Server Getting Plug-Ins
1/17/2010 6:43:00 PM Server Loading Plugins



If you need mroe info or want a complet copy of the logs let me know.

Tim

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: Clean Install - ML Server Crashes

Postby DavidL » Sun Jan 17, 2010 7:52 pm

make sure you are using the latest mlweatherlobby (and all other plugins / software versions). That's the first place to start.

TheCodeMan
Senior Member
Senior Member
Posts: 204
Joined: Fri Sep 22, 2006 12:16 pm
Contact:

Re: Clean Install - ML Server Crashes

Postby TheCodeMan » Fri Jan 22, 2010 10:37 am

David or Mario,

Would either of you have time to remote in and take a look?
I made the mistake of upgrading my domain controllers to Windows 2008 without taking into consideration whether or not MLServer would run on 2008. I just assumed it would. The problem for me is I have only two servers and I want both to be domain controllers for redundancy. Windows 2003 cannot act as a domain controller once you raise the domain level. The only other option I have is to load 2003 Server and run VMWare server so I can have yet a 3rd server, 2008, acting as a domain controller running as a VM (not a very elegant solution).

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Clean Install - ML Server Crashes

Postby CinemarDave » Fri Jan 22, 2010 12:44 pm

Set up LogMeIn and send me the info. I'll remote in and look.

TheCodeMan
Senior Member
Senior Member
Posts: 204
Joined: Fri Sep 22, 2006 12:16 pm
Contact:

Re: Clean Install - ML Server Crashes

Postby TheCodeMan » Fri Jan 22, 2010 2:01 pm

I already have all my systems on LogMeIn so I'll get my router and RDP configured sometime over the weekend. No rush.

Thanks

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Clean Install - ML Server Crashes

Postby Art Dustman » Thu May 13, 2010 8:50 pm

Just Moved ML server to a new i5 system, and getting this same exact issue on Win 7, 64 bit, UAC off and latest updates. Can you tell me what the resolution was?

Thanks

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Clean Install - ML Server Crashes

Postby CinemarDave » Fri May 14, 2010 12:01 pm

Every instance it different. Almost always it is related to permissions. Set up LogMeIn and I'll look at it.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Clean Install - ML Server Crashes

Postby Art Dustman » Sun May 16, 2010 9:48 am

Dave,

Sent you a PM with the login info. Thanks!

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Clean Install - ML Server Crashes

Postby Art Dustman » Thu May 20, 2010 8:16 pm

Dave....U still there?

Gotta run the irrigation this weekend. Have you/Can you please have a look?

Thanks

:wink:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Clean Install - ML Server Crashes

Postby CinemarDave » Thu May 20, 2010 8:51 pm

yeah - I'll will make sure to get to your system on Friday.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Clean Install - ML Server Crashes

Postby Art Dustman » Fri May 21, 2010 6:19 am

Thanks...

Always appreciated. Licenses for the server move will be coming your way as well.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Clean Install - ML Server Crashes

Postby Art Dustman » Tue May 25, 2010 8:18 pm

Dave.. Did you get into my server? It's still crashing daily. Also, you will notice several key requests for the server move.
Thanks.

Art


Return to “MLServer 3”

Who is online

Users browsing this forum: No registered users and 1 guest