MLServer 3.75 Plugin Compatibility Notes

Post here issues and solutions that relate to MainLobby Server 3
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

MLServer 3.75 Plugin Compatibility Notes

Postby CinemarDave » Wed Jun 10, 2009 12:14 pm

When MLServer 3.75 is released you will also see a lot of plugins being updated to version 3.75 status also.

There are a few simple rules to follow when updating your plugins.

1) Any version of a plugin that is 3.75.x or greater will only work with MLServer 3.75.x or greater. The one exception to this rule is the DVDLobby plugin. DVDLobby 3.75.500 and greater will only run on MLServer 3.75.x

2) All previous versions of all of the plugins will work on MLServer 3.75.x. Meaning that MLServer is 100% backwards compatible with old plugins.

You do not need to rush out and update all your plugins just because the versions change.

The main differences in the 3.75.x versions of the plugins is that they are internally structured to work with MLServer and SQL Server when the time comes to make that switch. Along with that the 3.75.x versions of the plugins will begin to make use of the new MLWorker Agent process to offload time consuming tasks to the agent. When fully upgraded to all the 3.75 versions you should see better performance.
Last edited by CinemarDave on Wed Jun 10, 2009 2:14 pm, edited 1 time in total.

bigDvette
Expert
Expert
Posts: 718
Joined: Thu Oct 12, 2006 12:19 pm
Contact:

Re: MLServer 3.75 Plugin Compatibility Notes

Postby bigDvette » Wed Jun 10, 2009 2:07 pm

CinemarDave wrote:2) All previous versions of all of the plugins will work on MLServer 3.75.x. Meaning that all old plugins are 100% backwards compatible.


I get you point, but I think you mean MLServer 3.75.x is backwards compatible with old plugins, or old-plugins are forwards compatible with 3.75, but 3.75 plugins are not backwards compatible with MLServer versions before 3.75.x.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Wed Jun 10, 2009 2:14 pm

Correct I changed my wording. Thanks.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Wed Jun 10, 2009 8:40 pm

That is way too confusing. I need to go visit drink-lobby :D
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Wed Jun 10, 2009 9:23 pm

I'm just trying to get the simple point across that users should not expect to have version 3.75.x plugins work on MLServer 3.0.x. No other hidden meanings or agendas.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Wed Jun 10, 2009 9:30 pm

You probably should have made a simple rule; When the new version is released; you must upgrade if you want support. That would make life a bit easier for you and Mario.
Thanks!

Dave Bruner
:shock:

donburkard
Expert
Expert
Posts: 595
Joined: Sun Apr 13, 2008 7:06 pm
Location: Downingtown, PA
Contact:

Postby donburkard » Thu Jun 11, 2009 12:43 pm

And when do we think this will be released? Rough time frame that is.
Hooked on HighDef


Return to “MLServer 3”

Who is online

Users browsing this forum: No registered users and 1 guest