client service

Post in this thread issues and solution you find with the MainLobby 3 Client
Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

client service

Postby Art Dustman » Thu Mar 17, 2011 4:39 pm

I have always had my clients setup as follows:

alias ip port
pc1 192.168.1.x 6292
pc2 192.168.1.x 6293
pc3 192.168.1.x 6294


First is that correct? The wiki only shows an example of 1 pc.

Second, one of my clients continually gets a ping timout... any ideas?

Thanks

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: client service

Postby CinemarDave » Thu Mar 17, 2011 7:39 pm

No - You never have to change the port number. Use the same port number for all the ClientSvc agents. The IP Address is the unique value. If you are getting ping timeouts then the remote ClientSvc agent is not 1) seeing the ping request or 2) so busy it cannot respond to the ping. What does its event log show?

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: client service

Postby Art Dustman » Thu Mar 17, 2011 10:06 pm

It connects gets some variables, then drops... and repeats. Should it stay connected permanently?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: client service

Postby CinemarDave » Thu Mar 17, 2011 11:47 pm

Once connected it will stay connected.

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: client service

Postby DavidL » Fri Mar 18, 2011 6:41 am

should be:

pc1 192.168.1.3 6292
pc2 192.168.1.4 6292
pc3 192.168.1.5 6292

Make sure your firewall is accepting those IP addresses / ports and the server is setup on the clients for firewall access.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: client service

Postby Art Dustman » Fri Mar 18, 2011 7:11 am

Tried re-installing client service, no avail.
This was all working without issue, however I have not looked into any clients for about 2 weeks (last updated all plugins about 2 weeks ago or so)

Limited client service to 1 client. Disabled firewalls and AV -- no go
Went into MLSERVER, disabled ALL plugins except client service -- no go

Did a Ping -t from the server to client - no problems after 5 minutes (no loss)

here are my logs

3/18/2011 8:06:43 AM System SetVariable Mixer_Wave_Volume_GAMEROOM=80
3/18/2011 8:06:43 AM System SetVariable Mixer_Wave_Mute_GAMEROOM=0
3/18/2011 8:06:43 AM System SetVariable Mixer_WaveIn_Volume_GAMEROOM=80
3/18/2011 8:06:43 AM System SetVariable Mixer_WaveIn_Mute_GAMEROOM=0
3/18/2011 8:06:43 AM System SetVariable Mixer_LineIn_Volume_GAMEROOM=85
3/18/2011 8:06:43 AM System SetVariable Mixer_LineIn_Mute_GAMEROOM=0
3/18/2011 8:06:43 AM System SetVariable Mixer_Mic_Volume_GAMEROOM=25
3/18/2011 8:06:43 AM System SetVariable Mixer_Mic_Mute_GAMEROOM=1
3/18/2011 8:06:43 AM System SetVariable Mixer_CD_Volume_GAMEROOM=94
3/18/2011 8:06:43 AM System SetVariable Mixer_CD_Mute_GAMEROOM=0
3/18/2011 8:06:43 AM System SetVariable Mixer_Midi_Volume_GAMEROOM=100
3/18/2011 8:06:43 AM System SetVariable Mixer_Midi_Mute_GAMEROOM=0
3/18/2011 8:06:47 AM Logging Server Event Logging set to Verbose + Tracing
3/18/2011 8:06:48 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:06:48 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:06:50 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:06:50 AM System SetVariable ClientSvc_192.168.1.2_Connected=1
3/18/2011 8:06:53 AM System SetVariable Mixer_Wave_Volume_GAMEROOM=80
3/18/2011 8:06:53 AM System SetVariable Mixer_Wave_Mute_GAMEROOM=0
3/18/2011 8:06:53 AM System SetVariable Mixer_WaveIn_Volume_GAMEROOM=80
3/18/2011 8:06:53 AM System SetVariable Mixer_WaveIn_Mute_GAMEROOM=0
3/18/2011 8:06:53 AM System SetVariable Mixer_LineIn_Volume_GAMEROOM=85
3/18/2011 8:06:53 AM System SetVariable Mixer_LineIn_Mute_GAMEROOM=0
3/18/2011 8:06:53 AM System SetVariable Mixer_Mic_Volume_GAMEROOM=25
3/18/2011 8:06:53 AM System SetVariable Mixer_Mic_Mute_GAMEROOM=1
3/18/2011 8:06:53 AM System SetVariable Mixer_CD_Volume_GAMEROOM=94
3/18/2011 8:06:53 AM System SetVariable Mixer_CD_Mute_GAMEROOM=0
3/18/2011 8:06:53 AM System SetVariable Mixer_Midi_Volume_GAMEROOM=100
3/18/2011 8:06:53 AM System SetVariable Mixer_Midi_Mute_GAMEROOM=0
3/18/2011 8:06:58 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:06:58 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:00 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:00 AM System SetVariable ClientSvc_192.168.1.2_Connected=1
3/18/2011 8:07:03 AM System SetVariable Mixer_Wave_Volume_GAMEROOM=80
3/18/2011 8:07:03 AM System SetVariable Mixer_Wave_Mute_GAMEROOM=0
3/18/2011 8:07:03 AM System SetVariable Mixer_WaveIn_Volume_GAMEROOM=80
3/18/2011 8:07:03 AM System SetVariable Mixer_WaveIn_Mute_GAMEROOM=0
3/18/2011 8:07:03 AM System SetVariable Mixer_LineIn_Volume_GAMEROOM=85
3/18/2011 8:07:03 AM System SetVariable Mixer_LineIn_Mute_GAMEROOM=0
3/18/2011 8:07:03 AM System SetVariable Mixer_Mic_Volume_GAMEROOM=25
3/18/2011 8:07:03 AM System SetVariable Mixer_Mic_Mute_GAMEROOM=1
3/18/2011 8:07:03 AM System SetVariable Mixer_CD_Volume_GAMEROOM=94
3/18/2011 8:07:03 AM System SetVariable Mixer_CD_Mute_GAMEROOM=0
3/18/2011 8:07:03 AM System SetVariable Mixer_Midi_Volume_GAMEROOM=100
3/18/2011 8:07:03 AM System SetVariable Mixer_Midi_Mute_GAMEROOM=0
3/18/2011 8:07:08 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:08 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:10 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:10 AM System SetVariable ClientSvc_192.168.1.2_Connected=1
3/18/2011 8:07:13 AM System SetVariable Mixer_Wave_Volume_GAMEROOM=80
3/18/2011 8:07:13 AM System SetVariable Mixer_Wave_Mute_GAMEROOM=0
3/18/2011 8:07:13 AM System SetVariable Mixer_WaveIn_Volume_GAMEROOM=80
3/18/2011 8:07:13 AM System SetVariable Mixer_WaveIn_Mute_GAMEROOM=0
3/18/2011 8:07:13 AM System SetVariable Mixer_LineIn_Volume_GAMEROOM=85
3/18/2011 8:07:13 AM System SetVariable Mixer_LineIn_Mute_GAMEROOM=0
3/18/2011 8:07:13 AM System SetVariable Mixer_Mic_Volume_GAMEROOM=25
3/18/2011 8:07:13 AM System SetVariable Mixer_Mic_Mute_GAMEROOM=1
3/18/2011 8:07:13 AM System SetVariable Mixer_CD_Volume_GAMEROOM=94
3/18/2011 8:07:13 AM System SetVariable Mixer_CD_Mute_GAMEROOM=0
3/18/2011 8:07:13 AM System SetVariable Mixer_Midi_Volume_GAMEROOM=100
3/18/2011 8:07:13 AM System SetVariable Mixer_Midi_Mute_GAMEROOM=0
3/18/2011 8:07:18 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:18 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:21 AM System SetVariable ClientSvc_192.168.1.2_Connected=0
3/18/2011 8:07:21 AM System SetVariable ClientSvc_192.168.1.2_Connected=1
3/18/2011 8:07:23 AM System SetVariable Mixer_Wave_Volume_GAMEROOM=80
3/18/2011 8:07:23 AM System SetVariable Mixer_Wave_Mute_GAMEROOM=0
3/18/2011 8:07:23 AM System SetVariable Mixer_WaveIn_Volume_GAMEROOM=80
3/18/2011 8:07:23 AM System SetVariable Mixer_WaveIn_Mute_GAMEROOM=0
3/18/2011 8:07:23 AM System SetVariable Mixer_LineIn_Volume_GAMEROOM=85
3/18/2011 8:07:23 AM System SetVariable Mixer_LineIn_Mute_GAMEROOM=0
3/18/2011 8:07:23 AM System SetVariable Mixer_Mic_Volume_GAMEROOM=25
3/18/2011 8:07:23 AM System SetVariable Mixer_Mic_Mute_GAMEROOM=1
3/18/2011 8:07:23 AM System SetVariable Mixer_CD_Volume_GAMEROOM=94
3/18/2011 8:07:23 AM System SetVariable Mixer_CD_Mute_GAMEROOM=0
3/18/2011 8:07:23 AM System SetVariable Mixer_Midi_Volume_GAMEROOM=100
3/18/2011 8:07:23 AM System SetVariable Mixer_Midi_Mute_GAMEROOM=0

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: client service

Postby Art Dustman » Fri Mar 18, 2011 7:36 am

Just checked the firewalls again. All fine.
Used Putty to telnet to client from server, and I connect and stay connected. So there is something wrong with my client service in MLSERVER? (I just re-installed that too)

I have literally spent over 14 hours on the dvd issue and this now, so I appreciate any help.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: client service

Postby Art Dustman » Fri Mar 18, 2011 9:13 am

Here is the log from the client:
Am I reading this right? There is a ping from the server, then the client answers to my server ALPHA from gameroom (client)

Yet the plugin keeps disconnecting due to ping timeout? Seems like the server is not seeing the reply back?


3/18/2011 10:09:06 AM [0] Ping
3/18/2011 10:09:11 AM [0] HELO~ALPHA (GameRoom)
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_Wave_Volume_GAMEROOM = 80
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_Wave_Mute_GAMEROOM = 0
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_WaveIn_Volume_GAMEROOM = 80
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_WaveIn_Mute_GAMEROOM = 0
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_LineIn_Volume_GAMEROOM = 85
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_LineIn_Mute_GAMEROOM = 0
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_Mic_Volume_GAMEROOM = 25
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_Mic_Mute_GAMEROOM = 1
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_CD_Volume_GAMEROOM = 94
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_CD_Mute_GAMEROOM = 0
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_Midi_Volume_GAMEROOM = 100
3/18/2011 10:09:14 AM SendResults: SetVariable - Mixer_Midi_Mute_GAMEROOM = 0
3/18/2011 10:09:16 AM [0] Ping
3/18/2011 10:09:21 AM [0] HELO~ALPHA (GameRoom)
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_Wave_Volume_GAMEROOM = 80
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_Wave_Mute_GAMEROOM = 0
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_WaveIn_Volume_GAMEROOM = 80
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_WaveIn_Mute_GAMEROOM = 0
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_LineIn_Volume_GAMEROOM = 85
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_LineIn_Mute_GAMEROOM = 0
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_Mic_Volume_GAMEROOM = 25
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_Mic_Mute_GAMEROOM = 1
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_CD_Volume_GAMEROOM = 94
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_CD_Mute_GAMEROOM = 0
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_Midi_Volume_GAMEROOM = 100
3/18/2011 10:09:24 AM SendResults: SetVariable - Mixer_Midi_Mute_GAMEROOM = 0
3/18/2011 10:09:26 AM [0] Ping
3/18/2011 10:09:31 AM [0] HELO~ALPHA (GameRoom)
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_Wave_Volume_GAMEROOM = 80
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_Wave_Mute_GAMEROOM = 0
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_WaveIn_Volume_GAMEROOM = 80
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_WaveIn_Mute_GAMEROOM = 0
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_LineIn_Volume_GAMEROOM = 85
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_LineIn_Mute_GAMEROOM = 0
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_Mic_Volume_GAMEROOM = 25
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_Mic_Mute_GAMEROOM = 1
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_CD_Volume_GAMEROOM = 94
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_CD_Mute_GAMEROOM = 0
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_Midi_Volume_GAMEROOM = 100
3/18/2011 10:09:34 AM SendResults: SetVariable - Mixer_Midi_Mute_GAMEROOM = 0
3/18/2011 10:09:36 AM [0] Ping


Return to “MainLobby 3 Client”

Who is online

Users browsing this forum: No registered users and 1 guest