MLISY Disconnected?

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

MLISY Disconnected?

Postby T.Wells » Thu Oct 15, 2009 1:51 pm

Hello,

I suddenly can not get MLISY to connect to my ISY99i. I am running 0.1.14 of MLISY and my FW on the ISY is 2.7.6.

I am able to hit the ISY admin panel from both inside and outside my network.

Thanks,
T.Wells

FYI
I get the following error:


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at MLISY.isy.GetNodesConfig()
at MLISY.isy.Initialize()
at MLISY.IsySettings.Apply_Button_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MLComDevice
Assembly Version: 1.1.6.0
Win32 Version: 1.1.6
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/MLComDevice/1.1.6.0__747731dbdf7e1a5f/MLComDevice.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
MLDMR
Assembly Version: 3.0.3161.15448
Win32 Version: 3.0.3161.15448
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/MLDMR/3.0.3161.15448__9041e622e0f40a51/MLDMR.dll
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
DMR
Assembly Version: 1.0.2957.23083
Win32 Version:
CodeBase: file:///C:/Program%20Files/MLServer/DMR.DLL
----------------------------------------
msvcm80
Assembly Version: 8.0.50727.4016
Win32 Version: 8.00.50727.4016
CodeBase: file:///C:/Windows/WinSxS/x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4016_none_d0893820442e7fe4/msvcm80.dll
----------------------------------------
System.Management
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------
System.Web
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_32/System.Web/2.0.0.0__b03f5f7f11d50a3a/System.Web.dll
----------------------------------------
MLISY
Assembly Version: 1.0.1.14
Win32 Version: 1.0.1.14
CodeBase: file:///C:/Program%20Files/MLServer/Plugins/MLISY.DLL
----------------------------------------
System.ServiceModel
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.4037 (QFE.030729-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.ServiceModel/3.0.0.0__b77a5c561934e089/System.ServiceModel.dll
----------------------------------------
SMDiagnostics
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.4037 (QFE.030729-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/SMDiagnostics/3.0.0.0__b77a5c561934e089/SMDiagnostics.dll
----------------------------------------
System.Runtime.Serialization
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.4037 (QFE.030729-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Serialization/3.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
System.IdentityModel
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.4037 (QFE.030729-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.IdentityModel/3.0.0.0__b77a5c561934e089/System.IdentityModel.dll
----------------------------------------
9dsrsvkg
Assembly Version: 1.0.1.14
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

bpwwer
Senior Member
Senior Member
Posts: 215
Joined: Fri Jul 07, 2006 10:58 am
Contact:

Re: MLISY Disconnected?

Postby bpwwer » Thu Oct 15, 2009 7:23 pm

Hi,

Have you made any changes recently on the ISY like add a new type of device or create any folders for devices? My best guess would be folders. With the addition of folder support, the data the plug-in receives from the GetNodesConfig call can be different. Different enough that it can cause an unhandled exception while trying to process it.

Updating the ISY communication code in MLISY is on my list of things to do, but it's been pretty low on the list. Knowing that someone is having problems with it does move it higher.

If it is because you've started using folders, the temporary solution would be to delete all the folders and go back to a flat device list.

Bob

T.Wells wrote:Hello,

I suddenly can not get MLISY to connect to my ISY99i. I am running 0.1.14 of MLISY and my FW on the ISY is 2.7.6.

I am able to hit the ISY admin panel from both inside and outside my network.

Thanks,
T.Wells

FYI
I get the following error:


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at MLISY.isy.GetNodesConfig()
at MLISY.isy.Initialize()
at MLISY.IsySettings.Apply_Button_Click(Object sender, EventArgs e)
--
Bob

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

Re: MLISY Disconnected?

Postby T.Wells » Thu Oct 15, 2009 8:01 pm

Bob,

Thank you so much for the plug-in and the help. Yes, I did add folders recently. I will make the fix to flatten my device list so that you don't have to worry about fixing something on my behalf.

Thanks again for MLISY!

T.Wells

bpwwer wrote:Hi,

Have you made any changes recently on the ISY like add a new type of device or create any folders for devices? My best guess would be folders. With the addition of folder support, the data the plug-in receives from the GetNodesConfig call can be different. Different enough that it can cause an unhandled exception while trying to process it.

Updating the ISY communication code in MLISY is on my list of things to do, but it's been pretty low on the list. Knowing that someone is having problems with it does move it higher.

If it is because you've started using folders, the temporary solution would be to delete all the folders and go back to a flat device list.

Bob

T.Wells wrote:Hello,

I suddenly can not get MLISY to connect to my ISY99i. I am running 0.1.14 of MLISY and my FW on the ISY is 2.7.6.

I am able to hit the ISY admin panel from both inside and outside my network.

Thanks,
T.Wells

FYI
I get the following error:


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at MLISY.isy.GetNodesConfig()
at MLISY.isy.Initialize()
at MLISY.IsySettings.Apply_Button_Click(Object sender, EventArgs e)

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

Fixed

Postby T.Wells » Thu Oct 15, 2009 8:09 pm

Bob,

Thanks again. I just removed the folders and it connected without any problems.

-T.Wells

bpwwer
Senior Member
Senior Member
Posts: 215
Joined: Fri Jul 07, 2006 10:58 am
Contact:

Re: MLISY Disconnected?

Postby bpwwer » Thu Oct 15, 2009 11:12 pm

Too late. I've had the updated code for quite a while, it just needed to be integrated. So I did that tonight and I think it's working. I say that because after restarting MLServer, it (MLServer) is getting blocked by something so that everything runs fine for a second or two an then hangs for 5 seconds, then is fine for a couple more seconds. After a few minutes of this it started behaving normally. I don't know if MLISY was the cause or something else.

In any case, the update is available on my web site:

http://www.bobsplace.com/mlisy/
--

Bob


Return to “Insteon”

Who is online

Users browsing this forum: No registered users and 1 guest