ISY Install Issues

Nexus
Member
Member
Posts: 60
Joined: Mon Aug 25, 2003 7:04 pm
Contact:

Postby Nexus » Tue Feb 24, 2009 2:16 pm

bpwwer wrote:Thanks Nexus,


NP

Thanks for the great plug-in.

bpwwer
Senior Member
Senior Member
Posts: 215
Joined: Fri Jul 07, 2006 10:58 am
Contact:

Postby bpwwer » Sun Mar 01, 2009 4:09 pm

Version 0.1.13 of the plug-in has been posted to my web site.

http://www.bobsplace.com/mlisy/

I think this fixes the problem with it hanging after installation. It also adds some support for Thermostats and modules (weatherbug and energy). There's a lot of minor bug fixes too.
--
Bob

kirkfrey
Expert
Expert
Posts: 759
Joined: Wed Jan 12, 2005 10:55 am
Contact:

Postby kirkfrey » Sun Apr 26, 2009 5:40 pm

I just got my ISY and have it working fine but I am having the same issues as described below for 0.1.13 hanging. I am running MLS 591 but I don't see where to tell what version of firmware is on my ISY - nor how to get the updates from Universal Devices.

Tried the fix above - uninstall, install 0.1.10, configure and reinstall 0.1.13 - and it didnt help.

Any ideas?
Kirk

Just trying to figure it out...

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

Postby T.Wells » Sun Apr 26, 2009 7:11 pm

kirkfrey wrote:I just got my ISY and have it working fine but I am having the same issues as described below for 0.1.13 hanging. I am running MLS 591 but I don't see where to tell what version of firmware is on my ISY - nor how to get the updates from Universal Devices.

Tried the fix above - uninstall, install 0.1.10, configure and reinstall 0.1.13 - and it didnt help.

Any ideas?


Try this maybe:

1. Uninstall 0.1.13
2. Install 0.1.10
3. Configure ISY login/password and apply settings
4. Re-install 0.1.12
5. Install 0.1.13

-T.Wells

kirkfrey
Expert
Expert
Posts: 759
Joined: Wed Jan 12, 2005 10:55 am
Contact:

Postby kirkfrey » Sun Apr 26, 2009 9:16 pm

Ok, I uninstalled, reinstalled, updated .net... I got the plugin to see the ISY and its devices but when I try to control one of the lights from within the plugin I get the following error when I use "On", "FastOn" seems to work without error.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.FormatException: Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at MLISY.isy.Control(node& the_node, String& command, String& action)
at MLISY.plugin.isy_control(String id, String control, String action)
at MLISY.plugin.doCommand(String command, String client)
at MLISY.IsySettings.SendOn_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3082 (QFE.050727-3000)
CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MLISY
Assembly Version: 1.0.1.13
Win32 Version: 1.0.1.13
CodeBase: file:///C:/Program%20Files/MLServer/Plugins/MLISY.DLL
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3082 (QFE.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.ServiceModel
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.2254 (QFE.030729-1900)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.ServiceModel/3.0.0.0__b77a5c561934e089/System.ServiceModel.dll
----------------------------------------
SMDiagnostics
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.2152 (SP.030729-0100)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/SMDiagnostics/3.0.0.0__b77a5c561934e089/SMDiagnostics.dll
----------------------------------------
System.Runtime.Serialization
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.2152 (SP.030729-0100)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Serialization/3.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
System.Transactions
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_32/System.Transactions/2.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.Web
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3082 (QFE.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_32/System.Web/2.0.0.0__b03f5f7f11d50a3a/System.Web.dll
----------------------------------------
System.IdentityModel
Assembly Version: 3.0.0.0
Win32 Version: 3.0.4506.2152 (SP.030729-0100)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.IdentityModel/3.0.0.0__b77a5c561934e089/System.IdentityModel.dll
----------------------------------------
lkm37ifw
Assembly Version: 1.0.1.13
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

____________________________
toggle doesn't seem to work either - this is the error in MLS log.

4/26/2009 10:38:39 PM Error MLProcess via (kitchen) MLISY Error# -2146233033 - Input string was not in a correct format. raised by MLProcess via (kitchen) MLISY
Kirk

Just trying to figure it out...

bpwwer
Senior Member
Senior Member
Posts: 215
Joined: Fri Jul 07, 2006 10:58 am
Contact:

Postby bpwwer » Mon Apr 27, 2009 1:24 pm

kirkfrey wrote:Ok, I uninstalled, reinstalled, updated .net... I got the plugin to see the ISY and its devices but when I try to control one of the lights from within the plugin I get the following error when I use "On", "FastOn" seems to work without error.

I just tried it myself and the "On" button does the same thing for me. You must be the first person to try it since I released this version almost 2 months ago.

It's just the button control that's broken, sending ON commands to the plug-in should be working.

toggle doesn't seem to work either - this is the error in MLS log.

4/26/2009 10:38:39 PM Error MLProcess via (kitchen) MLISY Error# -2146233033 - Input string was not in a correct format. raised by MLProcess via (kitchen) MLISY


Toggle, at least, going from off to on is doing the same thing as the button.

So, two bugs that need to be fixed. Thanks for reporting them. I should have a new version with the fixes out later today or tomorrow at the latest.
--

Bob

bpwwer
Senior Member
Senior Member
Posts: 215
Joined: Fri Jul 07, 2006 10:58 am
Contact:

Postby bpwwer » Mon Apr 27, 2009 7:59 pm

bpwwer wrote:So, two bugs that need to be fixed. Thanks for reporting them. I should have a new version with the fixes out later today or tomorrow at the latest.


I just posted a new version to my web site with a fix for these two problems.

http://www.bobsplace.com/mlisy/

The fix is in version 0.1.14
--

Bob

kirkfrey
Expert
Expert
Posts: 759
Joined: Wed Jan 12, 2005 10:55 am
Contact:

Postby kirkfrey » Mon Apr 27, 2009 8:16 pm

Wow, now thats Service! I will download and give it a try tonight or tomorrow.
THANKS!
Kirk

Just trying to figure it out...


Return to “Insteon”

Who is online

Users browsing this forum: No registered users and 1 guest