OS Upgrade breaks plugin

SparkyD
Senior Member
Senior Member
Posts: 182
Joined: Thu Jul 28, 2005 3:12 pm
Contact:

OS Upgrade breaks plugin

Postby SparkyD » Tue Feb 02, 2010 7:58 am

I just did a clean install on my MLServer PC to Windows 7. This plugin was working before the switch. Now I get the following error after startup:

Loading Error at line #1940 - Type mismatch

I can arm and disarm the panel, but cannot see variables update. No changes were done to the panel (programming, firmware, or serial connection)

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Re: OS Upgrade breaks plugin

Postby mcascio » Tue Feb 02, 2010 8:58 am

Have you turned off UAC? You may have to reinstall the plugin as well after turning off UAC.
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

SparkyD
Senior Member
Senior Member
Posts: 182
Joined: Thu Jul 28, 2005 3:12 pm
Contact:

Re: OS Upgrade breaks plugin

Postby SparkyD » Tue Feb 02, 2010 3:42 pm

Yes, I turned off UAC right from the beginning. I verified it's off, and re-installed MLELK plugin, no luck. I also tried a different type of serial connection, and get the same error.

SparkyD
Senior Member
Senior Member
Posts: 182
Joined: Thu Jul 28, 2005 3:12 pm
Contact:

Re: OS Upgrade breaks plugin

Postby SparkyD » Tue Feb 02, 2010 5:32 pm

I am able to connect to the panel with RP software no problem. Any ideas for getting this functional?

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: OS Upgrade breaks plugin

Postby DavidL » Tue Feb 02, 2010 9:33 pm

I have used a Win732 w/ MLServer and latest MLElkM1 to Elk's latest firmware with no problem.

Not sure what issue your system is having. My guess is wrong port (non encrypted is a must) or firewall issues. That message isn't too specific to tell.

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Re: OS Upgrade breaks plugin

Postby mcascio » Tue Feb 02, 2010 9:35 pm

SparkyD,

Do you have MLServer running in XP compatability mode? If so, you should turn it off. We've found that to cause problems with MLServer.

After turning it off, you may need to reinstall any plugins with issues.
Mario Cascio

Cinemar, Inc.

http://www.cinemaronline.com

SparkyD
Senior Member
Senior Member
Posts: 182
Joined: Thu Jul 28, 2005 3:12 pm
Contact:

Re: OS Upgrade breaks plugin

Postby SparkyD » Tue Feb 02, 2010 11:17 pm

Thanks for your help, this is where I am at:

1. I have tried connecting this through a VScom PCI serial card that came with this Server from Cinemar. This is how it was connected the last 2 years without issue.
2. I tried the serial to USB converter sold by ELK.
3. I tried another manufacturers serial to USB cable
4. Tried a 4 port Edgeport serial to USB box
5. Tried a direct connection to Com Port 1 on the motherboard which I know is working correctly, and there is no chance of a driver issue.
6. UAC has been turned off since the beginning.
7. No programs are running in XP Compatibility mode.
8. I verified the ELK Panel, the various serial to usb adapters, and the plugin are all set to 115200 Baud Rate, 8 Bits, Parity N, 1 Stop bit, No flow control. 115200 is what I have been using successfully for the last couple years. If it should be different, let me know.
9. This is Windows 7 - 64 Bit, but I just got done reading a post from Dave that MLServer should run fine on a 64 bit OS.
10. I have unregistered using regsvr32.exe "C:\Program Files (x86)\MLServer\plugins\MLELKM1.dll" /u Then delete and reinstall. Tried this 3 times.
11. This is a fresh OS install. No antivirus or other software even installed yet.

If anyone can think of something else, please let me know. Mario or Dave, if you want to log in and take a look, please let me know.

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: OS Upgrade breaks plugin

Postby DavidL » Tue Feb 02, 2010 11:23 pm

You are using a 64 bit win7?
I have had problems running MLServer on that OS.
Problem with registry writing.

SparkyD
Senior Member
Senior Member
Posts: 182
Joined: Thu Jul 28, 2005 3:12 pm
Contact:

Re: OS Upgrade breaks plugin

Postby SparkyD » Tue Feb 02, 2010 11:38 pm

I wanted to go to Windows 7, and got this copy for free. I'm close to having this working.....

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: OS Upgrade breaks plugin

Postby CinemarDave » Tue Feb 02, 2010 11:49 pm

Sparky set up LogMeIn and email me your login information. I'll look at the PC tomorrow.

I say again for the record. There are NO issues with running MLServer on any version of Windows 7. Every problem we have looked at to date has been associated with incorrect configurations.

SparkyD
Senior Member
Senior Member
Posts: 182
Joined: Thu Jul 28, 2005 3:12 pm
Contact:

Re: OS Upgrade breaks plugin

Postby SparkyD » Thu Feb 04, 2010 12:06 pm

Hi Dave, I sent you a pm with my logmein info. I have noticed that I can send any command to the panel like arm, disarm, or operate a relay to close my garage door and it works correctly. MLServer just cannot seem to receive any info from the ELK Panel.

SparkyD
Senior Member
Senior Member
Posts: 182
Joined: Thu Jul 28, 2005 3:12 pm
Contact:

Re: OS Upgrade breaks plugin

Postby SparkyD » Mon Feb 08, 2010 5:26 pm

Dave found a glitch and updated the plugin. All is well.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Elk plugin problem

Postby Art Dustman » Thu Jun 24, 2010 7:51 pm

Plugin hell this week...

Just got an insane electric bill and found out my tstat routines were not working due to the elk plugin returning this:
6/24/2010 7:58:13 PM - Loading Error at line #1940 - Type mismatch

UAC is off, of course

Any help is appreciated
Dave.... I left logmein up if u want to have a looky

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: OS Upgrade breaks plugin

Postby CinemarDave » Thu Jun 24, 2010 8:34 pm

In this case look at the value of your PLC polling interval. It is set to a non-valid number. Version 3.0.6 of the plugin will compensate for this and set the value to 60 if it sees a non-valid number.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: OS Upgrade breaks plugin

Postby Art Dustman » Fri Jun 25, 2010 8:38 am

Ok, That did it.. back to the pool.


Return to “Elk Products”

Who is online

Users browsing this forum: No registered users and 1 guest