Putting in extra characters when sending M1 texts to Server

lilsmurfman
New Member
New Member
Posts: 26
Joined: Wed Aug 08, 2007 12:34 am
Contact:

Putting in extra characters when sending M1 texts to Server

Postby lilsmurfman » Mon Jun 15, 2009 3:48 am

Well it looks like the communication is ok but upon a test event, I try to update a variable "elktest" to the word, UNSECURE based on an M1 Event.

The variable updates, but with extra garbage ex "UNSECURE1EAS000000000111111100000000000F"

This is what I'm getting with both a carriage return inserted or not...

End Event [6/15/2009 1:26:46 AM]
Rcvd: 23 bytes [13TR02100726282000008]
Event: [13TR02100726282000008]
Rcvd: Thermostat Data
End Event [6/15/2009 1:26:56 AM]
Rcvd: 14 bytes [0AZC006900C3]
Event: [0AZC006900C3]
Rcvd: Zone Change Update Data
End Event [6/15/2009 1:26:58 AM]
Rcvd: 67 bytes [MLServeCmd.SetVariable|elktest~UNSECURE1EAS000000000111111100000000000F]
Event: [MLServeCmd.SetVariable|elktest~UNSECURE1EAS000000000111111100000000000F]
Sending: [MLServeCmd.SetVariable|elktest~UNSECURE1EAS000000000111111100000000000F]
Sent: [MLServeCmd.SetVariable|elktest~UNSECURE1EAS000000000111111100000000000F]
End Event [6/15/2009 1:26:58 AM]
Rcvd: 14 bytes [0AZC006200CA]
Event: [0AZC006200CA]
Rcvd: Zone Change Update Data
End Event [6/15/2009 1:27:01 AM]
Rcvd: 34 bytes [1EAS000000001111111100000000000E]
Event: [1EAS000000001111111100000000000E]

lilsmurfman
New Member
New Member
Posts: 26
Joined: Wed Aug 08, 2007 12:34 am
Contact:

Postby lilsmurfman » Mon Jun 15, 2009 5:10 am

well I got it working, I just happend to try ^M^J (Carriage return with Line Feed) and now all my events work....


hmmmmm

I'm on firmware 4.5 and m1xep firmware 1.21.2


Return to “Elk Products”

Who is online

Users browsing this forum: No registered users and 1 guest