3.0.28 - programmovieyear vs programoriginal

Report any bugs you may notice in TVLobby
randy h
Senior Member
Senior Member
Posts: 230
Joined: Sat Jan 08, 2005 7:27 pm
Location: Saint Louis, MO USA
Contact:

3.0.28 - programmovieyear vs programoriginal

Postby randy h » Sat Dec 15, 2007 12:52 pm

MLTVLobby - 3.0.28
tvlobby.swf - February 03, 2007, 7:25:12 PM
MLServer - 3.0.389
MLobby - 3.00.105
MLScheduler - 1.0.3

The {{tvlobby_current_programmovieyear}} variable is being populated correctly when a movie is selected. When a TV Program is selected it is being poplated with data that should be landing in {{tvlobby_current_programoriginalairdate}}. This would not be an issue if both data sets were formated the same and night even be considered a feature.

thanks,
randy

User avatar
Fonceur
Expert
Expert
Posts: 583
Joined: Sun Sep 09, 2007 10:18 am
Contact:

Re: 3.0.28 - programmovieyear vs programoriginal

Postby Fonceur » Sat Dec 15, 2007 1:21 pm

randy h wrote:When a TV Program is selected it is being poplated with data that should be landing in {{tvlobby_current_programoriginalairdate}}.

I will need to check, since the code makes use of the record number instead of the record name, I suspect things get shifted when some infos are missing...

User avatar
Fonceur
Expert
Expert
Posts: 583
Joined: Sun Sep 09, 2007 10:18 am
Contact:

Postby Fonceur » Sat Dec 15, 2007 1:39 pm

I just checked and it's working fine on my system, using MLBeyondTV as the guide data. If you have access to some database software (or you can download Mdb viewer plus), check the table TblProgram and see if programOriginalAirDate is properly filled...

randy h
Senior Member
Senior Member
Posts: 230
Joined: Sat Jan 08, 2005 7:27 pm
Location: Saint Louis, MO USA
Contact:

Postby randy h » Sat Dec 15, 2007 3:48 pm

I downloaded MDB Viewer Plus (nice tool btw), and sure enough the ProgramMovieYear column has Year data for movies and ProgramOriginalAirDate data for programs. My ProgramOriginalAirDate column is completely blank for all listings regardless of Movie or Program.

My data is coming from SD.

thanks,
randy

User avatar
Fonceur
Expert
Expert
Posts: 583
Joined: Sun Sep 09, 2007 10:18 am
Contact:

Postby Fonceur » Sat Dec 15, 2007 5:21 pm

randy h wrote:My ProgramOriginalAirDate column is completely blank for all listings regardless of Movie or Program.

Ok, sounds like a problem with the TVListings.exe, I'll take a peak...

User avatar
Fonceur
Expert
Expert
Posts: 583
Joined: Sun Sep 09, 2007 10:18 am
Contact:

Postby Fonceur » Sat Dec 15, 2007 5:57 pm

Confirmed and fixed in TVListings.exe 3.0.30 (avalaible soon...). Indeed everything was saved to programMovieYear.

randy h
Senior Member
Senior Member
Posts: 230
Joined: Sat Jan 08, 2005 7:27 pm
Location: Saint Louis, MO USA
Contact:

Postby randy h » Sat Dec 15, 2007 6:02 pm

Thanks, Fonceur. I will watch for the new version.

randy

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Sat Dec 15, 2007 7:00 pm

Update posted with new TVListings.exe file for MLServer root

randy h
Senior Member
Senior Member
Posts: 230
Joined: Sat Jan 08, 2005 7:27 pm
Location: Saint Louis, MO USA
Contact:

Postby randy h » Sat Dec 15, 2007 7:40 pm

MLTVLobby - 3.0.30 (second edition)
tvlobby.swf - February 03, 2007, 7:25:12 PM
MLServer - 3.0.389
MLobby - 3.00.105
MLScheduler - 1.0.3


MLTVLobby - 3.0.30 (second edition) has fixed this issue for me. Thanks
NOTE: Users must download and process a new TVListings dataset before the fix is noticed.

Thanks again,
randy


Return to “TVLobby Public Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest