Watch Cmd fails to pass on {{clientname}} variable to MLServ

Please post general questions about TVLobby here
digitaltrader
Senior Member
Senior Member
Posts: 205
Joined: Sat Jan 10, 2004 2:15 pm
Contact:

Watch Cmd fails to pass on {{clientname}} variable to MLServ

Postby digitaltrader » Mon Feb 16, 2009 5:52 pm

when using TVLobby to control multiple zones, I use TVLobby watch command to send the following:

REPEAT:MLGC100|SendIR~{{tv_{{clientname}}_activedevice}}~<<ChannelDigit>>


For some reason TVLobby fails to send on the {{clientname}} variable to MLserver. I have confirmed this error with Dave P. Is there anyway to update the plugin to allow this to pass on the value of {{clientname}} ?


The event log shows:

Macro|MLGC100|SendIR~[code]{{tv_{{clientname}}_activedevice}}~0!MLGC100|SendIR~{{tv_{{clientname}}_activedevice}}~7!MLGC100|SendIR~{{tv_{{clientname}}_activedevice}}~0

subst out: Macro|MLGC100|SendIR~~0!MLGC100|SendIR~~7!MLGC100|SendIR~~0


The variable {{tv_{{clientname}}_activedevice}} is correctly populated in the variable section but isnt passing on within TVLobby. I hope this can be fixed soon.

User avatar
Fonceur
Expert
Expert
Posts: 583
Joined: Sun Sep 09, 2007 10:18 am
Contact:

Postby Fonceur » Mon Feb 16, 2009 6:06 pm

As long as you are using a recent version, you need to use <<ClientName>> for the substitution to occur...
MLComDevice: Control serial/TCP device (ASCII/hex) - MLSchedule: Alternative to MLScheduler
MLBeyondTV and MLSageTV: PVR support - TChanger: Sony BDP-CX7000ES 400 disc Bluray changer
TRadio: Sirius/HD/XM radio - TChart: Chart from variable Wiki

digitaltrader
Senior Member
Senior Member
Posts: 205
Joined: Sat Jan 10, 2004 2:15 pm
Contact:

Postby digitaltrader » Tue Feb 17, 2009 11:19 am

Thanks for the quick reply, that now works.


Return to “TVLobby Questions & Answers”

Who is online

Users browsing this forum: No registered users and 1 guest