Need Help with MLGenericDevice Plugin and MLServer 4

Repository of MainLobby Server plug-ins and updates not available in the current installation.
User avatar
DanielSiegel
Intermediate
Intermediate
Posts: 302
Joined: Mon Oct 11, 2004 6:05 am
Contact:

Need Help with MLGenericDevice Plugin and MLServer 4

Postby DanielSiegel » Sun Mar 25, 2012 11:53 pm

I tried testing this plugin with a Key Digital matrix switcher having a very simple command language (eg, CC13 to switch Input #3 to Output #1).
I used a USB to Serial device (my PC doesnt have a serial port), and it appears to be communicating with the plugin, but is not responding correctly to the command.

I used the standard "13" (carriage return) terminator, but tried various others with no better results.

Whenever I test the command (eg, CC13, CC18, etc), the plugin simply responds with "testing command - CC13".
If I manually switch the inputs (via buttons on the Key Digital switcher itself), the following string appears each time I press a button to switch inputs:

--------------------------------
Buffer partially filled - Waiting for additional data
Buffer - fffx€˜àøfff˜x€˜àøfff€˜àøfff˜æ˜àøfff€˜àøfff˜€˜àøffff˜€˜àøfff†x~˜àøfffæx~˜àøfff~˜àøffff~˜àøfff†~˜àøfffæ~˜àøfffæ~˜à˜àøfffæ~x
Last character in buffer = > 102
Buffer partially filled - Waiting for additional data
Buffer - fffx€˜àøfff˜x€˜àøfff€˜àøfff˜æ˜àøfff€˜àøfff˜€˜àøffff˜€˜àøfff†x~˜àøfffæx~˜àøfff~˜àøffff~˜àøfff†~˜àøfffæ~˜àøfffæ~˜à˜àøfffæ~x
Last character in buffer = > 30

ETC
--------------------------------

Any idea what I am doing wrong, or how I can fix this?
I have been using this device successfully with the MLGirder plugin for many years on MLServer 3 (Girder doesnt ask for a Termination character), and I know my Port settings are the same (9600 N-8-1), but I'm now out of ideas.

Any thoughts will be greatly appreciated.

Return to “MLServer Plug-Ins”

Who is online

Users browsing this forum: No registered users and 1 guest