MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Repository of MainLobby Server plug-ins and updates not available in the current installation.
MurrayW
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1198
Joined: Sun Mar 07, 2004 1:05 pm
Location: Austin, TX
Contact:

MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby MurrayW » Mon Feb 07, 2011 6:40 pm

I'd like to see if others are seeing what I see. I have posted previously about delays with calling scripts using the previous MLDirecTV serial plugin, but this one is entirely different. The serial problem was something going on with the command getting sent to the DVR, but once the command was sent the DVR responded. What I am seeing with the Polling checked for Now Playing and Playlist is DVR related. The command gets sent to the DVR immediately, but the DVR may not respond right away.

This is what I am seeing. About once every 30 - 60 seconds the DVR stops responding to remote commands and queues them up. Then when it becomes unbusy (anywhere from 1-2 seconds to 30 - 40 seconds) it sends all the commands that are queued up. What usually happens is during this unresponsive time I hit the same command multiple times, so I end up going past where I intended to go. Because of this I have to uncheck the polling boxes. I see this behavior regardless of the time since the last reboot.

This is my setup.
1. 5 DVR's (3 HR20's, HR21 and HR24). This behavior happens on all of them. I need to do more testing on the HR24 to see if the delays are shorter since it has a faster processor.
2. I have the whole home DVR service.
3. I have external drives on each DVR.
4. There is no serial connection on any DVR's. I disconnected the USB-Serial adapters and rebooted each DVR.

I'd like to see if I am the only one or if there are others.

thanks,
Murray

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby erikhimber » Tue Feb 08, 2011 9:14 am

Murray,

I am running 4 hr20-700's with the ip control, serial is also disconnected. I experience a delay, but only on the initial startup. Once all info has been populated into variables, ie playlist, then everything seems to run fine. Granted I don't use the controls constantly, once everything is fired up from a macro, I usually end up with the DTV remote in my lap.

My wife does use the playlist option from the ML side quite often and she has not complained of anything.

Hope my rambling gives you some insight.
Erik

MurrayW
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1198
Joined: Sun Mar 07, 2004 1:05 pm
Location: Austin, TX
Contact:

Re: MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby MurrayW » Tue Feb 08, 2011 11:42 am

erikhimber wrote:Murray,

I am running 4 hr20-700's with the ip control, serial is also disconnected. I experience a delay, but only on the initial startup. Once all info has been populated into variables, ie playlist, then everything seems to run fine. Granted I don't use the controls constantly, once everything is fired up from a macro, I usually end up with the DTV remote in my lap.

My wife does use the playlist option from the ML side quite often and she has not complained of anything.

Hope my rambling gives you some insight.
Hi Erik, could you do me a favor when you have a few minutes. Go into the guide and just use the down arrow and scroll through the guide for a couple of minutes and see if you run into any of the delays that I am seeing?

thanks,
Murray

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby erikhimber » Wed Feb 09, 2011 7:19 am

Hi Murray,
Last night I spent about 5 minutes navigating through the DTV guide, list, pausing and playing shows. I saw no significant delay in the executiuon of any command. I was also watching the event log for the mldirectvip plugin, when the poll commands would queue up, my button press would follow suit and execute within a second or two max. Perhaps you might want to try a power off re-boot for your units. Unplug them for abot 2 minutes, I do this occasionaly to my units, along with a DAILY reboot and it seems to keep them working smoothly.

Hope this helps.
Erik

MurrayW
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1198
Joined: Sun Mar 07, 2004 1:05 pm
Location: Austin, TX
Contact:

Re: MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby MurrayW » Wed Feb 09, 2011 10:46 am

erikhimber wrote:Hi Murray,
Last night I spent about 5 minutes navigating through the DTV guide, list, pausing and playing shows. I saw no significant delay in the executiuon of any command. I was also watching the event log for the mldirectvip plugin, when the poll commands would queue up, my button press would follow suit and execute within a second or two max. Perhaps you might want to try a power off re-boot for your units. Unplug them for abot 2 minutes, I do this occasionaly to my units, along with a DAILY reboot and it seems to keep them working smoothly.

Hope this helps.
Erik, I'll try the power off for 2 minutes. I do reboots 3 times a week. Just to confirm, you do have both the now playing and playlist polling checked, correct?

thanks,
Murray

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby erikhimber » Wed Feb 09, 2011 3:28 pm

MurrayW wrote:Erik, I'll try the power off for 2 minutes. I do reboots 3 times a week. Just to confirm, you do have both the now playing and playlist polling checked, correct?

thanks,
Murray


That's correct.
Erik

sbuckler
Intermediate
Intermediate
Posts: 349
Joined: Tue Feb 11, 2003 8:17 am
Location: Cape Cod
Contact:

Re: MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby sbuckler » Thu Feb 10, 2011 6:18 am

FWIW, I have not re-booted any of my DVRs in over 2 weeks, have not re-booted my HTPC in over 3 weeks and find no significant delay in any commands, using the guide, or navigating. In fact, it's pretty peppy. Now playing and playlist are polling.

MurrayW
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1198
Joined: Sun Mar 07, 2004 1:05 pm
Location: Austin, TX
Contact:

Re: MLDirecTVIP users: Does Polling Interfere with Remote Cmds?

Postby MurrayW » Thu Feb 10, 2011 10:26 am

sbuckler wrote:FWIW, I have not re-booted any of my DVRs in over 2 weeks, have not re-booted my HTPC in over 3 weeks and find no significant delay in any commands, using the guide, or navigating. In fact, it's pretty peppy. Now playing and playlist are polling.
I don't know whether to be happy for everyone else that they see no delays and therefore, my system should be able to do the same :D or be sad that I am the only one experiencing this problem! :cry:

Thanks for the feedback.


Return to “MLServer Plug-Ins”

Who is online

Users browsing this forum: No registered users and 1 guest