MLCallerID not formatting long distance numbers correctly

Repository of MainLobby Server plug-ins and updates not available in the current installation.
Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

MLCallerID not formatting long distance numbers correctly

Postby Blade » Thu Dec 30, 2010 12:42 pm

It seems to be putting the dashes in the wrong places for long distance numbers.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby CinemarDave » Thu Dec 30, 2010 2:16 pm

Can you let me know what pattern you are using and what number was not being parsed properly?

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby Blade » Thu Dec 30, 2010 9:46 pm

It seems to parse a long distance number as follows:

xxx-xxx-xxxxx

It should be this:

x-xxx-xxx-xxxx

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby Blade » Mon Jan 03, 2011 3:55 pm

This should be an easy fix.
I was going to write a script to do it but it needs to be fixed at the source.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby DaveB » Mon Jan 03, 2011 7:49 pm

My variable setting (ie: Mask) is like this;

@@@-@@@-@@@@

The "1" in front of the long distance number simply truncates for display purposes.
Thanks!

Dave Bruner
:shock:

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby Blade » Tue Jan 04, 2011 7:11 pm

My mask is the same but the long distance numbers are messed up

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby DaveB » Tue Jan 04, 2011 7:51 pm

Blade - Did you try @-@@@-@@@-@@@@ ?? I am assuming that you did.
Thanks!

Dave Bruner
:shock:

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby Blade » Tue Jan 04, 2011 8:13 pm

Would that not mess up the normal calls then?

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: MLCallerID not formatting long distance numbers correctly

Postby DaveB » Tue Jan 04, 2011 8:46 pm

Do not know - Might be worth a try?? I know that when I get a call with no area code, the formating is correct.
Thanks!

Dave Bruner
:shock:


Return to “MLServer Plug-Ins”

Who is online

Users browsing this forum: No registered users and 1 guest