XRt12 Problem

Repository of MainLobby Server plug-ins and updates not available in the current installation.
rkerdza
New Member
New Member
Posts: 44
Joined: Wed Oct 07, 2009 1:19 pm
Contact:

XRt12 Problem

Postby rkerdza » Fri Nov 12, 2010 10:35 pm

I seem to be having a rather minor issue with the XRt12 plugin for MLServer. I have it hooked up to my computer using a serial cable hooked up to a GC100. I am able to change channels using the commands in the Wiki, but the server is not setting the correct variables from the info sent back from the unit. It is receiving the correct info from the XRt12 (as seen in the plugin log), but the variables are not getting into the software correctly.

As a side note, I was able to get the info from the receiver on my previous install, but that was using a serial cable straight into the PC's serial port. Unfortunately, the new computer I purchased does not have on-board serial ports and using a USB/Serial converter cable just plain doesn't work at all. At least by hooking it into the GC100, I can at least control the unit, but I'd like to be able to update my PC with song title, artist and current channel info.

I can provide extra info if needed, but any ideas based upon my description?

rkerdza
New Member
New Member
Posts: 44
Joined: Wed Oct 07, 2009 1:19 pm
Contact:

Re: XRt12 Problem

Postby rkerdza » Wed Jan 19, 2011 4:08 pm

Bumping this thread, too. Can anyone help with this issue?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: XRt12 Problem

Postby CinemarDave » Wed Jan 19, 2011 4:50 pm

Post some of the plugins Event logs for me to look at.

rkerdza
New Member
New Member
Posts: 44
Joined: Wed Oct 07, 2009 1:19 pm
Contact:

Re: XRt12 Problem

Postby rkerdza » Wed Jul 27, 2011 10:39 am

Sorry about the VERY long delay in getting you the log info. Life has been very busy lately and this hasn't been a major pressing issue. Here is some of the log that is being displayed in the xrt12 plugin:

<<<<<<<<<

Rcvd: [rtist Name:
Linkin Park
Current Channel Song Title:
In The End
]
Got [GetChannel]
GC-100 Sending 0 bytes [GetChannelInformation]
Rcvd: [GetChannelInformation
Current Chann]
Got [GetSong]
GC-100 Sending 0 bytes [GetSongInformation]
Rcvd: [el Number is: 14
Current Channel Name is:
Pop2K
Current Category Name is:
Pop
]
Rcvd: [GetSongInformation
Current Channel A]
Rcvd: [rtist Name:
Linkin Park
Current Channel Song Title:
In The End
]
Got [GetSong]
GC-100 Sending 0 bytes [GetSongInformation]
Rcvd: [GetSongInformation
Current Channel A]
Rcvd: [rtist Name:
Linkin Park
Current Channel Song Title:
In The End
]
Got [GetChannel]
GC-100 Sending 0 bytes [GetChannelInformation]
Got [GetAntenna]
GC-100 Sending 0 bytes [GetAntennaStrength]
Rcvd: [GetChannelInformation
Current Channe]
Rcvd: [l Number is: 14
Current Channel Name is:
Pop2K
Current Category Name is:
Pop
]
Rcvd: [GetAntennaStrength
Invalid Command
]


>>>>>>>>>

In addition, here is am example of what is being populated in the MLServer variables:

xrt12_artist: hake It Off ('t0gthInvalid Command
xrt12_channelname: GetSongInformationCurrent Channel A

The rest of the variables created have values similar to the above.


Just as an FYI, I am running on a Win 7 machine in compatibility mode. The current MLServer version is 3.75.204 and my version of the MLXRT12 plugin is 1.0.5. Amy other info needed, please ask.

Thanks in advance!

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: XRt12 Problem

Postby CinemarDave » Sat Jul 30, 2011 10:31 am

The issue is that the data coming in from the GC100 is not coming in complete strings. The plugin will need to buffer the incoming data until it sees the trailing <cr>. I'll make the change and post an update.

rkerdza
New Member
New Member
Posts: 44
Joined: Wed Oct 07, 2009 1:19 pm
Contact:

Re: XRt12 Problem

Postby rkerdza » Sat Jul 30, 2011 2:45 pm

Cool. I will be anxiously waiting!


Thanks.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: XRt12 Problem

Postby CinemarDave » Sat Jul 30, 2011 8:01 pm

Version 3.99.0 of the MLXRt12 plugin has been released. It should resolve the GC100 issues.

rkerdza
New Member
New Member
Posts: 44
Joined: Wed Oct 07, 2009 1:19 pm
Contact:

Re: XRt12 Problem

Postby rkerdza » Mon Aug 01, 2011 11:54 am

Works perfectly now. Thanks for all your help!

rkerdza
New Member
New Member
Posts: 44
Joined: Wed Oct 07, 2009 1:19 pm
Contact:

Re: XRt12 Problem

Postby rkerdza » Thu Jun 14, 2012 6:46 pm

Dave,

Hate to bring up the MLXRt plugin again, but every time MLS closes (power outage, reboot, etc.), the XRt Plug-in changes the IP address of the GC-100 unit to 192.168.1.7. It should be 192.168.1.73. I can't figure out why it seems to delete the 3 every time. It happens every time I start MLS. I wouldn't really care so much, but it is kind of annoying, especially if I'm not around to make the correction.

Any idea how to stop the program from reverting to the wrong address?


Return to “MLServer Plug-Ins”

Who is online

Users browsing this forum: No registered users and 1 guest