mlserver crash

Please post general questions about WeatherLobby here
Robethan09
Newbie
Newbie
Posts: 7
Joined: Sat Sep 22, 2007 10:34 pm
Contact:

mlserver crash

Postby Robethan09 » Mon Jan 04, 2010 6:11 pm

Ok figured out the problem I may have. It seems after reinstalling weatherlobby twice It seems my mlserver is crashing after about 30 mins. I have one error in my mlworker log. Error: Readsetting the connectionstring property has not been initialized. But not sure if this is related. Any ideas would be great.

mattdb
New Member
New Member
Posts: 41
Joined: Wed Oct 04, 2006 3:06 pm
Contact:

Re: mlserver crash

Postby mattdb » Tue Jan 05, 2010 9:07 am

Mine is also crashing since installing weather lobby and when it is running it is staying at 50% cpu utilization.

User avatar
jjjukebox
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1024
Joined: Sat May 22, 2004 9:54 pm
Location: Toronto
Contact:

Re: mlserver crash

Postby jjjukebox » Tue Jan 05, 2010 10:00 am

I also had high CPU utilization after install WeatherLobby 3.90. Make sure that Update Variables in FastMode is selected in the plugin. Restart MLServer and see if that makes a difference.

Later
J.J. Jukebox
Member

cadillackid
Senior Member
Senior Member
Posts: 155
Joined: Mon Jul 11, 2005 11:43 am
Location: Columbus, ohio
Contact:

Re: mlserver crash

Postby cadillackid » Tue Jan 05, 2010 3:29 pm

im not experiencing allout crashes but I noticed the gif2swf utility they use POUNDS my CPU usage big time..... which then makes everything a little sluggish including airpanels that are remoted into my MLServer as clients.. if I shutdown weatherlobby my whole system is much more responsive....
-Christopher

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: mlserver crash

Postby CinemarDave » Fri Jan 08, 2010 12:11 am

Converting an animated gif to an swf requires a lot of cpu cycles. If your MLServer PC doesn't have the spare cycles then you should limit the number of animated maps you convert.

cadillackid
Senior Member
Senior Member
Posts: 155
Joined: Mon Jul 11, 2005 11:43 am
Location: Columbus, ohio
Contact:

Re: mlserver crash

Postby cadillackid » Fri Jan 08, 2010 2:45 pm

this is a dual core xeon machine with uber amounts of RAM and space... if I dont run the gif2swf converter tha machine is running at 25% load.....and that is with the following:
1] MLServer
2] Homeseer and 8 serial ports of hardware
3] my Internet radio station playout (SAM broadcaster).. which includes music playing, encoding. streaming
4] shoutcast server
5] web server
6] virtual server running linux and 4 security cameras (IP cameras that STREAM VIDEO!and are viewable as streamed on a browser)
7] 2 ML clients (airpanels in RDP sessions to this server running ML client)
8] Zoned HVAC control program
9] FTP Server
10] VPN server
11] vehicle GPS tracking server (which extracts maps and makes them GIFs for web viewing)
12] Light-O-Rama Christmas Light control software..

*ALL* of the asbove run and I get 25% CPU usage and about 2 gigs of RAM...

then when I run that one Little Gif2SWF utility it hammers it up to 90%??? something is really wrong here because im doing a Heck of a lot of intensive stuff on that machine and it doesnt hammer it nearly what the utility does.. im only picking down 1 MAP.. animated radar.. it seems that it keeps updating more than just once every 20 minutes like I have it set in the configuration...
-Christopher

cadillackid
Senior Member
Senior Member
Posts: 155
Joined: Mon Jul 11, 2005 11:43 am
Location: Columbus, ohio
Contact:

Re: mlserver crash

Postby cadillackid » Fri Jan 08, 2010 3:08 pm

I didnt see till now there is a .21 update... I loaded it and it seems my CPU is not being slammed now.. only taking it up to about 50% and just momentarily which is more than acceptable..
-Christopher


Return to “WeatherLobby Questions & Answers”

Who is online

Users browsing this forum: No registered users and 1 guest