Library 30 (Koa) graphic question

Add visual flare to your interface with our professionally designed GuiGraphix Libraries.
User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Library 30 (Koa) graphic question

Postby DaveB » Tue Jun 19, 2012 11:17 am

Dave - I finally jumped into KOA. I see some good possibilities with graphics that match our decor. I was playing around with the scenes, making some of the newest v4 stuff work. On the climate scene, i have converted it to v4 HAI. Works well with the exception of The temperature bar indicator 0030_0318. I can not seem to make it do anything. What value is that graphic looking for? I have labeled it with the interior temperature from HAI, which is working fine in the thermostat display. I know that the data is there.
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Library 30 (Koa) graphic question

Postby DaveB » Tue Jun 26, 2012 8:00 am

Dave - Just refreshing this one that you may have missed. Please see above.

Also, another question; This is an old problem that has resurfaced. In the weather scene for Koa, the small map view does not match the large view when pressed. They are the same maps, it is just that the small view is old and does not seem to get updated. I can not figure out why since they are from the same source. I know that this is an old issue and can not recall the fix. I did clear the cache.
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Library 30 (Koa) graphic question

Postby CinemarDave » Tue Jun 26, 2012 11:03 am

Make sure the server variables you use in the label are in all lower case. There was a case sensitivity issue with some of those objects and maybe that one was missed.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Library 30 (Koa) graphic question

Postby DaveB » Tue Jun 26, 2012 12:53 pm

I changed all to lower case. I did notice that the small view, which is called via the web server get image method, contains maps from days prior.

The call from the thumbnail view in the main weather scene is:

Code: Select all

http://{{server_servername}}:6246/getimage?{{weather_map{{weather_active_map}}_url}}|width=300|height=200


The call from the Map scene is:

Code: Select all

Label:  {{weather_map{{weather_active_map}}_url}}~768~480

JPG Image: {{weather_map{{weather_active_map}}_url}}


I see no difference in the two calls. It is the main weather scene small map view that is not the correct version and seems to be getting updated randomly. Not all of the maps are form the same day for instance.
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Library 30 (Koa) graphic question

Postby DaveB » Tue Jun 26, 2012 9:04 pm

Dave - The above plus this questions - Why does the correct theme load on start up of ML, but the background image for the home page not load? If I browse to any other scene, the background is correct, then back to the home page and it loads. I have tried this on my three screens and the server with the same results. Variables are saved on exit on the server.
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Library 30 (Koa) graphic question

Postby CinemarDave » Wed Jun 27, 2012 11:34 am

change the background image on the home page from the server variable reference to the image you want to use.

I do not know what the weather issue is. The lower case I was making reference to was from the first post concerning the temperature scale.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Library 30 (Koa) graphic question

Postby DaveB » Wed Jun 27, 2012 12:05 pm

Concerning home page, does that revision then break the ability to dynamically change the Theme?

Concerning Weather Maps: Where does the call via the web port then grab data from? What directory or cache area? Obviously, that cache area is not being updated by the v4 Weather driver, or at minimum, not being consistently updated.
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Library 30 (Koa) graphic question

Postby DaveB » Thu Jun 28, 2012 9:22 am

Dave - I checked into the weather map issue with Library 30 more. This is not a Library specific issue but a v4 server issue. However you are caching the map info into the web server, it is not being done in real time. The maps in the small view on screen are up to one day old, some as far behind as only a few hours. Maps are updated by weather.com about twice in 24 hours, some more frequently. Them small view on the scene contains the prior update to the current map in every case. The strange part, and part of the program that i do not understand is that when you click on the small view of the map and load the overlay of the larger view, that contains the most current map. Maybe you can ad some insight on how you are caching the map information and why the two are not the same. :D
Thanks!

Dave Bruner
:shock:


Return to “GuiGraphix Libraries”

Who is online

Users browsing this forum: No registered users and 1 guest