Touchscreens and 028 library button misbehavior

Add visual flare to your interface with our professionally designed GuiGraphix Libraries.
RZajcew
Intermediate
Intermediate
Posts: 257
Joined: Mon Jul 21, 2008 6:31 pm
Contact:

Touchscreens and 028 library button misbehavior

Postby RZajcew » Fri Apr 01, 2011 12:12 am

I'm running latest version of MainLobby. I have two types of touchscreen clients -- MSI 2020 All-in-one computers running Windows 7 (32 bit) and an HP Touchsmart tm2 laptop running Windows 7 (64 bit). And I am seeing very strange behavior of Library 28, button 4.

Looking at buttons 0028_0004, 0028_0006, and 0028_0007. Button presses behave perfectly normally if I use a mouse (not using the touchscreen) (on all my clients). That is, clicking 0028_004 causes the white outline to move from the bottom to the top, and then immediately to return. For 0028_0006 and 0028_0007, a single button click causes the white outline to move from the bottom to the top, and then it stays there. However, when using a touchscreen (on both the MSI AIO and the HP Touchsmart), the buttons behave inconsistently.

- For button 0028_0004, about 3/4 the time, touching the button has no effect. I mean, I can see the "touch indicator" from Windows 7 in the correct place, but nothing happens. If I touch the button again, it works correctly (the gap between touches can be several seconds). If I touch one button, then a second button, then the first button, usually I will end up with no activity.

- For button 0028_0006 and 0028_0007, about 1/2 the time the button behaves correctly (the white outline moves from the bottom to the top). However, the other 1/2 the time, the white outline moves to the top of the button and then the white outline immediately goes back to the bottom of the button.

I'm not sure I truly understand how 0028_0006 and 0028_0007 are supposed to behave. But I do understand 0028_0004. And all these buttons behave very inconsistently with both types of touchscreens I use.

- Roman

User avatar
MHd
Member
Member
Posts: 81
Joined: Sun Mar 09, 2008 9:35 pm
Location: Sedona, Arizona
Contact:

Re: Touchscreens and 028 library button misbehavior

Postby MHd » Thu Apr 21, 2011 12:15 am

Looking into this... See my PM. If anyone else sees these same issues let me know.

Margaret


Return to “GuiGraphix Libraries”

Who is online

Users browsing this forum: No registered users and 1 guest