GuiGraphix Designer Library 0026 (Lodge) released

Add visual flare to your interface with our professionally designed GuiGraphix Libraries.
User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Thu Sep 04, 2008 8:53 pm

David P;
The only issue I see so far is with iTunes and the volume level indicator on the nav layer, and between the up and down volume buttons. It does not indicate anything. Look like the correct variable is attached, just the wrong graphic.

I will check out the rest and let you know of issues.
Thanks!

Dave Bruner
:shock:

User avatar
MHd
Member
Member
Posts: 81
Joined: Sun Mar 09, 2008 9:35 pm
Location: Sedona, Arizona
Contact:

Itunes Nav

Postby MHd » Thu Sep 04, 2008 9:45 pm

Thanks for pointing that out so quickly. I will fix the volume indicator on the Nav.

Margaret

User avatar
cborod
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1208
Joined: Fri Oct 07, 2005 5:26 pm
Location: Mount Gretna, PA
Contact:

Postby cborod » Thu Sep 04, 2008 9:49 pm

Not sure about whether all the new functions really work......but this update is very much appreciated. Nice additions, the new RSS/Stocks page, irrigation and itunes...Xcellent.

Right now I'm looking for some lightweight, serious but pleasant icon items to adapt as buttons on the home page to link RSS, Drinks, News, email, etc. Something tasteful that fits with the mood of this package. I fear too many words cluttering the page and thought pictures / icons could be used instead. (like what you did for horoscopes)

Calendar integration helps too...this really is a showcase library. Thanks! Thanks! Thanks!
ChrisB


___________________________________
"Round up the usual suspects."

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Fri Sep 05, 2008 6:44 am

I agree with Chris - I do not care for how the additional navigation buttons were placed at the upper right of the screen. They do not fit the overall design and tend to clutter the scenes. The real beauty of this interface is simplicity, and I am attempting to carry that theme on all scenes I design.

I have already changed this implementation to the navigation bar style with the left and right arrows, and I am calling a second set of nav buttons at the bottom. This fits the overall design better in my oppinion.

Same with the iTunes Home and Back buttons - work fine, but a poor choice of graphics and colors.
Thanks!

Dave Bruner
:shock:

User avatar
MHd
Member
Member
Posts: 81
Joined: Sun Mar 09, 2008 9:35 pm
Location: Sedona, Arizona
Contact:

New icons for home page

Postby MHd » Fri Sep 05, 2008 11:46 am

Hi there,

I have to agree with the icon suggestion. Originally I thought it might look strange with all different icons in different colors. But I could make them all equivalent to the horoscope. They would be subtle and hopefully not look too busy.

The itunes nav is probably personal preference. I liked them to stand out and there were already alot of arrows being used. Anyhow I will look at it some more, but don't know if I will change it.

Also as far as functionality... Thought it was all equivalent to Marios, but davep and I will look at it all again.

Margaret

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Fri Sep 05, 2008 12:10 pm

Thanks! Still great job on the revisions. :D The beauty of this system is we can all change items to just our liking.

Everything does seem to function just fine, with the exception of the web items, but that has nothing to do with the library or work you have done.
Thanks!

Dave Bruner
:shock:

Cecil
New Member
New Member
Posts: 39
Joined: Sun Apr 09, 2006 10:42 pm
Contact:

Postby Cecil » Fri Sep 05, 2008 12:30 pm

None of the RSS links are working for me. Maybe it's because I have my RSS feeds set to Fox and not CNN. :-)

Anyway, I can't parse what this command is trying to do.

Macro|MLScript|Replace~Tilde~mlrss_feed_001_item_003_link!SetVariable|rss_activelink~{{mlrss_feed_001_item_003_link}}

Should it be MLStrings rather than MLScript? Or is there some Replace script I need to load into MLScript.

When run as shown, the value in the Rss_activelink variable is always set to "http://feeds.foxnews.com/"

Here is the original MLRss link variable "http://feeds.foxnews.com/~r/foxnews/latest/~3/384309062/0,2933,417461,00.html" This URL works fine when I cut/paste it into a browser.

As others have said, great update, I just can't get the RSS section to work either from the home page or the separate RSS page.

Cecil

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Fri Sep 05, 2008 12:34 pm

At the end of the Lodge server install there was a note that said you had to import the file called Lodge.scripts into MLScript. We cannot do that automatically but there are two MLScripts in there that the Lodge scenes require. One of those is a script that fixes tildes in URL so that they do not break WebLobby. CNN uses a lot of tildes in their URLs. Load the missing scripts file and see if that helps. If it doesn't then we'll continue to work on it.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Fri Sep 05, 2008 12:35 pm

Did you import the script file into MLScript as instructed in the installer splash screen?
Thanks!

Dave Bruner
:shock:

Cecil
New Member
New Member
Posts: 39
Joined: Sun Apr 09, 2006 10:42 pm
Contact:

Postby Cecil » Fri Sep 05, 2008 1:10 pm

OK...so I can't follow directions very well. I just skimmed the message and assumed it applied to the command maps from the next screen of the installer. Violated rule #1: READ THE *&#$@# INSTRUCTIONS.

Have now installed the scripts and re-started ML server. Rss_activelink variable now gets correct value.

This seems to have generated another set of strange behavior.

1) When I click on the RSS feed links, the rss feed window opens correctly. However nothing displays. After a second or so pause, a new Internet Explorer window opens up with the correct page (the one that should have displayed in on the rss reed window.)

2) When I start the ML Client, it, after a short pause on the home page, it always the automatically switches to the last page I was viewing before I quit ML Client.

Any ideas?

Thanks,
Cecil

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Wed Sep 10, 2008 7:14 pm

Version 3.0.7 of Library 0026 has been republished. You will see new images on the home page for RSS, Web and Drinkfinder. The iTunes pages now include the volume progress bar.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Sun Sep 21, 2008 11:13 am

Dave -

I finally implemented the changes and they look good. The only issue I have is with the drink finder keyboard pop up. When I hit cancel or Save, the screen slides away and the keyboard stays. I need to dig into the issue. I have more trouble with keyboards than anything else in the system.

On the design side, the only complaint I am getting from the family is once more with the buttons on the main toolbars. There are two issues; They should have more definition and you can not tell when they are pressed (or missed).

I can change the color to provide definition. The press movement/alternate press color should have more definition as I can not change these settings. The existing buttons have too much of a membrane feel and look.
Thanks!

Dave Bruner
:shock:

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Postby rileydog » Sun Sep 21, 2008 9:29 pm

I use 026 too and I can't get the on screen keyboards to work either. Really frustrating - I am trying to figure out the command maps and I have KB.save et al and they look OK for me...

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Postby rileydog » Mon Sep 22, 2008 7:07 am

Just FYI - I got the keyboards working - what I had to do was to create 2 new server commands - KB_cancelactiontest and KB_Saveactiontest -- I just duplicated the KB.Cancel and KB.Save commands and renamed them accordingly.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Mon Sep 22, 2008 7:52 am

Yea - I also figured it out. SOmehow, with the latest rendition of library 26, the wrong keyboard got included. I went through this 4 weeks ago, and in the end, figured out that the commands were hard coded to the buttons, and that the buttons were calling the macros as you stated.
Thanks!

Dave Bruner
:shock:


Return to “GuiGraphix Libraries”

Who is online

Users browsing this forum: No registered users and 2 guests