Playing ISO from NAS on client

Discuss topics related to the plugins and uses for MLServer beta
donaldeweaver
Senior Member
Senior Member
Posts: 107
Joined: Thu Dec 27, 2007 9:03 am
Location: Indiana
Contact:

Playing ISO from NAS on client

Postby donaldeweaver » Thu Nov 20, 2014 2:04 pm

I looked for newer posts on the subject but didn't find a direct match to this. Looks like TheaterTek is dead.
In version 3, I used Daemon Tools to mount an ISO file and TheaterTek to play it. It works very nicely.

I used the following commands to mount and unmount my ISO files on a specific HTPC (called Medusa).

Sys.Medusa|Send~Run~C:\Program Files (x86)\DAEMON Tools Lite\DTLite.exe -unmount 0!
Sys.Medusa|Send~Run~C:\Program Files (x86)\DAEMON Tools Lite\DTLite.exe -mount 0,"\\Byanus\media\Movies\\{{movies_selection_fixedtitle_{{clientname}}}}.ISO"!

These commands no longer work in v4. What is the version 4 equivalent to accomplishing this?
I've tried using the command builder to put together the command but I couldn't find an exact match. I tried some variations of the following:

MLCmd|System~Medusa~Run~C:\Program Files (x86)\DAEMON Tools Lite\DTLite.exe -unmount 0

In addition, it looks like I'll be using MPC for v4 instead of TheaterTek as that seems to be what many are doing. Is there a better way to play ISO's than what I'm trying to do with Daemon tools?

Thanks for all those who have been providing input. I've had a lot of posts lately (and more coming) as I'm trying to get some main components working and get the WAF prior to making the switch to v4 (and hardware upgrades).
-Don

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Playing ISO from NAS on client

Postby CinemarDave » Thu Nov 20, 2014 7:24 pm

You'll want to use the V4 AVAgent for all of this. You'll see a tab on the Agent called ISO / Archiving Support. You'll define the path to Daemon tools there and the drive letter you want to use. After that you can use any of the supported movie players. When the AV Agent sees that an .iso file is being played i will automatically mount the title and then tell the movie player to play the movie from the mounted drive.

MPC should play them fine.

donaldeweaver
Senior Member
Senior Member
Posts: 107
Joined: Thu Dec 27, 2007 9:03 am
Location: Indiana
Contact:

Re: Playing ISO from NAS on client

Postby donaldeweaver » Sun Nov 23, 2014 9:44 am

Setup the AV Agent as suggested. It kept giving me an error with Daemon Tools Lite so I switched to Slysofts VCD. It doesn't seem to work with drive letter higher than F, but that's fine for now. Also had to remove autoplay as it keep trying to load MPC too quickly. Other than that it works seamlessly.

Thanks for the info. It would be nice for others if the AV agent/VCD/MPC setup were included in the wiki.

-Don


Return to “MLServer Questions & Answers”

Who is online

Users browsing this forum: No registered users and 1 guest