Yamaha AV family Driver converting volume values

Discuss topics related to the plugins and uses for MLServer beta
Dkip
New Member
New Member
Posts: 27
Joined: Sun Feb 26, 2006 1:25 pm
Contact:

Yamaha AV family Driver converting volume values

Postby Dkip » Sat Sep 17, 2016 11:34 am

Hopefully some one has seen this and I am not the only one. I have done a bunch of searching on the forum but it has not pop up
It seems the math for volume in the AV Yamaha family driver is incorrect
When I enter a command like "AV|1~Volume~Main~40" the driver converts it to TX:1 - @MAIN:VOL=-41.7
the problem here is the amp RX-A 3030 will only accept values rounded to the nearest .5
Is there a way I could get the driver to round the math to a hole number.
this is preventing me from being able to use sliders

Thanks

indecision
Intermediate
Intermediate
Posts: 431
Joined: Wed Jul 14, 2004 12:23 pm
Contact:

Re: Yamaha AV family Driver converting volume values

Postby indecision » Sat Sep 17, 2016 1:00 pm

I use the yamaha driver but have never asked it to send a specific volume setting to my RX-A2010. I will give it a shot and let you know what happens.

Davis

indecision
Intermediate
Intermediate
Posts: 431
Joined: Wed Jul 14, 2004 12:23 pm
Contact:

Re: Yamaha AV family Driver converting volume values

Postby indecision » Sat Sep 24, 2016 7:05 am

Dkip,

I am seeing the same thing. 40 shows as sending -41.7. If I send 20, the plugin pushes -61.1. So my receiver responds as @UNDEFINED.

Davis

Dkip
New Member
New Member
Posts: 27
Joined: Sun Feb 26, 2006 1:25 pm
Contact:

Re: Yamaha AV family Driver converting volume values

Postby Dkip » Thu Oct 06, 2016 3:17 pm

Thanks for checking

I thought it may be a driver issue. The amp will only recognize a value rounded to the nearest .5 so it is hit or miss when using sliders
I would be happy even if it always rounded up to the nearest hole number


Return to “MLServer Questions & Answers”

Who is online

Users browsing this forum: No registered users and 1 guest