BUG: Album art isn't changing

Report any bugs you may notice in either MusicLobby or MusicLobby Pocket PC
User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Tue Feb 05, 2008 10:12 pm

Jeff's coverart process was added to the wiki since he was feeling lazy :)

Thanx for the contribution.

jeffdoo
Intermediate
Intermediate
Posts: 329
Joined: Sat Aug 25, 2007 9:19 pm
Location: Huntersville, NC
Contact:

Postby jeffdoo » Wed Feb 06, 2008 9:22 am

Thanks for posting those details to the wiki! I just hope all of the instructions are written well enough for someone to follow without too much trouble.

Regarding v3.0.31 hanging MediaCenter .. go here:

http://www.cinemaronlineforums.com/forum/viewtopic.php?p=80331


Thanks.

- Jeff
Last edited by jeffdoo on Wed Feb 06, 2008 3:22 pm, edited 2 times in total.

jeffdoo
Intermediate
Intermediate
Posts: 329
Joined: Sat Aug 25, 2007 9:19 pm
Location: Huntersville, NC
Contact:

Postby jeffdoo » Wed Feb 06, 2008 1:29 pm

[Post deleted....]

- Jeff
Last edited by jeffdoo on Wed Feb 06, 2008 3:21 pm, edited 1 time in total.

Funboy
Intermediate
Intermediate
Posts: 294
Joined: Sat Mar 01, 2003 9:54 pm
Contact:

Postby Funboy » Wed Feb 06, 2008 2:30 pm

Guys, not to be a pain but can we split this discussion off onto another thread?

I'd really like to keep this thread focused on the album cover art missing. It's near and dear to my heart, and I'm waiting with bated breath for Dave to get a new OCX out for testing.
- Funboy

jeffdoo
Intermediate
Intermediate
Posts: 329
Joined: Sat Aug 25, 2007 9:19 pm
Location: Huntersville, NC
Contact:

Postby jeffdoo » Wed Feb 06, 2008 3:23 pm

Funboy wrote:Guys, not to be a pain but can we split this discussion off onto another thread?


Sure, hijacking my thread :wink: ... but I do agree and have opened a new thread and removed the postings from here (as best as possible).

- Jeff

Funboy
Intermediate
Intermediate
Posts: 294
Joined: Sat Mar 01, 2003 9:54 pm
Contact:

Postby Funboy » Fri Feb 08, 2008 2:44 pm

Dave any update on this?

I'd hate to have to update all of my cover art to unique names.

thanks
- Funboy

interruptvector
New Member
New Member
Posts: 48
Joined: Sat Oct 07, 2006 5:28 am
Contact:

ditto...

Postby interruptvector » Sun Feb 10, 2008 3:26 pm

Ditto what Funboy said for me as well... ;)

indecision
Intermediate
Intermediate
Posts: 431
Joined: Wed Jul 14, 2004 12:23 pm
Contact:

Postby indecision » Sun Feb 10, 2008 5:30 pm

I have been playing around trying to find an easy way to convert my cover art. So far I haven't had any luck finding an easy automated process. I thought that one of the cover art downloader programs would make it happen there is still too much to do manually. If anyone has suggestions fire away.

Thanks,
Davis

Funboy
Intermediate
Intermediate
Posts: 294
Joined: Sat Mar 01, 2003 9:54 pm
Contact:

Postby Funboy » Sun Feb 10, 2008 5:35 pm

>If anyone has suggestions fire away.

I live by the adage "fix the problem".

My suggestion...wait for Dave to fix the OCX ;-)
- Funboy

indecision
Intermediate
Intermediate
Posts: 431
Joined: Wed Jul 14, 2004 12:23 pm
Contact:

Postby indecision » Sat Feb 16, 2008 9:22 am

I'm waiting. Just missing my cover art. Any progress?

Thanks!

User avatar
ccarpenter1
Member
Member
Posts: 74
Joined: Sun Dec 10, 2006 7:49 pm
Contact:

Cached Problem for Cover Art Still Exists

Postby ccarpenter1 » Sun Feb 17, 2008 9:45 pm

I really need to get some help on getting this coverart working with the folder.jpg method. Otherwise, I have a big job ahead of me to rename all of these files.

I did some more investigation and noticed that there is definitely a caching problem on the cover art and thumbnails. For the longest time, I was getting the same coverart and thumbnails for all screens and I could not figure out where it was coming from. I deleted all the folder.jpg image files that I thought were being cached in the IE temp folder only to find it would be recreated when I launched MusicLobby again. After running Process Monitor, I found that the IE cached files were being generated from files in the folder C:\Program Files\J River\Media Center 12\Plugins\100_100_Folder.jpg and 202_202_Folder.jpg. These files had the troublesome images. Once I deleted these images, MusicLobby then had different images, but unfortunately the images still would not change from the new image. My hunch is that these files are somehow related to the images displayed in MusicLobby. I am wonderig if each time a thumbnail needs to be generated, these files should have been updated and then cached into IE.

Thoughts?

Any help would be greatly appreciated!

jeffdoo
Intermediate
Intermediate
Posts: 329
Joined: Sat Aug 25, 2007 9:19 pm
Location: Huntersville, NC
Contact:

Re: Cached Problem for Cover Art Still Exists

Postby jeffdoo » Sun Feb 17, 2008 10:05 pm

ccarpenter1 wrote:I really need to get some help on getting this coverart working with the folder.jpg method. Otherwise, I have a big job ahead of me to rename all of these files.

I did some more investigation and noticed that there is definitely a caching problem on the cover art and thumbnails. For the longest time, I was getting the same coverart and thumbnails for all screens and I could not figure out where it was coming from. I deleted all the folder.jpg image files that I thought were being cached in the IE temp folder only to find it would be recreated when I launched MusicLobby again. After running Process Monitor, I found that the IE cached files were being generated from files in the folder C:\Program Files\J River\Media Center 12\Plugins\100_100_Folder.jpg and 202_202_Folder.jpg. These files had the troublesome images. Once I deleted these images, MusicLobby then had different images, but unfortunately the images still would not change from the new image. My hunch is that these files are somehow related to the images displayed in MusicLobby. I am wonderig if each time a thumbnail needs to be generated, these files should have been updated and then cached into IE.

Thoughts?

Any help would be greatly appreciated!


You have confirmed everything in this thread. You're at the same point as "funboy," "indecision," and "interruptvector". You can either find a software solution (unlikely so far) or wait for the software update which they (I believe) are all waiting for instead. For myself, I was re-ripping our who library to FLAC anyway (hopefully the last time) so I created the batch file earlier in this thread which pulls the art file from the FLAC file and name it appropriately (not folder.jpg).

Depending upon your music library directory structure the best option right now is to probably sit tight and wait for an update from Dave. But, if if you want to post your music directory structure I might be able to craft a batch file to rename the *jpg to something else but that's your call. I'm very particular about this and my music for JRiver is actually on the house server and not our primary file server.

- Jeff

User avatar
ccarpenter1
Member
Member
Posts: 74
Joined: Sun Dec 10, 2006 7:49 pm
Contact:

Music Lobby File Structure

Postby ccarpenter1 » Tue Feb 19, 2008 9:34 pm

Hi Jeff,

Any help you could provide would be greatly appreciated! I have attached a sample file structure from my server. If you have a sample batch file or program you could send me, I probably could modify for my file structure.

Thanks!
Chuck
You do not have the required permissions to view the files attached to this post.

jeffdoo
Intermediate
Intermediate
Posts: 329
Joined: Sat Aug 25, 2007 9:19 pm
Location: Huntersville, NC
Contact:

Re: Music Lobby File Structure

Postby jeffdoo » Wed Feb 27, 2008 9:34 pm

ccarpenter1 wrote:Any help you could provide would be greatly appreciated! I have attached a sample file structure from my server. If you have a sample batch file or program you could send me, I probably could modify for my file structure.


Sorry this took so long....

Attached is a batch file you WILL need to edit for your setup. I tried to put some useful comments at the beginning of the file. Basically you execute as follows:

renameJPG.bat folder.jpg

run it initially as-is, it will display the values for the rename command but won't do anything. If things look a little off then adjust the %%a, %%b, %%c, etc variables as needed and repeat the dry run. If everything looks good then remove the "REM" statement in front of the rename command and add REMs for the echos you don't want to see.

PLEASE make sure you have a backup of some sort!

Regarding Media Center v12 ... I only have one jpg in each folder, while you appear to have multiple files. I'm not certain how well the "Quick Find" is going to work in that situation. There is a setting I stumbled across for MC12:

Tools -> Options -> File Location

In the right panel, click the "down arrow" (ie; "V") next to "In the same folder as the file" and select "as [Artist] - [Album].jpg" AND make sure the checkbox for "Also store image in the file's tag" is NOT (repeat NOT) checked.

Now go to "Audio" to view your music library, highlight the whole library [select the first song, then press Ctrl + Shift + End], right click in the selected area, from the pop-up menu select "Cover Art -> Remove Cover Art", DO NOT remove the cover art from the hard drive. WAIT for all the tags to be saved (watch the message bar at the bottom of MC12). Now again, highlight the whole library, right click in the selected area, from the pop-up menu select "Cover Art -> Quick Find In File / Cover Art Directory" and cross your fingers it picks up the "[artist] - [album].jpgs" and not one of your other jpgs in the directory.

If everything works you'll have uniquely named cover art for each artist/album and your MusicLobby should work as expected.

Again, please make sure you have backups or test this some place safe!

Good luck!

UPDATE: Forgot to mention... the renameJPG.bat should be placed at the root of the music directory structure (ie; d:\music) ... not the root of the drive or you'll pickup more than you want....
You do not have the required permissions to view the files attached to this post.

User avatar
ccarpenter1
Member
Member
Posts: 74
Joined: Sun Dec 10, 2006 7:49 pm
Contact:

WOW, Thanks this is great

Postby ccarpenter1 » Sat Mar 01, 2008 8:08 am

Thanks so much Jeff for the script, I really appreciate it! I am trying to get everything organized and finished in the next couple of days. This will save me a lot of time.

I will let you know how it works.


Return to “MusicLobby Public Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest