Error at AddTrack Line 3840 - String or Binary Data would be

Please post general questions about using this product.
User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Error at AddTrack Line 3840 - String or Binary Data would be

Postby simonmason » Sat Jan 19, 2013 10:13 am

It seems like this is related to the length of a field? Any pointers on which field is causing this and I can look into shortening it in JRMC before importing? Thanks.
Simon D. S. Mason

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10548
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Error at AddTrack Line 3840 - String or Binary Data woul

Postby CinemarDave » Sat Jan 19, 2013 12:49 pm

It is either the track title or the path to the file that is greater than 255 characters. I'll assume that it is the title because Windows cannot process files paths greater than 255 chars. I just updated MusicLobby so that it will truncate the title of it exceeds 255 characters. This should resolve the issue.

indecision
Intermediate
Intermediate
Posts: 431
Joined: Wed Jul 14, 2004 12:23 pm
Contact:

Re: Error at AddTrack Line 3840 - String or Binary Data woul

Postby indecision » Sun Jan 27, 2013 2:01 pm

Dave,

I am still seeing that error for one of my entries. Is it possible to view the database to see the record at the referenced line?

I seem to be having several issues with MusicLobby. I have been struggling with it for a few weeks. I was trying to clean up some of my "various artist" albums and make them display correctly and in many cases MuL doesn't see the tag changes. I have initialized the database several times. Over the past few days it is not finding some of my music when I re-build the database, but after re-scanning 3 to 4 times it usually picks up everything. But now some of the coverart is incorrect even though it has been correct in previous scans over the past several days. Strange stuff.

Thanks,
Davis

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10548
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Error at AddTrack Line 3840 - String or Binary Data woul

Postby CinemarDave » Sun Jan 27, 2013 3:20 pm

Instead of just trying to re-import the entire database again. Run this experiment.

1) Initialize the database.
2) Delete everything in the MLServer\Cache\Music folder
3) Delete everything in the MLServer\Images\Music folder
4) Have MusicLobby re-scan the music folder with MusicLobby events written to a file
5) If possible identify some of the songs that did not get imported.
6) Install LogMeIn on the server. Send me your LogMeIn credentials, the access code to the PC and the list of songs that did not get imported. I will then remote in and investigate.


Return to “MusicLobby Questions & Answers”

Who is online

Users browsing this forum: No registered users and 1 guest