Multiple Variables in a text button

Report any bugs here that you may have found in MainLobby
Big Bob
Posts: 289
Joined: Sun Aug 29, 2004 1:01 pm

Multiple Variables in a text button

Postby Big Bob » Wed Sep 13, 2006 11:49 am


There appears to be a problem with button values updating when more than one MLS variable is included in the label field of the button.

My WeatherLobby scenes have a text button with the following in the label "{{mlweather_location}} - {{mlweather_forecast_1_day}}, {{mlweather_forecast_1_date}}" which should return "Pittsburgh, PA - Wednesday, Sep 13", and it does when the button is first set up.

But, when in launch mode and the location is changed, via another button in the scene, the location value does not change in the text button. If you edit the button, you see the updated value, but no update occurs in launch mode. I've tried this with all 4 text button - MultiLine, SingleLine, SingleLine2 and TextBox; along with button 0014_0001 - and gotten the same results.

Also - it appears to be related to having different variables in the label rather than just multiple variables. For example, if I substitue "{{mlweather_location}} - {{mlweather_location}} - {{mlweather_location}}", I get "Pittsburgh, PA - Pittsburgh, PA - Pittsburgh, PA" and the text updates when I change the location.

Hope this makes sense.


User avatar
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi

Postby mcascio » Mon Sep 18, 2006 12:22 pm


I would recommend creating a variable in MLServer of your choice:
mlweather_complete = {{mlweather_location}} - {{mlweather_forecast_1_day}}

Then put in your label: {{mlweather_complete}}

This lets MLServer do all the heavy lifting. :)
Mario Cascio
Cinemar, Inc.

Return to “MainLobby Public Bug Report”

Who is online

Users browsing this forum: No registered users and 1 guest