I am new to this...

Topics related to the new MainLobby Web Designer software for Android and iOS devices.
Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

I am new to this...

Postby Blade » Fri Feb 12, 2016 9:54 am

OK I am finally getting around to checking this out.
I will only be using our iPhones and iPads/Android tablets and I am curious the best way to approach this.
Will I have to create a whole system for each type of device? That could be a lot of work.

I loaded up the sample ipad pages last night. I tried to play music and Pandora but it did not do anything. Tried to select the source but it did not do anything. I must be missing something.

Any hints anyone could provide would be very helpful

Thanks

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: I am new to this...

Postby CinemarDave » Fri Feb 12, 2016 1:15 pm

Because of the different hardware aspect ratios on the devices you do need separate apps. You could create an iPad app and then use that same app on an Android tablet but it will not fill the screen on the Android device.

All the sample apps work but they do not know the details of your environment/setup. For instance the zones and sources on the bottom navigator are built from cyclestates values and those need to be customized to match your setup.

To just play Pandora without the zones and cyclestates involved click on the settings button that brings up the graphic equalizer and select the radio you want to play. Once you've done that you can then select a Pandora station and start playing.

Same holds true for all the other apps. There is always a settings button that lets you prime the app.

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: I am new to this...

Postby Blade » Fri Feb 12, 2016 5:40 pm

Thanks Dave
I will play around with it.

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: I am new to this...

Postby Blade » Fri Feb 12, 2016 5:44 pm

OK using the FX button on both worked

On the home screen what is the source and zone selection - they do not seem to do anything

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: I am new to this...

Postby CinemarDave » Fri Feb 12, 2016 6:09 pm

Zones and sources will not do anything by default. They need cyclestate variables defined to make them work. In the MLServer\Data folder you should see sample zones and sources cyclestates files. You could import them and then start making the modifications to customize them to your home.

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: I am new to this...

Postby Blade » Sun Feb 14, 2016 1:01 pm

I have the Weather app set to metric but in the pages it seems to go back and forth between celsius and fahrenheit
Any ideas?

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: I am new to this...

Postby Blade » Sun Feb 14, 2016 1:39 pm

I use Plex Media Server to play movies.
I added the Plex driver and it is synchronizing but I do not see how to use it with the html 5 ipad sample. The movies page seems to use DVDLobby
What am I missing?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: I am new to this...

Postby CinemarDave » Sun Feb 14, 2016 5:00 pm

Check the startup macro on the main weather.html page. It is probably setting the temp units to F there.

There is a separate set of scenes just for Plex. You should see a serials of Plex* files in the project folder. These will replace the Movie files and should be called installed of the Movie files. I am attaching the sample plex scenes just in case they are not in your project folder.
You do not have the required permissions to view the files attached to this post.

Blade
Expert
Expert
Posts: 760
Joined: Tue Nov 09, 2004 9:38 pm
Location: Lucan, Ontario
Contact:

Re: I am new to this...

Postby Blade » Sun Feb 14, 2016 5:16 pm

That worked - thanks


Return to “MainLobby Web Designer (V5)”

Who is online

Users browsing this forum: No registered users and 1 guest