Remote Access via Web

Topics related to the new MainLobby Web Designer software for Android and iOS devices.
User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 9:58 am

Dave - Is there a guideline that you can point me to for assistance in setting up remote web access? I have been using the HAI web app for years, but it has limitations. I would like to develop a slim interface for my iPhone to allow access to Alarm, Lighting, Cameras and Climate. I do not need remote access for media.
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Remote Access via Web

Postby CinemarDave » Fri Dec 11, 2015 10:40 am

Start with the sample iPhone web app.
Create a dyndns account (or the equivalent) and get yourself set up with a public IP Address e.g. daveb.dyndns.org
Set your MLServer dns name to be your public dns name. Restart MLServer
Next go to your router
Forward port 8080 to port 80 on your MLServer PC.
Forward port 8181 to port 8181 on your MLServer PC.
Forward port 6246 to port 6246 on your MLServer PC.

To test that this all works open Safari or Chrome on your phone and browse to
http://daveb.dyndns.org:8080/ipad/index.html

If the page opens save the page as a shortcut on the home screen and go have a cold brew.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 11:10 am

Thanks Dave -
I switched over to NoIP rather than DynDNS when DynDNS started charging to access about a year ago. I will get the ports configured.

Thanks
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 12:29 pm

Dave -
I now recall my issue with this;

The Comcast provided cisco router will not allow external forwarding to port 80. See below.

Forwarding1.PNG
You do not have the required permissions to view the files attached to this post.
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Remote Access via Web

Postby CinemarDave » Fri Dec 11, 2015 1:19 pm

Set the end port to 8080 and then tell MLServer to use port 8080 for its user web port.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 1:43 pm

Dave - Changing the MLS DNS name to the external name broke more than it helped. The short list is streaming (to the local machine, however web streaming works), thumbnails for stations, Fan Art, Weather icons, weather icon thumbs and I am sure the list goes on. Hey, the bonus is remote access worked, but only briefly and until I changed the MLS DNS back to the MLS machine IP address. It is almost like you need to develop and internal and external network setting on different ports. It gets much more complicated than that.
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 1:54 pm

CinemarDave wrote:Set the end port to 8080 and then tell MLServer to use port 8080 for its user web port.


That is what I did and it worked, but with the other issues as noted. Most issue are with thumbnails and fan art.
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Remote Access via Web

Postby CinemarDave » Fri Dec 11, 2015 1:55 pm

No you don't. I work with other customers all the time with this. You just have to give the system enough time to refresh its images et al.

Also all the internal devices must have their URLs changed so that they use the new port.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 2:36 pm

I changed all the internal devices without issue and can get to my web interfaces. I will let it go some and will let you know. The issues seem to be isolated to thumbs, weather icons, fan art.

The interface works well via the cell network or external network.

Did you ever implement the DynDNS settings from within MLS?
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Remote Access via Web

Postby CinemarDave » Fri Dec 11, 2015 2:50 pm

Yes the server fully supports DYNDNS syncing. It's in the options.

Double check that port 6246 is flowing out. That's the port all the images are served on.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 3:55 pm

Look like 6246 is open in the MLS machine fire wall and also port forwarded in the exterior firewall. Both internally and externally I am getting the same issues.

No weather icons, no fan art in Pandora or songza.

Album art works in songza and sat radio.

My cameras work and my news thumbs all work.

Art is broken in receipts and Bar.
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 6:32 pm

Dave

I may have found a clue as to why this is not working. See the error I captured in Chrome when viewing locally.

Failed to load resource: net::ERR_NAME_NOT_RESOLVED
2http://ziggy.noip.me.noip.me:6246/Cache/drinks/8754.jpg?57239644.0538


Failed to load resource: net::ERR_NAME_NOT_RESOLVED
http://ziggy.noip.me.noip.me:6246/Image ... /wx_97.png


Failed to load resource: net::ERR_NAME_NOT_RESOLVED
http://ziggy.noip.me.noip.me:6246/Image ... g?10204000


Notice how the links are attempting to resolve to .noip.me Twice.

Any Ideas?
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Remote Access via Web

Postby CinemarDave » Fri Dec 11, 2015 7:56 pm

How do you have the dns name defined in MLServer settings?

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 8:13 pm

It is set to

Ziggy.noip.me
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Remote Access via Web

Postby DaveB » Fri Dec 11, 2015 8:52 pm

Thinking about this, I may have it. I will test in the morning.

The computer name is Ziggy. I am browsing to Ziggy:8080/.... To get to the index page.

Maybe I am getting a loop back due to the DMS name. Long shot, but anything is possible.
Thanks!

Dave Bruner
:shock:


Return to “MainLobby Web Designer (V5)”

Who is online

Users browsing this forum: No registered users and 2 guests