iPhone 5 Web Interface issue

Topics related to the new MainLobby Web Designer software for Android and iOS devices.
User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

iPhone 5 Web Interface issue

Postby DaveB » Fri Nov 27, 2015 2:02 pm

Dave - I have had an issue for some time that I am just now getting back to. I slightly modified your iPhons5 sample interface, however use most of the pages as you have set up. My issue is with the Zones pop up list using web command

Code: Select all

/getdata/states/show/zones?fields=sval,sname


The pop up appears and the buttons on the list are accessible, however the name either do not appear or appear as the actual zone number and not the name. Sometimes the correct zone names do appear. I know it is all set up correctly in cycle states since my in wall Kiosk interface and my iPad tall interface both work without issues. I did note when attempting to diagnose this today that there is something up with the Footer.HTML file in the sample iPhone5 interface as it is not editable. My file is a copy of that file. I also noted that the iPhone interface appears to be the only sample that utilizes the pop-up list command with web commands. All other interfaces are just simple buttons.

Can you take a look at you sample when you have a chance and advise?

IMG_2051.PNG
You do not have the required permissions to view the files attached to this post.
Thanks!

Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: iPhone 5 Web Interface issue

Postby DaveB » Sun Nov 29, 2015 12:34 pm

I fixed it. First - The interface is not using the footer file. I found that the Zones file in the sample set had some very strange lines in the HTML. I deleted both that file and the copy of that file that I was using; Borrowed the iPhone 6 zones.html and modifies it to work with iPhone5. All is well. Who know where the file corruption originated.
Thanks!

Dave Bruner
:shock:


Return to “MainLobby Web Designer (V5)”

Who is online

Users browsing this forum: No registered users and 1 guest