Sample iPad App

Topics related to the new MainLobby Web Designer software for Android and iOS devices.
rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: Sample iPad App

Postby rileydog » Thu Dec 11, 2014 1:13 pm

Not sure if this is a "bug" but it is driving me nuts.

There are a lot of variables that populate when the play movie command in DVD Lobby is executed:

movies_nowplaying_{{lots of stuff}}_{{movies_activeplayer_{{clientname}}}}

But, these variables are not populated if a disc within a series is played - if I play a disc within a multi-disc series, all those variables do not change.

Is this a bug or my setup? I looked at my Play Movie command and I am not populating any of these variables. I wanted to use these variables to support my now playing scene

Thanks

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Sample iPad App

Postby CinemarDave » Thu Dec 11, 2014 2:35 pm

In all cases the DVDLobby|PlayMovie command is getting called. That in turn call the SetMovieVars routine to set all the server variables for the selected movie. Is DVDlobby events complaining about anything?

Also in the new samples {{movies_activeplayer_{{clientname}}}} is replaced with {{movies_activezone_{{clientname}}}} so that now playing is tied to a room and not a player.

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: Sample iPad App

Postby rileydog » Thu Dec 11, 2014 3:00 pm

OK - in the DVDLobby log - this is strange...

If I play a movie, it appears DVD Lobby is using {{movies_activeplayer_{{clientname}}}}
If I play a multi disc, it appears DVD Lobby is using {{movies_activezone_{{clientname}}}}

I have activeplayer set to "12" (my AV number) and activezone set to "Theater"

See enclosed screen shots when the play command is executed...
You do not have the required permissions to view the files attached to this post.


Return to “MainLobby Web Designer (V5)”

Who is online

Users browsing this forum: No registered users and 1 guest