Release Candidate #2

Topics related to the new MainLobby Web Designer software for Android and iOS devices.
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Tue Apr 02, 2013 11:17 pm

I spent some time on Ron's system this evening. The issue is that the updated embedded chrome browser control is using DirectX components that are not native to Windows XP. I tried the tricks that were suggested on their support site but it does not work. I’ll have to do more research on this in the morning. Are any non-Windows XP users having any issues with RC2?

EUROTECH
Senior Member
Senior Member
Posts: 229
Joined: Mon Aug 01, 2011 6:10 pm
Location: New Jersey
Contact:

Re: Release Candidate #2

Postby EUROTECH » Wed Apr 03, 2013 7:09 am

I'm running win7 64 on my designer machine. I updated to RC2 and everything looks ok. I did not go any further as I wanted to pull one of my backups before I went ahead and started changing things. I have a lot of sliders that need to be switched over.

Eurotech

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Wed Apr 03, 2013 10:01 am

Ok - Until we can get these DirectX isues resolved Windows XP users will have to keep using RC1. I've added the link to RC1 back into the Installation Assistant just in case you need to download it again. If you have to downgrade from RC2 to RC1 you will have to un-install RC2 from the Control Panel. Then delete the contents of the Cinemar\Designer folder. After that you can re-install RC1.

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: Release Candidate #2

Postby ronsatter » Wed Apr 03, 2013 9:26 pm

Thanks Dave.

Maybe it's a sign I should upgrade to Windows 7 8)

I'm going back to R1 for now.

Ron
If it ain't broke ... don't fix it!

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Fri Apr 05, 2013 5:11 pm

Update - RC2 Version 4.0.4843.26141

Today's update
1 - Adds the new Playsound client command (contains and updated scripts.js file)
2 - Fixes a horizontal slider paste issue reported earlier today.

This release does not contain any updates for the Windows XP users. We're still waiting on the fix from the people who write the embedded browser control.

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: Release Candidate #2

Postby ronsatter » Sun Apr 07, 2013 7:31 pm

Dave,

Any timeline for when R2 will be compitable with Windows XP?

Ron
If it ain't broke ... don't fix it!

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Sun Apr 07, 2013 7:42 pm

Unfortunately no. We are dependent on the developers of the embedded browser control we are using. In theory yesterday's release made us compatible with XP according to their tech notes but I do not think it did anything.

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: Release Candidate #2

Postby ronsatter » Sun Apr 07, 2013 9:59 pm

Are we (XP users) to assume there will never be a fix ... meaning an upgrade to Windows 7 is mandatory if we want to run the Web apps?

Ron
If it ain't broke ... don't fix it!

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Mon Apr 08, 2013 1:34 pm

No - but since I have no influence on the development of the embedded chrome browser control we are using we can only wait for the other developers to fix the issue. If I do not see anything forthcoming from them I can make a special build of the designer for XP users that uses the older embedded browser. I really do not want to introduce that headache into the mix but I will if I have too.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Mon Apr 08, 2013 2:15 pm

Ron, I'm going to remote into your server and test something with the designer.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Mon Apr 08, 2013 2:33 pm

Version 4.0.4846.19935 - 04/08/2013

This version
1) Will automatically renumber objects when you do a "Save As". This should greatly reduce the likelihood of a duplicate object ID on an overlay.
2) Fixes the Windows XP issue. The Designer should now run normally on Windows XP PCs.
3) Adds a new AppExit client command. If you run the Web Apps in Kiosk mode this will now give you an option of closing the web app directly from the UI.

alr
New Member
New Member
Posts: 35
Joined: Wed Jun 22, 2011 6:41 pm
Contact:

Re: Release Candidate #2

Postby alr » Mon Apr 08, 2013 3:26 pm

Dave,
Works fine. Thanks.Did they fix the browser or is this a special build?
Al

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Release Candidate #2

Postby CinemarDave » Mon Apr 08, 2013 3:31 pm

They offered up a fix for the embedded browser. No special builds.

alr
New Member
New Member
Posts: 35
Joined: Wed Jun 22, 2011 6:41 pm
Contact:

Re: Release Candidate #2

Postby alr » Mon Apr 08, 2013 3:33 pm

Great. Now for some fun.

alr
New Member
New Member
Posts: 35
Joined: Wed Jun 22, 2011 6:41 pm
Contact:

Re: Release Candidate #2

Postby alr » Mon Apr 08, 2013 10:35 pm

Dave,
The Home Button checkbox is missing under the button properties.
AL


Return to “MainLobby Web Designer (V5)”

Who is online

Users browsing this forum: No registered users and 2 guests