Pollen Bar Graph no longer working

Topics for the MainLobby 4 client
bpet
Senior Member
Senior Member
Posts: 225
Joined: Sat Aug 18, 2007 2:35 pm
Contact:

Pollen Bar Graph no longer working

Postby bpet » Thu Dec 04, 2014 10:30 am

The pollen_day1name does not seem to be correct, it shows Monday, while today is Thursday. The bar graphs also no longer appear. Is the pollen data no longer up to date? Weather app does shows "GetPollen - Retrieving Data for 33414" and so it seems that the data should be getting retrieved? My pollen page has not worked for months, I'm just getting around to working on it. Using most recent version of Weather App ...21792

Thanks for your help!

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Pollen Bar Graph no longer working

Postby DaveB » Thu Dec 04, 2014 10:42 am

Pollen only appears during the season. In my area, it stopped about two weeks ago and is now blank. It will pick back up around March or so.
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Pollen Bar Graph no longer working

Postby CinemarDave » Thu Dec 04, 2014 10:55 am

Thanks for letting me know. We get the pollen data from scraping the pollen.com web site and they have changed the layout of their pollen graph so I'll have to update the WeatherLobby app to compensate. Watch for the updated WeatherLobby.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Pollen Bar Graph no longer working

Postby CinemarDave » Thu Dec 04, 2014 3:33 pm

Just released a WeatherLobby update that should return the pollen data display back.

bpet
Senior Member
Senior Member
Posts: 225
Joined: Sat Aug 18, 2007 2:35 pm
Contact:

Re: Pollen Bar Graph no longer working

Postby bpet » Thu Dec 04, 2014 5:33 pm

The MLServer variables seem to be updated now, but the bar in the bar chart is still not showing? It is:
http://www.pollen.com/make_img.asp?d=0&v={{mlweather_pollen_day1level}} whre the variable shows %97bn in MLServer.

Thanks,
Brett

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Pollen Bar Graph no longer working

Postby CinemarDave » Thu Dec 04, 2014 6:24 pm

Ah, the Flash client. Need to fix that too.

bpet
Senior Member
Senior Member
Posts: 225
Joined: Sat Aug 18, 2007 2:35 pm
Contact:

Re: Pollen Bar Graph no longer working

Postby bpet » Fri Dec 05, 2014 6:58 pm

Ok, I'll keep an eye out for the fix, thanks! :)

I assume it will come in the form of an updated Weather App? Or is the flash client part of the Mainlobby Client?

Thanks again!

bpet
Senior Member
Senior Member
Posts: 225
Joined: Sat Aug 18, 2007 2:35 pm
Contact:

Re: Pollen Bar Graph no longer working

Postby bpet » Fri Dec 12, 2014 12:14 pm

Is that a quick fix...or something that is going to require a significant amount of work?...If its the latter, I can remove that scene for a while until you get an opportunity to get it working again...

Thx

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Pollen Bar Graph no longer working

Postby CinemarDave » Fri Dec 12, 2014 12:21 pm

You'll have it back before the weekend is over. I have higher priority items to get off the plate at the moment.

bpet
Senior Member
Senior Member
Posts: 225
Joined: Sat Aug 18, 2007 2:35 pm
Contact:

Re: Pollen Bar Graph no longer working

Postby bpet » Wed Dec 17, 2014 8:10 am

Would I expect to see an updated MLClient in the Installer, or is this in an updated MLServer?

Thanks,
Brett

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Pollen Bar Graph no longer working

Postby CinemarDave » Wed Dec 17, 2014 12:30 pm

Install the version of WeatherLobby I just released. You will have to make one set of changes on your scenes. The server variables {{weather_pollen_day1level}} through {{weather_pollen_day5level}} now contain the full url path to the pollen image. Make sure you remove any hard coded url information in the jpg path leaving only the server variable name.

bpet
Senior Member
Senior Member
Posts: 225
Joined: Sat Aug 18, 2007 2:35 pm
Contact:

Re: Pollen Bar Graph no longer working

Postby bpet » Wed Dec 17, 2014 5:55 pm

Works great, thanks for the fix!

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: Pollen Bar Graph no longer working

Postby DaveB » Sat Apr 02, 2016 10:35 am

Dave - I think that Pollen is no longer working. I have tried various locations that previously worked and nothing is downloading. I can not recall if you are using Weather Underground or TWC as the source.
Thanks!

Dave Bruner
:shock:

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Pollen Bar Graph no longer working

Postby CinemarDave » Sat Apr 02, 2016 1:28 pm

Pollen is broken. Pollen.com updated their website so Weather will have to be updated. We will still get the bar chart but the detail description as to what is going on with pollen is gone.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Pollen Bar Graph no longer working

Postby CinemarDave » Sat Apr 02, 2016 4:44 pm

The Weather App has been updated. Pollen data has been restored with one exception. The Pollen Description server variable should be removed from your scenes as it no longer contains valid data.


Return to “MainLobby 4 Client”

Who is online

Users browsing this forum: No registered users and 1 guest