Russound Driver Released

Topics for MLServer Device Drivers
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Russound Driver Released

Postby CinemarDave » Fri Aug 15, 2014 1:42 pm

I just updated the driver. It looks like for those events I should be looking at the SourceZone byte in the response string and not the TargetZone. Tested here with my CAV 6.6 on zone 5 and it now appears correct.

randyf
Member
Member
Posts: 55
Joined: Fri Jun 13, 2014 7:57 am
Location: Northern Virginia
Contact:

Re: Russound Driver Released

Postby randyf » Fri Aug 15, 2014 4:10 pm

Thanks Dave - I will give this a try tomorrow.

randyf
Member
Member
Posts: 55
Joined: Fri Jun 13, 2014 7:57 am
Location: Northern Virginia
Contact:

Re: Russound Driver Released

Postby randyf » Sat Aug 16, 2014 10:46 am

I've confirmed that the fixes that were made takes care of the problem with passing the proper zone to command macros - much appreciated Dave!

beerguy
Senior Member
Senior Member
Posts: 198
Joined: Mon Jan 16, 2006 10:44 pm
Contact:

Re: Russound Driver Released

Postby beerguy » Fri Aug 29, 2014 9:35 am

Dave, I installed the latest Russound driver and now I'm getting this and can't control my CAV6.6. It is serial control at com port 7:

PopulateDevices - Error at PopulateDevices at line #232 - Index was outside the bounds of the array.

Thanks for the help. Need music this weekend.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Russound Driver Released

Postby CinemarDave » Fri Aug 29, 2014 10:31 am

There is an issue with the latest version of MLServer that is affecting some drivers that were written in C# on some customers PCs. I'm working on it. If you have an older version of MLServer revert back to it in the meantime.

beerguy
Senior Member
Senior Member
Posts: 198
Joined: Mon Jan 16, 2006 10:44 pm
Contact:

Re: Russound Driver Released

Postby beerguy » Fri Aug 29, 2014 10:44 am

Thanks Dave. I don't have an old version. Can you send one so I can get back in business before this weekend?

Thanks. Pat

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Russound Driver Released

Postby CinemarDave » Fri Aug 29, 2014 10:44 am

I'll have it fixed shortly. What operating system are you running?

beerguy
Senior Member
Senior Member
Posts: 198
Joined: Mon Jan 16, 2006 10:44 pm
Contact:

Re: Russound Driver Released

Postby beerguy » Fri Aug 29, 2014 10:50 am

Windows 7 Professional

beerguy
Senior Member
Senior Member
Posts: 198
Joined: Mon Jan 16, 2006 10:44 pm
Contact:

Re: Russound Driver Released

Postby beerguy » Fri Aug 29, 2014 4:09 pm

Dave, if it's easier to just send an older version of MLServer for now that's fine. I'd just like to get it back going before the holiday weekend. Thanks.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Russound Driver Released

Postby CinemarDave » Fri Aug 29, 2014 4:11 pm

For technical reasons I don't have one to release without breaking a lot of other things.

beerguy
Senior Member
Senior Member
Posts: 198
Joined: Mon Jan 16, 2006 10:44 pm
Contact:

Re: Russound Driver Released

Postby beerguy » Fri Aug 29, 2014 4:26 pm

Are you still shooting to get a fix out today?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Russound Driver Released

Postby CinemarDave » Fri Aug 29, 2014 4:30 pm

Yes - this problem is only reproducible on a few PCs. I cannot reproduce it on any of my PCs in my home. I am working on a PC in Canada trying to figure out what the issue is. Trust me I want to fix this and I'm not going to stop until I have.

beerguy
Senior Member
Senior Member
Posts: 198
Joined: Mon Jan 16, 2006 10:44 pm
Contact:

Re: Russound Driver Released

Postby beerguy » Fri Aug 29, 2014 5:02 pm

Thanks for working on it. How about a previous version of the Russound driver? Mine worked fine until I updated the other day.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Russound Driver Released

Postby CinemarDave » Fri Aug 29, 2014 5:17 pm

It is not the Russound driver. Do you have any legacy plugins installed? Especially MLTimer. If yes can you rename your MLServer plugins folder to Plugins.offline and restart the server to see what happens.

beerguy
Senior Member
Senior Member
Posts: 198
Joined: Mon Jan 16, 2006 10:44 pm
Contact:

Re: Russound Driver Released

Postby beerguy » Fri Aug 29, 2014 5:23 pm

Yes, I have MLTimer. I renamed the directory and now the Russound driver works fine. Haven't tested anything other than that one.


Return to “MLServer 4 Device Drivers”

Who is online

Users browsing this forum: No registered users and 1 guest