V4 ISY Driver

Topics for MLServer Device Drivers
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: V4 ISY Driver

Postby CinemarDave » Wed Dec 17, 2014 7:21 pm

Very good.

User avatar
Oronomus
Intermediate
Intermediate
Posts: 346
Joined: Mon Aug 14, 2006 1:18 pm
Location: Atlanta
Contact:

Re: V4 ISY Driver

Postby Oronomus » Wed Jan 07, 2015 7:54 pm

In the command builder for ISY-Climate, there is not a specific command for Query. I tried a few combos without success. When you get a moment, can you please add a Query command to the command builder? The Insteon thermostats I have are notorious for not reporting back changes in temperature readings, etc. This is the response I get in the ISY Driver log to a manual Query using the ISY query function:

Thermostat-Query.JPG
You do not have the required permissions to view the files attached to this post.

tmcgowan
Senior Member
Senior Member
Posts: 201
Joined: Fri Nov 25, 2005 1:27 pm
Location: Grosse Ile, MI
Contact:

Re: V4 ISY Driver

Postby tmcgowan » Wed Jan 07, 2015 11:03 pm

What I used to do (before I changed out my Insteon thermostats over to NESTs) was to create a program in the ISY to query the thermostats, and then run a timer in ML to execute an ISY program run command. I know it's a little clunky, but it worked for me.

Hopefully, this helps!

-Todd

Blade Runner
Newbie
Newbie
Posts: 19
Joined: Sun Mar 08, 2015 11:22 am
Contact:

Re: V4 ISY Driver

Postby Blade Runner » Mon Mar 30, 2015 6:18 pm

I'm having an issue with the area selector not displaying any options. I think I have the family configured correctly.

lighting.jpg
You do not have the required permissions to view the files attached to this post.
Last edited by Blade Runner on Mon Mar 30, 2015 6:20 pm, edited 1 time in total.

Blade Runner
Newbie
Newbie
Posts: 19
Joined: Sun Mar 08, 2015 11:22 am
Contact:

Re: V4 ISY Driver

Postby Blade Runner » Mon Mar 30, 2015 6:19 pm

... and this is all I see on the web app:

lighting2.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: V4 ISY Driver

Postby CinemarDave » Mon Mar 30, 2015 6:24 pm

The family looks correct. What does the properties of the left-hand infinite scroll look like?

Blade Runner
Newbie
Newbie
Posts: 19
Joined: Sun Mar 08, 2015 11:22 am
Contact:

Re: V4 ISY Driver

Postby Blade Runner » Mon Mar 30, 2015 6:38 pm

Here you go...

lighting3.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: V4 ISY Driver

Postby CinemarDave » Mon Mar 30, 2015 6:45 pm

Notice that the default web service is ending in /upper. This means the filter is looking for devices in level/floor = upper which there are none.

clear the value of the {{lighting_activezoneservice_{{clientname}}}} server variable(s) and change the value of the default web service to /getdata/lighting/show/zones

This should restore the left-hand list.

Blade Runner
Newbie
Newbie
Posts: 19
Joined: Sun Mar 08, 2015 11:22 am
Contact:

Re: V4 ISY Driver

Postby Blade Runner » Wed Apr 01, 2015 9:40 am

I figured that might be the case and removed it but I didn't clear the variable's. Working great now. Thanks!

jeffdoo
Intermediate
Intermediate
Posts: 329
Joined: Sat Aug 25, 2007 9:19 pm
Location: Huntersville, NC
Contact:

Re: V4 ISY Driver

Postby jeffdoo » Sat Apr 23, 2016 9:21 am

Dave,

I am not getting device status or variable updates from ISY which is resulting in programs failing to run, the most important of which is turning thermostats on/off when the door to the porch is opened/closed. I use the ISY to flip a variable between 0/1 after the door has been closed/opened for five minutes respectively.

I have rebooted the ISY, plugged and unplugged the Insteon module, restarted MLS (multiple times) without any success. MLS does properly read the variables upon start-up and reacts according, but any further updates are not received.

Does the ISY subscribe for updates? If yes, it is not present when I made the REST call to list active subscriptions.

ISY - 4.4.6 (03/24/16)
MLS - 4.0.5956.25239
V4 ISY Driver - 4.0.5836.30316

Results from isy.kingsquarry.net/rest/subscriptions (MLS is running right now):

Code: Select all

<Subscriptions>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
<Sub isExpired="yes" isPortal="no" sid="-1" sock="-1" isReusingSocket="no" isConnecting="no"/>
</Subscriptions>


Thanks!

- Jeff

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: V4 ISY Driver

Postby CinemarDave » Sat Apr 23, 2016 4:30 pm

The ISY driver does not currently subscribe to updates. Didn't know it could. I'll have to do some research to see how that is done.

jeffdoo
Intermediate
Intermediate
Posts: 329
Joined: Sat Aug 25, 2007 9:19 pm
Location: Huntersville, NC
Contact:

Re: V4 ISY Driver

Postby jeffdoo » Mon May 23, 2016 5:55 pm

Dave,

Not sure what happened but variables are once again updating with the update to just the MLS Server, no change to the ISY since March or the ISY Driver. What made this important is we have Insteon door sensors which trigger a 5 minute timer on the ISY which then triggers MLS to announce the door is open and turns off the thermostats. (Now if we just had music working again (iTunesSync) ;) and I have to get our webpages functioning).... Yes, I have a very patient family.

ISY - 4.4.6 (03/24/16)
MLS - 4.0.5959.16182
V4 ISY Driver - 4.0.5836.21191 (accidentally typed the last digits for the iTunesSync driver....)

Jeff

yzpmpgq
Senior Member
Senior Member
Posts: 193
Joined: Tue Oct 19, 2004 9:05 am
Contact:

Re: V4 ISY Driver

Postby yzpmpgq » Sat Jul 23, 2016 9:56 am

Dave, since the last MLServer update (keep in mind I only check them every 2-3 months), my ISY controlled thermostats are no longer reporting things like cool setpoint, heat setpoint, etc. The only thing in the driver log is:

Rest-REST request/vars/definitions/1 failed {404} OK

What info would you need to narrow it down?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: V4 ISY Driver

Postby CinemarDave » Mon Aug 01, 2016 11:38 am

The 404 error means that that URL "request/vars/definitions/1" is no longer valid in the ISY world. I'd have to remote into the system so I could query your ISY manually to see 1) why the URL is no longer valid and 2) what the new way to query definitions is.


Return to “MLServer 4 Device Drivers”

Who is online

Users browsing this forum: No registered users and 1 guest