MLServer 4 A/V Agent

Topics for MLServer Applets
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Sat Mar 03, 2012 11:33 am

I thought we were handling all flavors of the bdmv folder. Try the version I released today. If it doesn't help. What do your paths to the movies look like? What version of Arcsoft?

User avatar
Oronomus
Intermediate
Intermediate
Posts: 346
Joined: Mon Aug 14, 2006 1:18 pm
Location: Atlanta
Contact:

Re: MLServer 4 A/V Agent

Postby Oronomus » Sat Mar 03, 2012 2:24 pm

Most of my Blu-Rays point to a folder:

n:\17 Again\17_Again\BDMV

Over the last 6 months or so I have been downloading to a file:

n:\127 Hours\127_HOURS\BDMV\index.bdmv

On the latest Arcsoft TMT 5 version - 5.2.1.119. Is there a way in Content Manager to quickly find and replace all to add "\index.bdmv" to the movie files that currently point to a folder?

Btw, Installation assistant shows a new Content Manager version (4.0.4445.16334), but if I download and install, it stays red - doesn't indicate that a new version is installed. Throws an error on the install - delete file failed; Code 5 - MLServer\DevComponents.DotNetBar2.dll

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Sat Mar 03, 2012 2:38 pm

There was an update to a dll that both MLServer and Content Manager share. You must stop the server and install both the new version of the Content Manager and MLServer.

You didn't say if the new AV Agent solved your problem.

User avatar
Oronomus
Intermediate
Intermediate
Posts: 346
Joined: Mon Aug 14, 2006 1:18 pm
Location: Atlanta
Contact:

Re: MLServer 4 A/V Agent

Postby Oronomus » Sat Mar 03, 2012 3:10 pm

Sorry, when I looked at the AV Agent in the installer, it was not red, and I assumed you had not posted yet. I have now downloaded and installed the new version (which is later than indicated on the download header). It now starts movies in TMT5 from a folder that is one level up from the "\BDMV" folder. That appears to be built into TMT5 version 119. Try to drop down the "Open" tab in TMT5 and start a movie from a folder. You will see that it will not start from the "\BDMV" level. That is a change from all prior versions of TMT5.

EDIT - ALSO may not have installed CM to current version. CM shows 4.0.4445 available but when installing it shows 4.04442 version.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Sat Mar 03, 2012 4:37 pm

The version of the AV Agent I just released should handle every flavor of path to the BDMV folder.

User avatar
Oronomus
Intermediate
Intermediate
Posts: 346
Joined: Mon Aug 14, 2006 1:18 pm
Location: Atlanta
Contact:

Re: MLServer 4 A/V Agent

Postby Oronomus » Sun Mar 04, 2012 5:13 pm

AV Agent works fine for me now. Starts all variations of the movie files in TMT 5. Thanks for that

There is still a version mismatch with Content Manager, though it doesn't seem to affect TMT 5 startup:

AV Agent Error III.JPG
You do not have the required permissions to view the files attached to this post.

kgingerich
Intermediate
Intermediate
Posts: 312
Joined: Sun Jan 21, 2007 9:11 am
Contact:

Re: MLServer 4 A/V Agent

Postby kgingerich » Wed Mar 14, 2012 9:30 pm

Trying out auto archiving for the first time. Running anydvd 7.0.2.0 and the latest a/v driver and agent.

Put in a movie and anydvd pops up but doesn't rip the movie. It just sits there... see screenshot below.
Capture.PNG


Then in about 10 seconds anydvd disappears and i see the error below in the logs.
Capture2.PNG


The folder is not being created on the server even though the logged on user can create/delete anything on that share.
You do not have the required permissions to view the files attached to this post.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Thu Mar 15, 2012 11:27 am

Slysoft evidently made some changes to their forms when they released version 7. So now the Agent cannot find the buttons on the ripper form to click. I'll have to update the agent to be compatible with version 7 of AnyDVD.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Thu Mar 15, 2012 11:52 am

The latest release of the AV Agent is now compatible with AnyDVD version 6 and 7.

kgingerich
Intermediate
Intermediate
Posts: 312
Joined: Sun Jan 21, 2007 9:11 am
Contact:

Re: MLServer 4 A/V Agent

Postby kgingerich » Thu Mar 15, 2012 5:17 pm

Thanks the latest release is now ripping the movie. This is pretty slick.

One question remains, how often does the avagent poll the server to see if the connection is live and/or vice versa?

I ask because when i updated the a/v agent on the client and started it back up it didn't seem to automatically link up with the server. I waited about 3 minutes and then restarted mlserver which got it going again.

The computer that rips dvds usually is in sleep mode so I wouldn't want to have to restart mlserver each time I wake it up to rip movies.
-Kyle

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Thu Mar 15, 2012 5:34 pm

Every 5 seconds. However putting a Windows PC into sleep mode is almost always a disaster because MLServer will rarely. if ever, see the connection as being terminated but the PC going to sleep will drop the connection. A Windows feature? I'm not sure.

kgingerich
Intermediate
Intermediate
Posts: 312
Joined: Sun Jan 21, 2007 9:11 am
Contact:

Re: MLServer 4 A/V Agent

Postby kgingerich » Thu Mar 15, 2012 6:08 pm

fair enough, it's my wife's office pc so it doesn't get used much but we'll just keep it online unless you can think of any other way I can trigger a reconnection automatically.

On another note, the ripping finished and dvdlobby imported the movie very weird.
here is what i see in content manager, all of the videots and vts folders were just added
contentmanager.PNG

Here are my settings in dvdlobby.
dvdlobby settings.PNG

the avagent logs
avagent log.PNG

dvdlobby logs
dvdlobby logs.PNG
You do not have the required permissions to view the files attached to this post.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Thu Mar 15, 2012 6:22 pm

Do not have the "Monitor" column checked off in the DVDLobby folders as this will try to import movies as they are discovered. This is meant for people who rip elsewhere and drop their movies into the share. When you use the AVAgent ripping functions you want to make sure that monitoring is disabled or you will get the side effects you are seeing.

User avatar
opus1050
Newbie
Newbie
Posts: 22
Joined: Thu Feb 11, 2010 8:04 am
Location: Kissimmee FL
Contact:

Re: MLServer 4 A/V Agent

Postby opus1050 » Tue Mar 20, 2012 8:26 am

CinemarDave wrote:I found it. Updates have been posted. Install the new beta MusicLobby app.

Today's change to the agent was to modify how Arcsoft plays m2ts files and adds support for the new AVDriver

The AVDriver adds the missing commands from the old clientSvc app
Speak
Run
Stop
Monitor on,off
ScreenSaver on,off

The AVDriver has the command builder file showing the syntax.

Trying to use Speak on client PC fails! I see entry in MLServer log but now sound? If I use the old clientsvc plugin it works. EX: SYS.CS3|Send~Speak~First Message~Second Message
I have tried using the Command Builder to verify syntax without success either. The command executes just no sound. If the AVDriver now has the Speak command, does that mean we no longer need MLSpeak plugin?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Tue Mar 20, 2012 10:31 am

What is in the AVAgent event log. The Agent will speak using the default sound card that you have defined in Windows.

The AV command is AV|<<alias>>~Speak~Text to Speak and it works here.

MLSpeak is the legacy plugin and only allowed the MLServer PC to speak. In the V4 world you do not need it as you can use the AV Agent for speech and any PC in your network is then capable of speech.


Return to “MLServer 4 Applets”

Who is online

Users browsing this forum: No registered users and 2 guests