MLServer 4 A/V Agent

Topics for MLServer Applets
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Sun Jan 29, 2012 4:08 pm

>>>> 1. I downloaded the new AV Agent to another PC in my house that I plan to use as a remote A/V zone. This PC has PowerDVD on it. On which PC's AV agent do I define the player path in “media players” tab - MLServer PC or Local PC.

Everything you do on the AV Agent is relative to the local PC. That is because the Agent is only controlling the applications on the local PC.

>>>> 2. Are the State Variables “Movie Zones” still utilized with the new AV Agent structure? I don’t believe so, but can you confirm? Can / should this state variable be deleted?

The State Variables "Movie Zones" are a thing of the past. The new DVDLobby actually queries the Family database to retrieve a dynamic list of available movie zones. So the only thing you need to do is add the player into the Family Manager and everything after that will automatically pick it up. You don't need to delete the old state variables but they will never be used. So if you want to do some housecleaning then you can delete them.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Sun Jan 29, 2012 5:44 pm

Version 4.0.4411.25767 of the AV Agent adds support for the automatic mounting of .iso files for all media players using Slysoft's Virtual Clone Drive.

greyt
Intermediate
Intermediate
Posts: 448
Joined: Mon Jul 04, 2005 7:26 am
Contact:

Re: MLServer 4 A/V Agent

Postby greyt » Tue Jan 31, 2012 5:20 pm

CinemarDave wrote:Version 4.0.4411.25767 of the AV Agent adds support for the automatic mounting of .iso files for all media players using Slysoft's Virtual Clone Drive.


Thanks that's working really well.

I have one issue with PowerDVD - I cannot send an "Enter / OK" command to confirm a selection within a menu. up/down/left/right works fine. The keystroke to be sent to PowerDVD is Enter.

I have tried AV|AV1~rtn and AV|AV1~enter.

AV|AV1~left / AV|AV1~down etc work fine.

sbuckler
Intermediate
Intermediate
Posts: 349
Joined: Tue Feb 11, 2003 8:17 am
Location: Cape Cod
Contact:

Re: MLServer 4 A/V Agent

Postby sbuckler » Wed Feb 01, 2012 6:09 am

I have noticed that on both PowerDVD and CX777ES the Rewind button in V4 sample scenes does not work. All other buttons work.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Wed Feb 01, 2012 6:30 pm

Today's AV Agent fixes the PowerDVD Rewind issue. It was issuing a backframe instead of a rewind.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Sun Feb 05, 2012 12:08 pm

All that means is that the Radio Station you are listening to is injecting invalid metadata into the stream. Since I wasn't expecting that to happened I failed to look for and trap the error. The latest version of the A/V Agent compensates for this.

User avatar
Krumpy
Developer
Developer
Posts: 1228
Joined: Thu Sep 04, 2003 10:17 pm
Location: Minneapolis, Mn
Contact:

Re: MLServer 4 A/V Agent

Postby Krumpy » Tue Feb 07, 2012 6:44 pm

Yeah, probably was the German language or something like that.


Thanks!

shakey
Intermediate
Intermediate
Posts: 285
Joined: Sat Jun 28, 2008 9:55 pm
Contact:

Re: MLServer 4 A/V Agent

Postby shakey » Sat Feb 11, 2012 9:23 pm

Dave,

When I try to download the new A/V agent it downloads a 0 byte file and does not install. Can you double check the installer file?

Thanks

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Sun Feb 12, 2012 5:19 pm

Today's release of the A/V Agent adds the capability to auto-archive and catalog your physical DVD and Blu-Ray media. Once configured all you need to do is drop a movie into your PCs Blu-Ray or DVD drive and the agent will automatically make a backup copy of it for you and add it to the movie database. You'll get an email when the archive is complete. You can read about it here on the wiki. Please note you have to supply the archiving software. Currently AnyDVD / AnyDVD HD is supported. If any of you are into making backups of your personal media then give this feature a try and let us know how it works.
You do not have the required permissions to view the files attached to this post.

sbuckler
Intermediate
Intermediate
Posts: 349
Joined: Tue Feb 11, 2003 8:17 am
Location: Cape Cod
Contact:

Re: MLServer 4 A/V Agent

Postby sbuckler » Mon Feb 13, 2012 4:06 pm

The auto archiver does not work for me. I'm pretty sure I have it set up correctly. I do have a valid email address as well as I just received notification of a trial expiring. Here are my settings and log error.
You do not have the required permissions to view the files attached to this post.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Mon Feb 13, 2012 4:09 pm

Looks like you did not install the AVDriver device driver and/or have not configured the PC as a remote AVDriver device.

sbuckler
Intermediate
Intermediate
Posts: 349
Joined: Tue Feb 11, 2003 8:17 am
Location: Cape Cod
Contact:

Re: MLServer 4 A/V Agent

Postby sbuckler » Mon Feb 13, 2012 4:48 pm

Right again Dave! I missed that step. :oops:
Very slick addition and as always, thanks for your help.
Stan

User avatar
Oronomus
Intermediate
Intermediate
Posts: 346
Joined: Mon Aug 14, 2006 1:18 pm
Location: Atlanta
Contact:

Re: MLServer 4 A/V Agent

Postby Oronomus » Fri Mar 02, 2012 6:27 am

Tried to follow all the Wiki steps to install the AV Agent, but am getting an error. Error indicates "Family av is not licensed or invalid family alias." I have a valid Family-AV License, and in the image below the client is listed as AV1 under alias tab in Family Manager, and its IP address is proper.

I am out of time to troubleshoot right now, thought someone might help me with steps to diagnose the problem:

AV Agent Error.JPG


AV Agent Error II.JPG
You do not have the required permissions to view the files attached to this post.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer 4 A/V Agent

Postby CinemarDave » Fri Mar 02, 2012 10:35 am

By looking at the log entry AV|~PlayMovie~N:\... it tells me that you are not setting the server variable {{movies_activeplayer_{{clientname}}}} to a valid AV Family Alias. You should be setting Movies_ActivePlayer_{{clientname}} using DVDLobby|NextPlayer or DVDLobby|PrevPlayer or if you only have one playback location set it to the correct alias as part of the DVDLobby scene startup macro.

User avatar
Oronomus
Intermediate
Intermediate
Posts: 346
Joined: Mon Aug 14, 2006 1:18 pm
Location: Atlanta
Contact:

Re: MLServer 4 A/V Agent

Postby Oronomus » Sat Mar 03, 2012 9:58 am

Alright, fixed that. However, new Arcsoft driver is not starting movies from the BDMV folder. A while back you fixed the legacy Arcsoft plugin to properly handle all variations of the \BDMV path. Can you do that for the AV Agent and the current Arcsoft Driver? Thanks...


Return to “MLServer 4 Applets”

Who is online

Users browsing this forum: No registered users and 1 guest