MusicLobby 4

Topics for MLServer Applets
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MusicLobby 4 Public Preview

Postby CinemarDave » Thu Jan 05, 2012 4:18 pm

Can you email a screen shot of what your existing music folder structure looks like? In particular the folders where various artist and compilations are stored?

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: MusicLobby 4 Public Preview

Postby ronsatter » Thu Jan 05, 2012 4:33 pm

CinemarDave wrote:Can you email a screen shot of what your existing music folder structure looks like? In particular the folders where various artist and compilations are stored?


I have never incorporated "Various Artists" or "Compilations" into my ML3 folder structure. I never liked the results, so I just keep a very simple folder structure:

\\Server\Music\Artist\Artist Albums

I usually manually tag the artist tracks which are part of a "Various Artists" album with the common "Various Artists" or "Compilation" album name and artwork, but the artists and tracks never appear listed together in the album. I might have 10 entries of the same "Various Artists" album name and artwork, but each entry is unique to the performing artist.

Not ideal, but I don't care to have dozens of albums with "Various Artists" as the title.

Ron
Last edited by ronsatter on Thu Jan 05, 2012 10:10 pm, edited 1 time in total.
If it ain't broke ... don't fix it!

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MusicLobby 4 Public Preview

Postby CinemarDave » Thu Jan 05, 2012 5:26 pm

If your embedded tags have album artist defined as "Various Artists" then it should work just fine.

I would like to see the files first hand.
Can I remote in? Before I do point me to a various artists folder so I can inspect the tags.

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: MusicLobby 4 Public Preview

Postby ronsatter » Thu Jan 05, 2012 10:33 pm

CinemarDave wrote:If your embedded tags have album artist defined as "Various Artists" then it should work just fine.

I would like to see the files first hand.
Can I remote in? Before I do point me to a various artists folder so I can inspect the tags.


Happy to let you have a look ... but I probably confused you with my last post.

I don't have any "Various Artists" albums in my library. I know that may seem hard to believe, but I'm not a big fan of "Various Artists" albums.

However, I would like to test the new folder structure method for ML4, but I need to know how to keep my ML3 music folder structure as is while I test.

Do I need to clone my ML3 music library and modify the clone for ML4 testing?

I would prefer not to clone the library, if there is another way to test without permanently changing ML3 music folder structure.

Ron
If it ain't broke ... don't fix it!

pete_auto
Intermediate
Intermediate
Posts: 387
Joined: Tue Jan 25, 2005 6:50 pm
Contact:

Re: MusicLobby 4 Public Preview

Postby pete_auto » Thu Jan 05, 2012 10:47 pm

Dave,

I have been noticing that with the latest MusicLobby 4.0.4385.31057, whenever I try to play music, MLServer shuts down. For example, in MuL main scene (thumbs) via Library 28 scenes, I select an album. Then press "play album". The track either will not play, and MLServer shuts down. Very repeatable - happens every single time. Can you please take a look when you get a chance?

Thanks

pete_auto
Intermediate
Intermediate
Posts: 387
Joined: Tue Jan 25, 2005 6:50 pm
Contact:

Re: MusicLobby 4 Public Preview

Postby pete_auto » Thu Jan 05, 2012 11:09 pm

pete_auto wrote:I have been noticing that with the latest MusicLobby 4.0.4385.31057, whenever I try to play music, MLServer shuts down. For example, in MuL main scene (thumbs) via Library 28 scenes, I select an album. Then press "play album". The track either will not play, and MLServer shuts down. Very repeatable - happens every single time. Can you please take a look when you get a chance?


Correction...this is fixed. It seems that my MAudio Delta card inputs assignments got messed up for some reason. I re-assigned the three sources correctly, restarted the server and MuL is working fine now.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MusicLobby 4 Public Preview

Postby CinemarDave » Fri Jan 06, 2012 1:03 pm

Version 4.0.4388.19601 of MusicLobby adds a new Music_SourceX_TrackArtist server variable. Also, if the Album is a compilation type album then the TrackArtist will be used in the lyrics look up instead of the album artist.

greyt
Intermediate
Intermediate
Posts: 448
Joined: Mon Jul 04, 2005 7:26 am
Contact:

Re: MusicLobby 4 Public Preview

Postby greyt » Fri Jan 06, 2012 1:24 pm

Looks good. Just tested and that is working here. Any chance of linking in fan art lookup to track artist as well?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MusicLobby 4 Public Preview

Postby CinemarDave » Fri Jan 06, 2012 1:54 pm

Good point. Version 4.0.4388.20825 should resolve that.

freak69
Senior Member
Senior Member
Posts: 111
Joined: Sun Mar 25, 2007 3:00 pm
Contact:

Re: MusicLobby 4 Public Preview

Postby freak69 » Sun Feb 12, 2012 6:57 am

Should ML scan the "Album Artist" tag, or "Artist" tag? I have a bunch of (mp3) albums where for a few tracks, they list multiple artists in the "Artist" tag (collaborations) and MUL seems to treat these as different albums. The "Album Artist" tag is correct in all cases and this worked fine with ML3.75. Is this a "feature", as I don't really want to change tags on all my albums.

Paul

sbuckler
Intermediate
Intermediate
Posts: 349
Joined: Tue Feb 11, 2003 8:17 am
Location: Cape Cod
Contact:

Re: MusicLobby 4 Public Preview

Postby sbuckler » Wed Sep 05, 2012 10:00 am

I finally manually re-entered my dvd's after losing the database. I inadvertently entered one movie in content manager 2 times with the title only. The third time I entered it properly. Now in MuL4 I have 3 of the same movie showing, two with no cover art (cuz I never searched for it) and one showing properly. The two titles without cover art do not show up in content manager. How do I delete those two movies.

monteourdog
Senior Member
Senior Member
Posts: 174
Joined: Sat May 20, 2006 5:03 am
Location: Vancouver
Contact:

Re: MusicLobby 4 Public Preview

Postby monteourdog » Mon Feb 11, 2013 6:54 am

Would it be possible to include the "ID" with the random music?

I think it is kind of nice to be tempted with a random music selection...but as far as I can tell, there is nothing you can do with it other than looking at the cover, artist and album. Add the variable of the ID, now we got something.

Cheers!

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: MusicLobby 4 Public Preview

Postby ronsatter » Mon Feb 11, 2013 4:09 pm

monteourdog wrote:Would it be possible to include the "ID" with the random music?

I think it is kind of nice to be tempted with a random music selection...but as far as I can tell, there is nothing you can do with it other than looking at the cover, artist and album. Add the variable of the ID, now we got something.

Cheers!

I worked out a "poor man's" solution for displaying the random NetFlix movie ... using a search technique to acquire the ID. You can adapt this to search music.

Here's the post: viewtopic.php?f=170&t=16996#p109889

It's not as bullet proof as having the ID included in the "Random" variables, but it works pretty well ... 99% of the time. Caveats in this method are noted in the post.

Ron
If it ain't broke ... don't fix it!

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MusicLobby 4 Public Preview

Postby CinemarDave » Mon Feb 11, 2013 5:32 pm

I'll update all the media apps within the next few days that generate random images to also include the ID. Watch for the updates. They'll all happen at the same time.

User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Re: MusicLobby 4 Public Preview

Postby simonmason » Mon Feb 11, 2013 9:44 pm

does "media" extend to photolobby random photo id?
Simon D. S. Mason


Return to “MLServer 4 Applets”

Who is online

Users browsing this forum: No registered users and 1 guest