ML Server keeps not respoding

Topics related to MLServer 4
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: ML Server keeps not respoding

Postby CinemarDave » Wed Apr 13, 2016 8:06 pm

There was one additional update to MLServer today to correct for issue trying to resize images.

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Thu Apr 14, 2016 7:14 am

Dave,

Still having crash issues.

Even with the updates installed, I can not run the Weather App.

Also, the updated weather still does not provide pollen info.

This is on a brand new PC with fresh install of ML and SQL.

Any more ideas ??
Erik

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: ML Server keeps not respoding

Postby CinemarDave » Thu Apr 14, 2016 2:48 pm

On the new install did you set the file permissions of the MLServer folder so the the group "Users" has full control of the entire folder and sub-folders?

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Thu Apr 14, 2016 5:26 pm

Dave,

Just made that change, hopefully that will do the trick.
Erik

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: ML Server keeps not respoding

Postby DaveB » Thu Apr 14, 2016 7:41 pm

Also make double sure that UAC is turned off. Some recent Win 10 updates turned it back on behind the scenes. I actually had to go to the registry and force it to off.
Thanks!

Dave Bruner
:shock:

User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Re: ML Server keeps not respoding

Postby simonmason » Thu Apr 14, 2016 9:54 pm

It's working for me. I am running Windows 7 so I didn't have to worry about rights, etc.
Simon D. S. Mason

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: ML Server keeps not respoding

Postby DaveB » Thu Apr 14, 2016 10:21 pm

Yes- It seems so far that I am also back to normal.

I am officially removing myself from the Beta train wagon. Next update will be only when something new and needed is announced. I need to stop being a beta tester.

Dave - You really need to start documenting all the updates as the occur so there can all make good choices of weather to update.
Thanks!

Dave Bruner
:shock:

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Fri Apr 15, 2016 7:10 am

Dave,

Woke this morning to a frozen server.

I am running Windows 7, I believe all user settings are where they need to be.

I had to end processes as well, and noticed that DataMiner was running in 3 instances and consuming a majority of the resources.

One hour after restart, DataMiner was using 50% of the cpu.

i disabled the Weather App and DataMiner process ended on it's own.

Hopefully the server will run for more than 24 hours, with the weather app disabled.

What should I do next ??
Erik

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: ML Server keeps not respoding

Postby CinemarDave » Fri Apr 15, 2016 12:23 pm

Erik, I need to remote into your system. Dataminer is the utility I wrote to gather pollen data outside of the server. It obviously cannot get to the internet to get its data and I need to understand why it cannot.

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Fri Apr 15, 2016 1:37 pm

Dave,

Just sent you a pm with info
Erik

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Fri Apr 15, 2016 6:55 pm

Dave,

Came home from dinner and server was frozen.

Dataminer had somehow started again and consumed resources. I killed the process and the server returned to normal, without having to restart MLServer.

Whatever the issue is with the DataMiner, its killing my server.

Weather is disabled, so i don't know how the process started.

But I would like to receive my weather data soon.

Please let me know what to do.

Thanks.
Erik

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Sat Apr 16, 2016 7:15 am

Morning Dave,

Server is running as expected, this morning.

Weather App is disabled and Dataminer has not shown up in the process list.

I would like to re-enable the Weather App, is there a way to disable the DataMiner process ??
Erik

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Sat Apr 16, 2016 2:32 pm

Dave,

Some more info to help you sort this out.

My OLD Server, latest updates, no issues with the DataMiner or freezing of the server. All of the Pollen variables populate.

New Server, same network, same version of installed files, DataMiner frequently sticks and i have to manually end the process. No Pollen variable population. Once I end the DataMiner process, MLServer returns to normal and does not have to be restarted.

The reason I switched servers is because the OLD server has something bad in the SQL directory and will not backup the database. The new server backs up properly but can't provide weather information without manual intervention.

If only i could merge the two.

Please let me know if there is any other info I can track or provide to assist you in this.
Erik

erikhimber
Expert
Expert
Posts: 872
Joined: Wed Jun 11, 2003 8:54 pm
Location: West Palm Beach, FL
Contact:

Re: ML Server keeps not respoding

Postby erikhimber » Mon Apr 18, 2016 1:27 pm

THANK YOU Dave,

Everything is working perfectly now.

Pollen info is now populating the variables and the server has not locked up since you updated everything.

Your time spent in resolving this issue for me is GREATLY appreciated.
Erik

brettcp
Member
Member
Posts: 56
Joined: Fri Sep 12, 2008 6:13 pm
Location: San Diego, CA
Contact:

Re: ML Server keeps not respoding

Postby brettcp » Tue Apr 19, 2016 2:00 pm

Mine is now working and stable again after the latest MLServer update, thank you!


Return to “MLServer 4”

Who is online

Users browsing this forum: No registered users and 1 guest