ML Server keeps not respoding

Topics related to MLServer 4
User avatar
Mr. Spock
Member
Member
Posts: 92
Joined: Fri Jul 04, 2008 12:33 pm
Location: San Diego
Contact:

ML Server keeps not respoding

Postby Mr. Spock » Sun Mar 06, 2016 9:56 pm

I've just noticed a problem with 4.0.5830.28260. I think I've had this problem for weeks but only really noticed it now when I was using Musiclobby.

I see that it goes through a cycle of not responding for about 17 seconds, responds for about 3 seconds, not responds for another 17 seconds, then responds normally for about 50 seconds. This cycle repeats over and over. By not responding I mean there is no client response and I see on the server PC's Task Manager that MLServer.exe status is not responding. My server PC is a recent i5 with very low CPU utilization running windows 8.1. I've rebooted everything.

What should I be looking for/at?

Thanks.
Live long and prosper.

Synergy_Tech
Senior Member
Senior Member
Posts: 101
Joined: Wed Sep 26, 2012 8:36 pm
Contact:

Re: ML Server keeps not respoding

Postby Synergy_Tech » Tue Mar 08, 2016 5:20 pm

Does it still happen when you're not using musiclobby?

User avatar
Mr. Spock
Member
Member
Posts: 92
Joined: Fri Jul 04, 2008 12:33 pm
Location: San Diego
Contact:

Re: ML Server keeps not respoding

Postby Mr. Spock » Wed Mar 09, 2016 12:39 am

Yes, it happens 24/7. Its basically oscillating in and out of usability.

I was able to upgrade to the latest version (4.0.5908.31977), but to do the update I had to kill MLS first with task manger. It was the only way I could successfully install the update. Unfortunately the latest version is exactly the same.

I have a very small implementation of Mainlobby, so I'm suspecting maybe something with SQL but I'm guessing.

I'm not sure how to approach this.
Live long and prosper.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: ML Server keeps not respoding

Postby CinemarDave » Thu Mar 10, 2016 4:49 pm

This has to be something polling on the main thread that is causing the issue. Nothing in the server polls on the main thread so it has to be a driver, app or plugin doing it. The exercise will be to start the server without any apps or drivers loaded. Verify the issue is gone and then systematically add the offline objects in one at a time until you see the issue come back. This can be time consuming if you have a lot of apps and drivers.

Send me a list of the apps and drivers you are running. I'll know which ones of those are polling.

User avatar
Mr. Spock
Member
Member
Posts: 92
Joined: Fri Jul 04, 2008 12:33 pm
Location: San Diego
Contact:

Re: ML Server keeps not respoding

Postby Mr. Spock » Sat Mar 12, 2016 1:36 pm

Dave, I PM'd you a list of my drivers and apps.

I traced it down to the Dish driver. Unchecking the Enabled box in the Device Drivers tab and restarting ML brought back stability. I have everything but the Dish driver enabled and all is good again.
Live long and prosper.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: ML Server keeps not respoding

Postby CinemarDave » Tue Mar 15, 2016 8:00 pm

Ok, that guy was polling on the main thread and since we have not received an updated client certificate from dish the driver is essentially dead in the water. Just keep it unloaded for now.

Synergy_Tech
Senior Member
Senior Member
Posts: 101
Joined: Wed Sep 26, 2012 8:36 pm
Contact:

Re: ML Server keeps not respoding

Postby Synergy_Tech » Thu Mar 17, 2016 2:23 pm

Is dish being a PITA?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: ML Server keeps not respoding

Postby CinemarDave » Tue Mar 22, 2016 7:28 pm

In order to get a driver for Dish we need to build and send them an entire Server setup and tablet device so they can test the system in their labs. They need to make sure we are not doing anything that might knock their satellites out of orbit. If they like the driver and deem it safe they will issue a security certificate good for one year. Then next year we have to go through the drill all over again. A bit extreme for a simple remote control scene.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: ML Server keeps not respoding

Postby DaveB » Wed Mar 23, 2016 9:36 pm

Just a side note - If Dave could figure out how to knock something out of orbit; I am all in. :lol:
Thanks!

Dave Bruner
:shock:

Synergy_Tech
Senior Member
Senior Member
Posts: 101
Joined: Wed Sep 26, 2012 8:36 pm
Contact:

Re: ML Server keeps not respoding

Postby Synergy_Tech » Thu Mar 24, 2016 1:01 pm

That doesn't surprise me, Dish has always been a difficult company to deal with. I'm all for knocking their satellites out of orbit.

AVDCORPNY
Expert
Expert
Posts: 565
Joined: Mon Oct 09, 2006 6:38 pm
Location: 3231 lafayette ave, bronx
Contact:

Re: ML Server keeps not respoding

Postby AVDCORPNY » Mon Apr 04, 2016 9:32 am

The new Mlserver keep crashing after one hour up, it also show error . thank you

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: ML Server keeps not respoding

Postby DaveB » Mon Apr 04, 2016 9:44 am

I was also experiencing some strange behavior over the weekend. SQL keeps grabbing huge amounts of memory over a day or so until the machine gets very slow. A SQL restart helped but a reboot started the process over. I will check more tonight.
Thanks!

Dave Bruner
:shock:

AVDCORPNY
Expert
Expert
Posts: 565
Joined: Mon Oct 09, 2006 6:38 pm
Location: 3231 lafayette ave, bronx
Contact:

Re: ML Server keeps not respoding

Postby AVDCORPNY » Mon Apr 04, 2016 9:10 pm

I have gone back to and old version of mlserver and it still go down after a few hours, it never shut down till I upgrade to the last version.
Dave Please repair problem Thank You

User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Re: ML Server keeps not respoding

Postby simonmason » Tue Apr 05, 2016 7:34 pm

Same issue here - tried stepping back to an old version but it appears the damage was done by the new version and stepping back didn't do anything.
Simon D. S. Mason

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Re: ML Server keeps not respoding

Postby DaveB » Tue Apr 05, 2016 8:05 pm

Again tonight SQL is not releasing memory and ends up nearly crashing a very fast memory pack machine. The consumption was up to 1.4 gig tonight after running about 18 hours. Commands become sluggish and the system not useable.

Something in the last two updates (the failed one) coupled with the last one changed something in SQL that is causing the issue.
Thanks!

Dave Bruner
:shock:


Return to “MLServer 4”

Who is online

Users browsing this forum: No registered users and 1 guest