MLServer freeze

Topics related to MLServer 4
ggraef
Member
Member
Posts: 96
Joined: Fri Oct 24, 2003 10:00 am
Contact:

MLServer freeze

Postby ggraef » Sat May 03, 2014 1:18 pm

I've been seeing the following behavior when MLServer is idle for several hours. Clients will attempt to reconnect and MLserver freezes for ~30 seconds (e.g. if I push a button on the client, that command is lost). On the server event log I caught the following (alas, logging to disk wasn't on so I'm paraphrasing):
- client connection accepted message (no date stamp)
- some variables set
- license validation checks run
- one component is un-licensed (old gui graphic library I'm not using that I never re-licensed)
- mlcmd is run to display a license warning popup on the client
- eventually, a client connected message (with date stamp)

During the time between the last two steps, MLServer is completely un-responsive, e.g. clicking on a button directly on the MLServer window does nothing.

The same freezing behavior appears when using a web-client after a long idle time.

Is this just an intended license failure nag issue? If so, what is the best way to "remove" a library 14? Remove a swf somewhere or rework licensing? If not the nag popup, what else could be causing this?

Thanks!
Gerry

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer freeze

Postby CinemarDave » Sat May 03, 2014 2:02 pm

On all your MainLobby client PCs delete the library0014.swf file from the library folder. Then re-install the MainLobby client. This will get you the original unlicensed library 14 back. Then go into MLServer Licenses and delete the Library 14 license entry. Restart the server.

User avatar
Mr. Spock
Member
Member
Posts: 92
Joined: Fri Jul 04, 2008 12:33 pm
Location: San Diego
Contact:

Re: MLServer freeze

Postby Mr. Spock » Tue May 06, 2014 10:06 pm

Is this the standard procedure to uninstall a trial library?

I did a 30 day trial of GuiGraphix library 16 and never used it. Can I just delete the library0016.swf file in the library?
Live long and prosper.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer freeze

Postby CinemarDave » Tue May 06, 2014 10:23 pm

You cannot just delete a swf file because MainLobby will not start properly. Follow the rule of deleting the swf you do not want and then re-installing the MainLobby client.

User avatar
Mr. Spock
Member
Member
Posts: 92
Joined: Fri Jul 04, 2008 12:33 pm
Location: San Diego
Contact:

Re: MLServer freeze

Postby Mr. Spock » Tue May 06, 2014 10:51 pm

What is the proper procedure to reinstall mainlobby?
Live long and prosper.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer freeze

Postby CinemarDave » Wed May 07, 2014 11:20 am

Download it from the CIA and Install. It will not overwrite any of your scenes. Better yet, when you run the installer when you get to the option to install dialog you can unselect everything and just select MainLobby 4 Base Library files.

RZajcew
Intermediate
Intermediate
Posts: 257
Joined: Mon Jul 21, 2008 6:31 pm
Contact:

Re: MLServer freeze

Postby RZajcew » Mon Feb 08, 2016 9:21 pm

I also have a couple of libraries that I installed but did not use (in my case I was just overzealous when updating my system). Library 0010 and Library 0011. I tried to follow the instructions. However, I cannot delete the licenses for either of the libraries. Windows 10 Professional running on the server.

- Roman

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLServer freeze

Postby CinemarDave » Mon Feb 08, 2016 9:26 pm

As a last resort install a clean copy of the mainlobby client in a different folder. Then copy the blank library 10 and 11 files into the working libraries folder. You must do this on all pcs running the mainlobby client. Then in MLServer go into licenses and delete the library licenses and restart MLServer. If the license nags come back it means there is at least one MainLobby client out there using the full libraries.

RZajcew
Intermediate
Intermediate
Posts: 257
Joined: Mon Jul 21, 2008 6:31 pm
Contact:

Re: MLServer freeze

Postby RZajcew » Mon Feb 08, 2016 11:15 pm

So, what confused me here was when I deleted the licenses, they remained in the list of products (the lines for these libraries did not change at all). So I thought the deletion had not worked. I restarted MLServer and the products disappeared from the list. So I'm fine now.

Thanks,
Roman


Return to “MLServer 4”

Who is online

Users browsing this forum: No registered users and 1 guest