Can't get off the start with climate!

General discussions about the MainLobby web application running on Apple iPads.
User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Can't get off the start with climate!

Postby simonmason » Sat Feb 19, 2011 7:54 am

I am now working on the climate control. I have gone through the code and I found the block below which I updated to display the variables in my setup. However, I get no numbers when I come to this page. I tried to trace the code and I see that it is setting to zone 1 and should be displaying __Zone1. But nothing appears. Clues on the next step? I wish I knew more about html - alas I am teaching myself as I go!



Code: Select all

   <span id="__Zone1" style="visibility:hidden;">
      <span style="z-index:42; position:absolute;left:490px;top:120px;width:250px;text-align:center;font:normal 100px/110px Helvetica;color:rgba(255, 255, 255, 1.0);"><span id="ml_MLHSPlugin_z16">{{MLHSPlugin_z16}}</span>&#176;</span>
      <span style="z-index:42; position:absolute;left:420px;top:300px;width:50px;text-align:center;font:normal 18px/20px Helvetica;color:rgba(255, 255, 255, 1.0);"><span id="ml_MLHSPlugin_z17">{{MLHSPlugin_z17}}</span>&#176;</span>
      <span style="z-index:42; position:absolute;left:735px;top:300px;width:50px;text-align:center;font:normal 18px/20px Helvetica;color:rgba(255, 255, 255, 1.0);"><span id="ml_MLHSPlugin_z13">{{MLHSPlugin_z13}}</span>&#176;</span>
      <span style="z-index:42; position:absolute;left:555px;top:250px;width:50px;text-align:center;font:normal 40px/40px Helvetica;color:rgba(255, 255, 255, 1.0);" id="ml_MLHSPlugin_z27">{{MLHSPlugin_z27}}</span>
   </span>
Simon D. S. Mason

sonypoolplr
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1490
Joined: Fri Mar 26, 2004 8:48 am
Location: New Jersey
Contact:

Re: Can't get off the start with climate!

Postby sonypoolplr » Sat Feb 19, 2011 8:19 am

I am using this in my code:

style="z-index:2;position:absolute;top:80px;left:230px;">&nbsp;&nbsp;Heat&nbsp;&nbsp;</a>
<span style="z-index:2; position:absolute; left:110px; top:50px;font:normal 100px/110px Helvetica;color:rgba(255, 255, 255, 1.0);" id="ml__mlhsplugin_z31_value">{{mlhsplugin_z31_value}}</span>
<span style="z-index:2; position:absolute; left:53px; top:162px;font:normal 16px/20px Helvetica;color:rgba(255, 255, 255, 1.0);" id="ml__mlhsplugin_z33_value">{{mlhsplugin_z33_value}}</span>
<span style="z-index:2; position:absolute; left:274px; top:162px;font:normal 16px/20px Helvetica;color:rgba(255, 255, 255, 1.0);" id="ml__mlhsplugin_z32_value">{{mlhsplugin_z32_value}}</span>
<span style="z-index:2; position:absolute; left:135px; top:170px;font:normal 32px/40px Helvetica;color:rgba(255, 255, 255, 1.0);" id="ml__mlhsplugin_z30">{{mlhsplugin_z30}}</span>

The difference I see in mine and yours is that I am using the _valve. I am not an expert on this either, but maybe this will help you.

User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Re: Can't get off the start with climate!

Postby simonmason » Sat Feb 19, 2011 8:34 am

Thanks for the pointer. I did notice that I was using "ml_" instead of "ml__" so I corrected this. However, when I check on the server I can confirm that the variables without _value do contain the number I am looking for. In my case I am storing the temperature in the variable not the variable_value. But still I can't get it to show.
Simon D. S. Mason

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Can't get off the start with climate!

Postby CinemarDave » Mon Feb 21, 2011 10:54 am

Make sure you always use all lower case letters in your ID values. The javascript code is case sensitive.


Return to “MainLobby on the iPad”

Who is online

Users browsing this forum: No registered users and 1 guest