iPad MainLobby screens unresponsive after device standby

General discussions about the MainLobby web application running on Apple iPads.
jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

iPad MainLobby screens unresponsive after device standby

Postby jwr » Wed Feb 27, 2013 4:35 pm

I've been having this problem and I've been unable to isolate why it happens. I use the iPad to select a movie and start it. While the movie is playing the iPad goes into standby. I turn the device back on and the MainLobby screen is there but none of the buttons respond to touch (including home, menu and back). It happens on my iPad 1 and iPad mini. I thought it might be the IP address changing when it comes out of standby so I gave both iPads a static DHCP assignment, but this didn't help. I'd like to be able to bring the iPad out of stand by and use the MainLobby movie remote without having to kill the app, find the movie again and go to the remote.

Anyone else seeing this? Is there a solution?

greyt
Intermediate
Intermediate
Posts: 448
Joined: Mon Jul 04, 2005 7:26 am
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby greyt » Wed Feb 27, 2013 5:23 pm

I have the same issue, but didn't think too much about it, I have just been closing and opening the app again.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10549
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby CinemarDave » Wed Feb 27, 2013 7:56 pm

When the iPad comes out of sleep mode the web clients have long since lost their connection to the server. Pressing any button on the scenes that executes a MLServer command should be enough to wake the app up and create a new connection. I assume this doesn't work for you?

greyt
Intermediate
Intermediate
Posts: 448
Joined: Mon Jul 04, 2005 7:26 am
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby greyt » Thu Feb 28, 2013 3:07 am

Correct, pressing a button does not do anything. The red box you normally see when you press a button also doesn't happen, it is as though the screen has totally locked up.

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby jwr » Thu Feb 28, 2013 9:45 am

Also, the problem doesn't happen if the device goes to standby and I immediately turn it back on. Seems like it has to be in standby for a period of time. Perhaps something in the app times out when the device is in standby mode?

greyt
Intermediate
Intermediate
Posts: 448
Joined: Mon Jul 04, 2005 7:26 am
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby greyt » Thu Feb 28, 2013 9:54 am

jwr wrote:Also, the problem doesn't happen if the device goes to standby and I immediately turn it back on. Seems like it has to be in standby for a period of time. Perhaps something in the app times out when the device is in standby mode?


I suspect it is related to when the wifi radio is switched off - this doesn't happen immediately.

DevenLF
Member
Member
Posts: 94
Joined: Fri May 20, 2005 11:26 am
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby DevenLF » Sat Mar 14, 2015 10:38 pm

I'm experiencing this issue, as well.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10549
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby CinemarDave » Sun Mar 15, 2015 11:50 am

If your iOS devices are running iOs 8.0 to 8.1.2 then update them to iOS 8.2 because Apple breaks JavaScript on wake up in those versions. If you are running IOS 8.2 how long does it take your device to acquire its IP address from wake up?

User avatar
Krumpy
Developer
Developer
Posts: 1228
Joined: Thu Sep 04, 2003 10:17 pm
Location: Minneapolis, Mn
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby Krumpy » Wed Apr 08, 2015 10:26 pm

IOS 8.3 was released today. Any updates to whether Apple fixed the issues? Have not had chance to try myself.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10549
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby CinemarDave » Wed Apr 08, 2015 11:12 pm

I left all my iOS devices updating tonight. I'll do testing in the morning.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10549
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby CinemarDave » Thu Apr 09, 2015 10:39 am

At first glance it appears Apple has ignored the uiWebView bugs in this release. It was a higher priority for them to add the new 300 emoji characters instead of fixing show-stopper bugs. Still cannot play videos. Still cannot use the microphone. They do claim to have fixed the wifi issue that has been causing my iPad-mini to drop off the network 5 times a day. Time will tell if that is really fixed.

CNet published an article with the Apple's list of fixes.

User avatar
Krumpy
Developer
Developer
Posts: 1228
Joined: Thu Sep 04, 2003 10:17 pm
Location: Minneapolis, Mn
Contact:

Re: iPad MainLobby screens unresponsive after device standby

Postby Krumpy » Thu Apr 09, 2015 5:52 pm

I do agree with your point about the emoji.. Who cares!


Return to “MainLobby on the iPad”

Who is online

Users browsing this forum: No registered users and 1 guest