Problem with slider update

Discussions about Mainlobby running on Apple mobile devices.
winch20010
New Member
New Member
Posts: 35
Joined: Sat Jul 26, 2008 12:55 pm
Contact:

Problem with slider update

Postby winch20010 » Sun Dec 26, 2010 3:49 am

Hi,

one other post ...
the sliders are not automatically updated in the lighting webpage. can you help me on that ??

I see the problem comes from this function :
function UpdateSlider(sNum, sVal) {

Sliders[sNum-1].curX = sVal * (Sliders[sNum-1].maxX / Sliders[sNum-1].max);
$(Sliders[sNum-1].handel).style.webkitTransform = 'translate3d(' + Sliders[sNum-1].curX + 'px,0,0)';
}

Who calls this function ?


If I manually set sVal to a hard numeric value (in the function itself), then it works, I can see the sliders stopped to this value, else it does not work.
If I touch the slider and move to 90% for example, then the light dim to 90%, the slider shows 90%, but few milliseconds after, the slider value go back to its initial value...

Thanks for the help!

I attached the code just in case...
You do not have the required permissions to view the files attached to this post.

winch20010
New Member
New Member
Posts: 35
Joined: Sat Jul 26, 2008 12:55 pm
Contact:

Re: Problem with slider update

Postby winch20010 » Sun Dec 26, 2010 4:17 am

solution found !!!

important to know :
the device value name in Mainlobby must have the same name as the span id name ...

eg :
{{lighting_lamp1_value}} --> value for lighting_lamp1 in mainlobby
ml__lighting_lamp1_value --> name for the span id


Rgds,
Seb


Return to “MainLobby on iPhone, iPod Touch”

Who is online

Users browsing this forum: No registered users and 1 guest