AppendTrackPlay wonky in shuffle mode?

Questions comments and suggestions for MusicLobby 3.75
User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

AppendTrackPlay wonky in shuffle mode?

Postby simonmason » Wed Mar 06, 2013 8:16 pm

As I understand this command it is supposed to take the track, insert it into the playlist, and play it? For me, it seems to insert the track into the playlist and then issues a next track command. So the playlist advances to and plays the next track in the shuffle order, not the track that was just inserted. If shuffle mode is turned off then this command works fine.
Simon D. S. Mason

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: AppendTrackPlay wonky in shuffle mode?

Postby CinemarDave » Thu Mar 07, 2013 5:39 pm

When shuffle mode is turned on the track is added to the end of the playlist but the shuffle rules say play the next random song in the playlist. It will not automatically play the song just added. It picks a random song from the ones not yet played.

User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Re: AppendTrackPlay wonky in shuffle mode?

Postby simonmason » Thu Mar 07, 2013 5:56 pm

I swear there was a command that did this in 3.75? Was it InsertSongNowPlaying?
Simon D. S. Mason

User avatar
simonmason
Expert
Expert
Posts: 855
Joined: Tue Dec 26, 2006 9:06 pm
Contact:

Re: AppendTrackPlay wonky in shuffle mode?

Postby simonmason » Fri Nov 29, 2013 3:54 pm

For anyone that wants to get this working - I finally came up with a way to do it - Issue the command Shuffle Off, then AppendTrackPlay, and then Shuffle On. This works! I can't believe it took me this long to think about it. So now I can search for a song, and add it and play it immediately when listening to a shuffled playlist
Simon D. S. Mason


Return to “MusicLobby 3.75”

Who is online

Users browsing this forum: No registered users and 1 guest