Music Lobby scrolls thru, but doesn't play

Questions comments and suggestions for MusicLobby 3.75
Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Music Lobby scrolls thru, but doesn't play

Postby Art Dustman » Sat Sep 10, 2011 2:56 pm

I have seen this before, but can't remeber if I ever figured out how to fix. Only on ONE client, when I select an album to play, it shows the title and time, and goes to the next title, and next, etc - but doesn't play. I have checked the settings over and over...but if anyone knows exactly where I need to look, I would appreciate it.

It's a Win XP SP2 client, using client service, default ports, shows connected.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Music Lobby scrolls thru, but doesn't play

Postby Art Dustman » Sat Sep 10, 2011 3:03 pm

Looking at the logs, I get this: (for this example, and all 8243 more)
LogAudioError: ERR_INVALID_FILE -6 Invalid sound file

But all the other clients can play it.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Music Lobby scrolls thru, but doesn't play

Postby CinemarDave » Sun Sep 11, 2011 12:44 am

I don't know how this can be client related since the server is playing the file. Can you show a little more of the event log?

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Music Lobby scrolls thru, but doesn't play

Postby Art Dustman » Sun Sep 11, 2011 11:58 am

9/11/2011 12:55:55 PM [1] Ping
9/11/2011 12:56:00 PM [1] Ping
9/11/2011 12:56:05 PM [1] Ping
9/11/2011 12:56:10 PM [1] Ping
9/11/2011 12:56:11 PM [0] Mul~Stop
9/11/2011 12:56:11 PM MusicLobby Cmd[Stop] Param[] Options[]
9/11/2011 12:56:11 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:15 PM [1] Ping
9/11/2011 12:56:18 PM [0] Mul~Stop
9/11/2011 12:56:18 PM MusicLobby Cmd[Stop] Param[] Options[]
9/11/2011 12:56:18 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:18 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\01 Toes.mp3
9/11/2011 12:56:18 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\01 Toes.mp3] Options[]
9/11/2011 12:56:18 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:25 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:25 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\01 Toes.mp3
9/11/2011 12:56:25 PM SoundDoneEvent
9/11/2011 12:56:25 PM [1] Ping
9/11/2011 12:56:25 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\02 Whatever It Is.mp3
9/11/2011 12:56:25 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\02 Whatever It Is.mp3] Options[]
9/11/2011 12:56:25 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:25 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:25 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\02 Whatever It Is.mp3
9/11/2011 12:56:25 PM SoundDoneEvent
9/11/2011 12:56:25 PM [1] HELO~ALPHA (Gameroom)
9/11/2011 12:56:26 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\03 Where The Boat Leaves From.mp3
9/11/2011 12:56:26 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\03 Where The Boat Leaves From.mp3] Options[]
9/11/2011 12:56:26 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:26 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:26 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\03 Where The Boat Leaves From.mp3
9/11/2011 12:56:26 PM SoundDoneEvent
9/11/2011 12:56:26 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\05 It's Not OK.mp3
9/11/2011 12:56:26 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\05 It's Not OK.mp3] Options[]
9/11/2011 12:56:26 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:26 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:26 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\05 It's Not OK.mp3
9/11/2011 12:56:26 PM SoundDoneEvent
9/11/2011 12:56:27 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\05 Free.mp3
9/11/2011 12:56:27 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\05 Free.mp3] Options[]
9/11/2011 12:56:27 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:27 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:27 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\05 Free.mp3
9/11/2011 12:56:27 PM SoundDoneEvent
9/11/2011 12:56:27 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\06 Chicken Fried.mp3
9/11/2011 12:56:27 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\06 Chicken Fried.mp3] Options[]
9/11/2011 12:56:27 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:27 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:27 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\06 Chicken Fried.mp3
9/11/2011 12:56:27 PM SoundDoneEvent
9/11/2011 12:56:28 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\07 Mary.mp3
9/11/2011 12:56:28 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\07 Mary.mp3] Options[]
9/11/2011 12:56:28 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:28 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:28 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\07 Mary.mp3
9/11/2011 12:56:28 PM SoundDoneEvent
9/11/2011 12:56:28 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\08 Different Kind Of Fine.mp3
9/11/2011 12:56:28 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\08 Different Kind Of Fine.mp3] Options[]
9/11/2011 12:56:28 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:28 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:28 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\08 Different Kind Of Fine.mp3
9/11/2011 12:56:28 PM SoundDoneEvent
9/11/2011 12:56:29 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\09 Highway 20 Ride.mp3
9/11/2011 12:56:29 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\09 Highway 20 Ride.mp3] Options[]
9/11/2011 12:56:29 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:29 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:29 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\09 Highway 20 Ride.mp3
9/11/2011 12:56:29 PM SoundDoneEvent
9/11/2011 12:56:29 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\11 Jolene.mp3
9/11/2011 12:56:29 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\11 Jolene.mp3] Options[]
9/11/2011 12:56:29 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:29 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:29 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\11 Jolene.mp3
9/11/2011 12:56:29 PM SoundDoneEvent
9/11/2011 12:56:29 PM [0] Mul~PlayTrack~\\BETA-PC\Good\Zac Brown Band\The Foundation\12 Sic 'Em On A Chicken.mp3
9/11/2011 12:56:29 PM MusicLobby Cmd[PlayTrack] Param[\\BETA-PC\Good\Zac Brown Band\The Foundation\12 Sic 'Em On A Chicken.mp3] Options[]
9/11/2011 12:56:29 PM Sound Stopped Event on Player [0]
9/11/2011 12:56:29 PM LogAudioError: ERR_INVALID_FILE -6 Invalid sound file
9/11/2011 12:56:29 PM PlayTrack Error - Cannot load file \\BETA-PC\Good\Zac Brown Band\The Foundation\12 Sic 'Em On A Chicken.mp3
9/11/2011 12:56:29 PM SoundDoneEvent
9/11/2011 12:56:30 PM [1] Ping
9/11/2011 12:56:35 PM [1] Ping
9/11/2011 12:56:40 PM [1] Ping

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Music Lobby scrolls thru, but doesn't play

Postby Art Dustman » Sun Sep 11, 2011 12:21 pm

After a ram upgrade this week, I am going to update this PC to Win 7/64. So whatever "may" be the issue might get resolved in the process. Seems to me it almost be a bad sound driver or corrupt codec. The audio card still processes the streaming content over UDP right?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: Music Lobby scrolls thru, but doesn't play

Postby CinemarDave » Mon Sep 12, 2011 11:30 am

Yes I would suspect a sound card driver getting confused because at this point in playback the sound components are using DirectX to play the song. See what upgrading the OS brings.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Music Lobby scrolls thru, but doesn't play

Postby Art Dustman » Sat Sep 17, 2011 11:21 am

Well. that seemed to fix the "scroll thru" issue. What I haven't figured out is how to MAKE the client svc or whatever controls the audio source use my SPDIF output. It's all setup a default in windows, media player works fine, windows sounds are fine, but when music plays, the VU meter in my volume mixer shows music on this client playing on the analog output "speakers." When I test speaking on the client svc, she speaks on the SPDIF. Is there a setting somewhere that needs to be changed?

Note: while it was a clean install, I moved my entire "cinemar" folder into this client so I didn't have to rewrite all my custom screens.

Art Dustman
Expert
Expert
Posts: 576
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact:

Re: Music Lobby scrolls thru, but doesn't play

Postby Art Dustman » Sat Sep 17, 2011 11:45 am

Ok Dave... That was it. Client working now. Something corrupt in the "cinemar" folder. Loaded another client's backup and it works fine. But where could it be?


Return to “MusicLobby 3.75”

Who is online

Users browsing this forum: No registered users and 1 guest