iPhone won't display some images - resolved

Forum for discussing building user interfaces for controlling MLServer using the iPhone or iPod Touch.
Andyt
Newbie
Newbie
Posts: 13
Joined: Mon Apr 26, 2010 4:57 am
Contact:

iPhone won't display some images - resolved

Postby Andyt » Wed May 05, 2010 7:19 am

Hi all,
 
I’ve almost got my iPhone working with the webserver pages, just have a problem displaying images on the phone.  When I go to the index.html and browse movies, it works fine on Safari from any PC’s on the network, but when I use the page on the iPhone, the DVD cover pictures are blank. My security cam shows ok but musiclobby pages show no pictures either.
 
After investigating I found a problem here.. when I click the URL below on the phone, it says safari cannot display the page, but it works fine on any networked PC’s

http://halserver:6246/Cache/5201802004097_65x95.jpg
 
Is it something to do with image cache?
 
 
Anyone help please?
 
Thanks
 
 
Last edited by Andyt on Wed May 05, 2010 3:28 pm, edited 1 time in total.

bigDvette
Expert
Expert
Posts: 718
Joined: Thu Oct 12, 2006 12:19 pm
Contact:

Re: iPhone won't display some images

Postby bigDvette » Wed May 05, 2010 11:25 am

It is most likely a problem with your router configuration and port 6246.

Is the iphone using wifi inside your home network or are you using the cellular data connection or wifi oustide your home?

Since you can get to the MLServer iphone pages, it shouldn't be a problem with resolving the IP address. I'm assuming you are outside of your home network with your iphone since I have found as long as your iphone can get the pages inside your network and other PCs can see images, the iPhone should work also.

So, if you are using your iPhone outside your home network, then you need to go open port 6246 on your router. The best way to set this up if you are using this outside your home is to setup a VPN connection in to the house so everyone can't mess with your MLServer instance.

Andyt
Newbie
Newbie
Posts: 13
Joined: Mon Apr 26, 2010 4:57 am
Contact:

Re: iPhone won't display some images

Postby Andyt » Wed May 05, 2010 12:12 pm

UPDATE - I insalled the latest dvdlobby plugin and it works ok now. Now I'm off to check musiclobby.

---




Hi,

thanks for the reply. Actually no, the phone is on the house wifi. I'm pointing directly to 192.168.1.181:85/index.html which works fine.

On any networked PC, if I go to
http://192.168.1.181:6246/Cache/5039036 ... 0x300F.jpg
it works fine.

but pulling that URL on the phone after a long delay it says safari cant open the page.

if I go to the movies.html the page comes up and I can click a file and see the writing, just not the pictures. Also the same for musiclobby. However, security cams do appear - although these are on port 80.

agh!


Return to “iPhone / iPod Touch Beta”

Who is online

Users browsing this forum: No registered users and 1 guest