Error: Reference Missing, Deleting track (2055 etc

Discussions for the iTunes Music Interface
User avatar
jonreid
New Member
New Member
Posts: 28
Joined: Wed Feb 27, 2008 5:45 am
Contact:

Error: Reference Missing, Deleting track (2055 etc

Postby jonreid » Thu Oct 23, 2008 8:04 pm

I have just updated to itunes 8.0.1.11
MLitunes Agent V1.0.0.2146
Itunes plugin V1.0.0.1518

All are working
When i start it all the itunes no songs appear in the list in mainlobby, i fixed that by verifying the database.
When i did verify the db afer adding all the new track it then gives a message Error: Reference Missing, Deleting track (2055 etc) and deltes all the tracks.
So when you click on anu itunes file in mainlobby the details are 100% another song and album, thus adding song toplay do not work.

I have reloaded the databases by deleting and then re running no luck.

Please can someone help, this all was working fine in the previous version.
Development for Progress

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: Error: Reference Missing, Deleting track (2055 etc

Postby ronsatter » Fri Oct 24, 2008 7:25 pm

jonreid wrote:I have just updated to itunes 8.0.1.11
MLitunes Agent V1.0.0.2146
Itunes plugin V1.0.0.1518

All are working
When i start it all the itunes no songs appear in the list in mainlobby, i fixed that by verifying the database.
When i did verify the db afer adding all the new track it then gives a message Error: Reference Missing, Deleting track (2055 etc) and deltes all the tracks.
So when you click on anu itunes file in mainlobby the details are 100% another song and album, thus adding song toplay do not work.

I have reloaded the databases by deleting and then re running no luck.

Please can someone help, this all was working fine in the previous version.


I'm having similar problems. Whenever you try to rebuild the database, it shows the "Reference Missing" error and screws up the whole plugin. I even tried a fresh install of iTunes app without any songs, then imported a single album to test the iTunes agent again ... but no luck. It's definitely broken as far as I can see.

Here a couple of screenshots of the agent log. Fig 1 just "Error Logging". Fig 2 "Verbose Logging" It shows what happens when you attempt to "Verify Database".

Ron :(
You do not have the required permissions to view the files attached to this post.
If it ain't broke ... don't fix it!


Return to “iTunes”

Who is online

Users browsing this forum: No registered users and 1 guest