errors in tmt agent. cant play movies.

Discussions around plugins that interact with Software DVD Players
donburkard
Expert
Expert
Posts: 595
Joined: Sun Apr 13, 2008 7:06 pm
Location: Downingtown, PA
Contact:

errors in tmt agent. cant play movies.

Postby donburkard » Sun May 08, 2011 8:45 pm

When i push play all i get in the tmt agent is
playfile~Z:\Action-Adventure\10000_BC.iso
processcommand:error at line #880-invalid procedure call or argument

in the mlserver log i get
/8/2011 9:29:58 PM Processing (3) myClient4 SetVariable|media_{{clientname}}_transport_source~MLArcSoftTMT
5/8/2011 9:29:58 PM Subst In myClient4 media_{{clientname}}_transport_source~MLArcSoftTMT
5/8/2011 9:29:58 PM Subst Out myClient4 media_myClient4_transport_source~MLArcSoftTMT
5/8/2011 9:29:58 PM Processing (3) myClient4 MLDVDLobby|MakeSource~{{media_{{clientname}}_transport_source}}
5/8/2011 9:29:58 PM Subst In myClient4 MakeSource~{{media_{{clientname}}_transport_source}}
5/8/2011 9:29:58 PM Subst Out myClient4 MakeSource~MLArcSoftTMT
5/8/2011 9:29:58 PM Processing (3) myClient4 AV.AS{{media_{{clientname}}_activeplayer}}|PlayFile~Z:\ACTION-ADVENTURE\10000_BC.ISO
5/8/2011 9:29:59 PM Subst In myClient4 AS{{MEDIA_{{CLIENTNAME}}_ACTIVEPLAYER}}
5/8/2011 9:29:59 PM Subst Out myClient4 AS2
5/8/2011 9:29:59 PM Processing (1) myClient4 SetScene|currentscene=Movies\Movies_Console_Details.mls~currentoverlay=Movies\Movies_Layer_Thumbs_2x6.mls~currentoverlay2=Movies\Movies_Layer_Cancel_Nav.mls
5/8/2011 9:29:59 PM Processing (1) myClient4 Macro|MLDVDLobby|InitDetails~200~300!MLDVDLobby|InitSimilar~18~200~300~130~195
5/8/2011 9:29:59 PM Processing (2) myClient4 MLDVDLobby|InitDetails~200~300
5/8/2011 9:29:59 PM Processing (2) myClient4 MLDVDLobby|InitSimilar~18~200~300~130~195
5/8/2011 9:29:59 PM Processing (1) myClient4 SetScene|currentscene=Movies\Movies_Console_Details.mls~currentoverlay=Movies\Movies_Layer_Thumbs_2x6.mls~currentoverlay2=Movies\Movies_Layer_Detail_Nav.mls
5/8/2011 9:29:59 PM Processing (1) myClient4 Macro|SetVariable|dvdcurrentselection_tab_{{clientname}}~synopsis!SetVariable|dvdcurrentselection_displaytext_{{clientname}}~{{dvdcurrentselection_overview_{{clientname}}}}
5/8/2011 9:29:59 PM Processing (2) myClient4 SetVariable|dvdcurrentselection_tab_{{clientname}}~synopsis
5/8/2011 9:29:59 PM Subst In myClient4 dvdcurrentselection_tab_{{clientname}}~synopsis
5/8/2011 9:29:59 PM Subst Out myClient4 dvdcurrentselection_tab_myClient4~synopsis
5/8/2011 9:29:59 PM Processing (2) myClient4 SetVariable|dvdcurrentselection_displaytext_{{clientname}}~{{dvdcurrentselection_overview_{{clientname}}}}
5/8/2011 9:29:59 PM Subst In myClient4 dvdcurrentselection_displaytext_{{clientname}}~{{dvdcurrentselection_overview_{{clientname}}}}
5/8/2011 9:29:59 PM Subst Out myClient4 dvdcurrentselection_displaytext_myClient4~

in dvdlobby i get
/8/2011 9:29:32 PM ProcessCommand - Cmd=[MakeSource] Param=[MLArcSoftTMT] Client=[myClient4] Index=[0]
5/8/2011 9:29:33 PM ProcessCommand - Cmd=[InitDetails] Param=[200~300] Client=[myClient4] Index=[0]
5/8/2011 9:29:33 PM ProcessCommand - Cmd=[InitSimilar] Param=[18~200~300~130~195] Client=[myClient4] Index=[0]
5/8/2011 9:29:42 PM ProcessCommand - Cmd=[InitBrowser] Param=[Thumbs~12~200~300~130~195] Client=[myClient4] Index=[0]
5/8/2011 9:29:45 PM ProcessCommand - Cmd=[SetActiveThumb] Param=[4] Client=[myClient4] Index=[0]
5/8/2011 9:29:45 PM ProcessCommand - Cmd=[GetMovie] Param=[35405~1] Client=[myClient4] Index=[0]
5/8/2011 9:29:45 PM SetMovieVars - 35405/1 from myClient4
5/8/2011 9:29:46 PM SetMovieDiscVars - 35405/1 from myClient4
5/8/2011 9:29:46 PM ProcessCommand - Cmd=[InitDetails] Param=[200~300] Client=[myClient4] Index=[0]
5/8/2011 9:29:46 PM ProcessCommand - Cmd=[InitSimilar] Param=[18~200~300~130~195] Client=[myClient4] Index=[0]
5/8/2011 9:29:58 PM ProcessCommand - Cmd=[PlayMovie] Param=[35405~1] Client=[myClient4] Index=[0]
5/8/2011 9:29:58 PM PlayMovie - 35405 from myClient4
5/8/2011 9:29:58 PM SetMovieVars - 35405/1 from myClient4
5/8/2011 9:29:58 PM SetMovieDiscVars - 35405/1 from myClient4
5/8/2011 9:29:58 PM ServerCommand - Macro|SetVariable|media_{{clientname}}_transport_source~MLArcSoftTMT!MLDVDLobby|MakeSource~{{media_{{clientname}}_transport_source}}!AV.AS{{media_{{clientname}}_activeplayer}}|PlayFile~Z:\ACTION-ADVENTURE\10000_BC.ISO
5/8/2011 9:29:58 PM ProcessCommand - Cmd=[MakeSource] Param=[MLArcSoftTMT] Client=[myClient4] Index=[0]
5/8/2011 9:29:59 PM ProcessCommand - Cmd=[InitDetails] Param=[200~300] Client=[myClient4] Index=[0]
5/8/2011 9:29:59 PM ProcessCommand - Cmd=[InitSimilar] Param=[18~200~300~130~195] Client=[myClient4] Index=[0]

the file path and everything is correct but what is error at line 880? i dont get it. Dave fixed me up so i could play a movie after i migrated to tmt and a few months later im back to square one. nowhere. I cant get these commands right to save my life. Is there just a BASIC "PLAY THIS ONE" command i can put on the play button in the movies_console_details.mls? for some reason, im not sure why, but whatever you did Dave, did not stick. Its not like i have a very big system. I have two unraid towers, a dedicated mlserver, an htpc, and a touchscreen laptop. nothing fancy but man oh man do i ever have a problem with these commands. Please, Anyone, Start shooting play commands for me to try [-o<

thanks
Hooked on HighDef

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: errors in tmt agent. cant play movies.

Postby CinemarDave » Mon May 09, 2011 11:55 am

On line #800 it is trying to launch daemon tools to mount the .iso file for playback. Look at your daemon tools setup in the agent. Everything ok with the path to daemon tools? Is it set to use the correct logical drive letter? There is nothing wrong in MLServer to DVDLobby. Everything points to daemon tools.

donburkard
Expert
Expert
Posts: 595
Joined: Sun Apr 13, 2008 7:06 pm
Location: Downingtown, PA
Contact:

Re: errors in tmt agent. cant play movies.

Postby donburkard » Mon May 09, 2011 7:20 pm

yea thats probably because i never told it to look for Daemon tools. #-o #-o #-o

Thanks Dave :oops: once again you are the man and have saved the day.


:shock: im such an idiot
Hooked on HighDef


Return to “Software DVD Players”

Who is online

Users browsing this forum: No registered users and 1 guest