Help with MLPowerDVD Script

Discussions around plugins that interact with Software DVD Players
lyfelyte
Member
Member
Posts: 58
Joined: Tue Apr 25, 2006 10:28 am
Location: Chicago, IL
Contact:

Help with MLPowerDVD Script

Postby lyfelyte » Fri May 09, 2008 11:38 pm

It's been a while since I have done any programming, so I'm rusty. I am trying to get my movies off HD to play. I'm not sure how to enter this script. Specifically when you put the alias in the command. Are you supposed to type in the alias name or number?

On the MLServeCMD line in DVD lobby I have typed the following script:
MLPowerDVD|001~PLAYMOVIE~C:movies\bourne_ultimatum\video_TS\vts_01_0

Am I missing something? Should I put the name of the alias instead of a number? Is my format wrong? Am I supposed to put MLServeCMD in front of the MLPowerDVD command?

Everything from the MLServer to the Plugin Gateway appears to be communicating, but I never see anything appear in the log windows.

Any help would be appreciated.

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Sat May 10, 2008 4:30 am

Here is the default Play Movie command that ships with DVDLobby 3.75

Not sure why you would be wanting to use something different as you can see this command does a lot more than just playing the movie. It sets the transport controls to be for PowerDVD and other variables that are used with the scenes that DVDLobby uses. You can also see the AV.<<alias>>|PlayMovie~<<file>> command which is the basic command.

Macro|SetVariable|media_{{clientname}}_transport_source~PowerDVD!MLDVDLobby|MakeSource~{{media_{{clientname}}_transport_source}}!AV.{{media_{{clientname}}_activeplayer}}|PlayMovie~<<file>>


Return to “Software DVD Players”

Who is online

Users browsing this forum: No registered users and 1 guest